Dolphin crashes when trying to access Samba shares


I have the most recent Tumbleweed installed and have the following problem: I mount my Samba shares RW through smb4k. They appear immediately in Dolphin as usual, and I can access them. However, with the current Dolphin/KDE/Tumbleweed installations, I see only top level directories. As soon as I try to open one of the top level directories, Dolphin crashes (freezes).

Obviously, mounting the shares works without problems: Using Krusader, everything works fine (this is currently my workaround …). I can also access the shares through apps like digikam without problems. I do not know what’s the problem with Dolphin or my procedure … Any help?

I assume this is an issue of Dolphin application, but I do not understand what the root cause could be.



Hm, dolphin should actually use the same means to access those mounted shares as all other applications.
Do you really access the mounted shares via the mount point, or rather use a smb:// URL? (that question is meant for all cases, i.e. also the other applications that work)

Maybe wait for KDE Frameworks 5.38 to be in Tumbleweed (it is already in, but because of other problems no new TW snapshot has been released for a while, the next one should be out really soon now I suppose).

If that doesn’t help, I’d recommend to file a bug report against dolphin (as it apparently works fine with other applications) at if there isn’t one already.

Yes, absolutely sure. By the way, when I access via smb:// URL it works, but I prefer to mount the shares. And dolphin sees the mounted shares, it just freezes/crashes when I try to open them. With krusader it works …

Hm, that’s strange.
If the share is mounted, the contents just appear like normal local files/folders to all applications.
And it’s even more strange that it works with krusader, as this is a KDE Frameworks5 application as well…

Frameworks 5.38 is in the Tumbleweed repo meanwhile, so maybe an update would help as already suggested.
Although I don’t see anything related really in the changelog.

Btw, you write it “freezes/crashes”.
What does it really do now?
If it crashes, can you please provide the backtrace? Maybe there’s a bug report already.

I just tried here on Leap 42.3 (with latest KF5 and dolphin from additional repos), without any problems.

To the @OP,

You should describe in detail what you’re doing including the specific mount command with any flags and locations.
Sometimes the smallest thing might be the cause of a problem.


Yes, understood. Is a bit difficult, though, because I am using smb4k.

I mount the NAS shares via smb4k. Once they are mounted, they immediately appear in dolphin under ‘devices’ (‘Geräte’ in German).

Then, I go to dolphin an click on a share that appeared under “devices”. E.g., I have a share that is called “Music”. When I click on this, dolphin correctly shows the folder structure; there are 8 subfolders in “Music”. I click on a subfolder name, and nothing happens. That is: just nothing. The folder does not open, I do not receive an error message. Dolphin does not react in any way, I can click on whatever I want in Dolphin and it does not work. That’s what I meant with “freeze”. The rest of the system works fine, of course. I have tried to just wait and see what happens, but that did not help as well.

Ok, then I click on the top right corner x to close dolphin, and then the application fades a bit and shows the information “not responding”, and then KDE takes over and I can terminate the session.

I do not know how to provide a backtrace. What would I need to do/install?

Krusader works as it should.



Fyi, I have installed the latest updates of Tumbleweed. The new version 5.48 of KDE Frameworks did not fix the issue.