Dolphin Copy and lost or changed file names

I have just used Dolphin to copy my music directory and subdirectories from a remote NAS running samba to my rebuilt 13.2 x86_64 machine with KDE desktop.

I thought I would check all was OK and found to my horror that some subdirectories and file names have been lost and substitutes such as CL4M6E~W inserted. I panicked a bit but when I used the web based NAS file manager all was as it should be on the NAS.

Please can somebody explain what is going on. I have tens of thousands of files and cannot check them all!!!

Probably incompatible file name formats/characters.

Thanks for the advice. Seems very possible but I did rip one of the problem recordings on the same machine that is showing to problem and it did not have a problem then.

I can identify one problem directory but where do I start looking for solutions?
Thanks again,

Show us the problem ie what names got changed?? At least a sample XYZ got changes to ABC

Yes, how do you think anybody can help you when you do not show even one example about what happens?

Of course I don’t but I am still trying to work out how to do that for the correct version which I cannot see except through browser. Possibly a screen shot will do it. Here are two screen shots one from the NAS showing the directory with the problem example highlighted and one from Dolphin showing how the same directory comes out when copied, ie CL4M6E~W. You will see that it is only one of many similar which have copied OK.


I have no idea if resolution/size will be OK but please instruct me how to improve if not.
Thanks again for your help.
PS tried to post the above and the .png files were not included as you can see. How should I do this please?

Whenever it is possible we use the CLI for showing things. Because it is easy to copy/paste in a post.In your case that would be

ls -l <filename>

of each of the two corresponding filenames.

And those two URLs you posted lead to nothing. They are local to your system and we are not loged in in your system.

When you feel you can not show t hings through a CLI (terminal), which happens sometimes, you can upload an image to and post the link here.

Hi Henk and thanks for the reply. Sorry if I am making hard work of this. The point of my PS was to try and get the screenshots posted. I can easily use CLI to get to the faulty file but I cannot easily use CLI to get to the file on the NAS. That is beyond my ability as NAS directory is not mounted on my machine. I might, after a while, be able to mount using NFS but the screen shot makes it clear. They are in .png image format but I cannot see how to include them here or upload to the above url. What should I do please?

The PNG format is allright in itself. And the openSUSE paste service should be self explaining. In any case I would start clicking on “image” at right top.

BTW, I do not understand the “it is not mounyed”. How can it then be accessed?

I thought it is SAMBA driven. But that also means mounting on the client imho.

OK here I hope are the urls:-


All this is because I have had a major hardware failure and had to rebuild my 13.2 server and the rebuild has brought to light some problems, one of which was that I had not changed the system language to EN-UK after installation. This has now been corrected and was only identified because Thunderbird takes its short date format from the system language setting, not the environment locale setting.

I mention this because I found mention of a Dolphin bug KDE Bug 159241 - dolphin can’t handle files with its filename not correctly encoded with current locale. I wonder if this may be part of the problem. Meanwhile I am re-copying with the locale and system set correctly to see if that makes any difference.

Well, the pictures are allright and can be seen. Only thing is please next time, do not post URLs between HTML tags. First because it is no HTML and second because it is easier to post URLs as such in a post, so we can simply click on them. Use the button with the Globe on it and not the HTML wrapper button.

I assume that it is the selected item in one picture (Cantatas BWV 179, 82 & 159 …) that is malformed to CL4M6E~W.

I have tried to find any peculiarity in that one file name against all the others that are done correctly. I think the & might be a clue. Can you check if the other malformed one also contain an &?

Of course it being Samba, the other side is MicroSoft Windows oriented of which I do not know much. But I should say that even then it should all be UTF-8 encoded Unicode. And when that is the case, no conversion is needed. And nothing depends on any Language or Locale.

BTW, as I said, the Samba share (as I think Microsoft people call these remote mounts) are mounted. Apperently somewhere in /Multimedia.
Check with


Hi Henk,
Many thanks and sorry about the incorrect tags. All new to me but getting there.
You are correct that the directory with the & is the one that failed. I have looked at other failed files and not found another & yet but plenty of characters that might be illegal in windoze.

Since none of the machines is running windoze I had assumed I could avoid the permitted character nonsense but I believe you are correct. I shall now check the detailed settings on the NAS because they are doubtless designed with windoze environment in mind even though running on an embedded linux.

Not sure about the mount. It is the NAS that is running samba server and I can see the share if I use dolphin to look at samba shares on network. I think I would have to do something more to have the samba share mounted wouldn’t I?

Will get back when I have done more work.
Thanks again,

It is rather simple. When it is not mounted, you can not use it. And I suggested you do a


to see what is mounted. So do not argue, but look for yourself if you are correct or I am. And post it, thus I can see I am wrong. I want to see facts and no talking.

And if the NAS is LInux bases, I assume you can configure NFS export on it, that you can then mount as NFS imports. Going from a Linux environment through a Windows one and back to Linux will give you the absolute minimum of features that are common to both :frowning:

Hi Henk, I am not arguing and you are correct. It is just that I couldn’t get the command right for mounting the smb directory on my home directory. I had been trying with Samba share as I had read somewhere it was the way to go. Clearly not!!!
Here is the result of the mount command:-

alastair@linux:~> mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
devtmpfs on /dev type devtmpfs (rw,nosuid,size=4605976k,nr_inodes=1151494,mode=755)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
/dev/sda2 on / type btrfs (rw,relatime,space_cache)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=28,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
/dev/sda2 on /.snapshots type btrfs (rw,relatime,space_cache)
/dev/sda2 on /var/tmp type btrfs (rw,relatime,space_cache)
/dev/sda2 on /var/spool type btrfs (rw,relatime,space_cache)
/dev/sda2 on /var/opt type btrfs (rw,relatime,space_cache)
/dev/sda2 on /var/log type btrfs (rw,relatime,space_cache)
/dev/sda2 on /var/lib/pgsql type btrfs (rw,relatime,space_cache)
/dev/sda2 on /var/lib/named type btrfs (rw,relatime,space_cache)
/dev/sda2 on /var/lib/mailman type btrfs (rw,relatime,space_cache)
/dev/sda2 on /var/crash type btrfs (rw,relatime,space_cache)
/dev/sda2 on /opt type btrfs (rw,relatime,space_cache)
/dev/sda2 on /usr/local type btrfs (rw,relatime,space_cache)
/dev/sda2 on /tmp type btrfs (rw,relatime,space_cache)
/dev/sda2 on /srv type btrfs (rw,relatime,space_cache)
/dev/sda2 on /boot/grub2/x86_64-efi type btrfs (rw,relatime,space_cache)
/dev/sda2 on /boot/grub2/i386-pc type btrfs (rw,relatime,space_cache)
/dev/sda3 on /home type xfs (rw,relatime,attr2,inode64,noquota)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sdb1 on /data type ext4 (rw,relatime,data=ordered)
none on /var/lib/ntp/proc type proc (ro,nosuid,nodev,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime) on /home/alastair/NFS_to_Nas2_MultiM type nfs (rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=,mountvers=3,mountport=30000,mountproto=udp,local_lock=none,addr=

I cannot see an smb mount but as you can see I have now set up NFS which I prefer and it is mounted perfectly.

I am now copying the subject directory again and I hope there will be no windoze snags. It will take a while so I shall post results tomorrow.
Thanks again for your help.

What about this one? on /home/alastair/NFS_to_Nas2_MultiM type nfs (rw,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=,mountvers=3,mountport=30000,mountproto=udp,local_lock=none,addr=

It seems that you use nfs from the NAS.

I thought I had explained in my last message, I set up the NFS AFTER your previous message and all the problem with smb. I have always preferred NFS but it would be good to know why smb falls over. I think you have it with the characters which windoze forbids but smb, I understood, had become truly cross platform. Possibly not with the setup on my Qnap NAS. I shall ask in due course.
Thanks again,

Samba was designed when companies wanted something more stable as file servers then Microsoft’s Server OS. The result was Unix with Samba as file server interface. This emulates Microsoft file serving (and printer serving was also incorporated as a sort of byproduct).

The other part was developed I think because there were people that used Unix systems inside corporations (and could convince their bosses that they realy could not do their task on a Windows system) and that needed access to corporate data on Microsoft file servers.

So these are two different requirements, each with their solution.

Now these two ends can be fitted together, but I have no idea what requirement that solves. In any case the result will have all the negatives of serving MS file systems to a Unix/Linux system, like no Linux/Unix ownership by user and group and no permissions and a few things more. Likewise I assume that things are lost in the other direction.

When you like to call that “cross plaform”, that is up to you. lol!

Hi Henk,
Many thanks for the background info on Samba. I am convinced it is best avoided. Sadly however my confidence that using NFS would solve my problem is only part true. The directory with the & still came across garbled as before. Another directory contents which had been completely garbled now is only half so. The fault is probably with the NAS system but before I waste more of your time I shall start over and try again.