Dolphin access permission display difference 11.2/11.3

I’m using Dolphin 1.5 on KDE 4.5.1 on openSUSE 11.2, 11.3 and 11.4(M1).

I select a folder and right-click to get “properties.” On the “permissions”
tab, I select “advanced permissions.” Up until that moment, everything is
the same on all three versions. Then -

On 11.2, I get a panel sub-headed “access permissions” which has one column
headed “special” which has three buttons. Below that is a panel in which I
can add, edit or delete entries so that I can, say, grant one user special
permissions.

On 11.3 and 11.4, I get a panel with the same heading, “access
permisssions,” but which is very different apart from that. Below the
heading is a table containing 4x3 buttons for setting “user,” “group” and
“others” but no panel such as in 11.2.

This different behaviour occurs for the identical user and folder. I’ve
checked that Dolphin preferences are the same for 11.2 and 11.3. Why am I
getting a less useful display from the later versions of openSUSE?


Graham Davis, Bracknell, Berks. E-mail: “newsman”, not “newsboy”.
“It pays to keep an open mind, but not so open your brains fall out.” - Carl
Sagan
Another Brick in The Wall: http://www.youtube.com/watch?v=OIP38eq-ywc

The difference is likely that the partitions are mounted differently. One is using the acl (access control lists) option and one isn’t.

On Friday 01 Oct 2010 23:36, drab scribbled:

>
> The difference is likely that the partitions are mounted differently.
> One is using the acl (access control lists) option and one isn’t.
>

So the method mounting of partitions has changed from 11.2 to 11.3?

Whatever the cause, it’s a serious problem for me that means I’ll have to
stick with 11.2. Time I raised a bug report.


Graham Davis, Bracknell, Berks. E-mail: “newsman”, not “newsboy”.
“It pays to keep an open mind, but not so open your brains fall out.” - Carl
Sagan

Graham P Davis wrote:

> On Friday 01 Oct 2010 23:36, drab scribbled:
>
>>
>> The difference is likely that the partitions are mounted differently.
>> One is using the acl (access control lists) option and one isn’t.
>>
>
> So the method mounting of partitions has changed from 11.2 to 11.3?
>
> Whatever the cause, it’s a serious problem for me that means I’ll have to
> stick with 11.2. Time I raised a bug report.

I don’t think it has changed. What are the contents of /etc/fstab on each
of those systems?


Don

On Tuesday 05 Oct 2010 13:51, Don Raboud scribbled:

> Graham P Davis wrote:
>
>> On Friday 01 Oct 2010 23:36, drab scribbled:
>>
>>>
>>> The difference is likely that the partitions are mounted differently.
>>> One is using the acl (access control lists) option and one isn’t.
>>>
>>
>> So the method mounting of partitions has changed from 11.2 to 11.3?
>>
>> Whatever the cause, it’s a serious problem for me that means I’ll have to
>> stick with 11.2. Time I raised a bug report.
>
> I don’t think it has changed. What are the contents of /etc/fstab on each
> of those systems?
>

Here’s edited fstabs for 11.2 and 11.3 on the same machine:

11.2:
/dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part6 swap
swap defaults 0 0
/dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part7 /
ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part11 /home
ext3 acl,user_xattr 1 2

11.3:
/dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part6 swap
swap defaults 0 0
/dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part8 /
ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part11 /home
ext3 defaults 1 2

Looks like “drab” has identified the problem. Thanks.

In 11.2, “/home” is using acl but in 11.3 (and 11.4) it is just set at
“defaults”. I see “/” sticks with acl through all systems.

I’ve now edited the fstab entries and the problem with Dolphin is resolved.

Any thoughts on whether this is a bug or a new feature that’s crept in with
11.3 and beyond? I’ll mull over it for a day or so before logging something
in bugzilla.


Graham Davis, Bracknell, Berks. E-mail: “newsman”, not “newsboy”.
“It pays to keep an open mind, but not so open your brains fall out.” - Carl
Sagan

Graham P Davis wrote:

> > Here’s edited fstabs for 11.2 and 11.3 on the same machine:
>
> 11.2:
> /dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part6 swap
> swap defaults 0 0
> /dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part7 /
> ext4 acl,user_xattr 1 1
> /dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part11 /home
> ext3 acl,user_xattr 1 2
>
> 11.3:
> /dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part6 swap
> swap defaults 0 0
> /dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part8 /
> ext4 acl,user_xattr 1 1
> /dev/disk/by-id/ata-Hitachi_HDT725050VLA360_VFK411R4DX2JKL-part11 /home
> ext3 defaults 1 2
>
> In 11.2, “/home” is using acl but in 11.3 (and 11.4) it is just set at
> “defaults”. I see “/” sticks with acl through all systems.
>
> I’ve now edited the fstab entries and the problem with Dolphin is
> resolved.
>
> Any thoughts on whether this is a bug or a new feature that’s crept in
> with 11.3 and beyond? I’ll mull over it for a day or so before logging
> something in bugzilla.

I don’t remember what the installation default is, but I have just
“defaults” for /home in both 11.2 and 11.3 and I don’t recall making any
changes in either.

Are you sure you didn’t change the mounting option at some point in 11.2
yourself?


Don

On Wednesday 06 Oct 2010 20:23, Don Raboud scribbled:

> I don’t remember what the installation default is, but I have just
> “defaults” for /home in both 11.2 and 11.3 and I don’t recall making any
> changes in either.
>
> Are you sure you didn’t change the mounting option at some point in 11.2
> yourself?

I wouldn’t know how without editing fstab by hand and this is the first time
I’ve done that! It also seems unlikely to me that I could have somehow
changed the settings for 11.2 on two machines and then not done the same for
11.3 and 11.4. Mind you, stranger things have happened to me.


Graham Davis, Bracknell, Berks. E-mail: “newsman”, not “newsboy”.
“It pays to keep an open mind, but not so open your brains fall out.” - Carl
Sagan