Dolphin 1.5 hangs in KDE 4.5

Since I’ve upgraded to KDE 4.5 on openSUSE 11.3 i am getting some instances of Dolphin hanging or lagging when navigating directories or opening files. Anyone else getting this?

Yes, I noticed the same issue since my upgrade to KDE 4.5. So, I just switched to Konqueror instead. I created two menu entries, one as a normal file system user and the other as a Super User.

Standard File Manager Using Konqueror:

kfmclient openProfile filemanagement

and as Super User:

kdesu kfmclient openProfile filemanagement

I decided to go Konqueror All the way…

Thank You,

I noticed the same hanging of about 10 seconds sometimes, by the way, in konqueror now lack the files filter bar (like in 3.5), do you know if it is possible to have that back again?? that filter bar was very useful and I started to use dolphin only after that filter bar was introduced.
Konqueror All the way with filter:-)

This bug was driving me crazy up until a few minutes ago, when some googling revealed it can be fixed by turning off Pop Up Notices for File transfers and other jobs in the Notifications Settings. Dolphin seems to be behaving properly again. It kinda sucks though, as this is the first release where I found the system tray’s implementation of tracking file transfers to actually be useful. Ah well, fingers crossed for 4.5.1.

Edit: It would appear I spoke too soon. ::head-desk:: KDE’s bug-tracker shows numerous reports of this issue. You would think in a feature release with 16,000 bug-fixes, something as critical as this would be one of them. :frowning:

I actually installed Konqueror 3.5 and have an icon pointing to it. Dolphin still crashes and hanging for me in many cases so I resort to Konqueror 3.5. Amazing the difference how much faster it is, but I guess we’ll get there eventually.

Following suite with the first reply, i switched file managers. I tried Konqueror but then i went to Krusader and Midnight Commander. I liked Midnight Commander a lot but Krusader was a little more user friendly for me and i like it as well and it seems to be working very well. :slight_smile:

I’m frustrated with KDE 4.5 Dolphin. It’s so unstable it’s unusable. I turned off all desktop effects, and pop up notifications and it still goes out to lunch for 10-15 seconds at a time randomly for no apparent reason. Just sitting open in a directory that has no activity going on it will occasionally crash without even touching it.

At this point, I’m sorry to say, I’ve switched to Nautilus. Some features I like are missing, but I’ll take a stable reliable file manager over eye candy and feature overload any day.

You do know that 4.5 is still very much beta in OpenSuse?? Why would you expect it to be stable?

Because the same issues occur in the “Stable” release of 4.4.4 under 11.3. I was hoping it actually got fixed.

glad to read this thread as i was beginning to think it was just me

I have had no trouble at all.

i did a re-install at the w/e to try to get to the bottom of this problem. straight re-install of 11.3 no problems, update to kde 4.5 still no problems but after installing the nvidia driver - i then get dolphin hanging and crashing, especially if i am copying files and have a split window view. going back to 4.4 solves the problem.

intel dual core system, 6 gb of ram & nvidia video card - opensuse 11.3 64 bit

have you tried switching off both items in ‘System Settings’ – ‘Window Behaviour’ – ‘Screen Edges’ – ‘Window Management’ ?

Not only is Dolphin hanging, it’s crashing by just browsing folders. I’ve heard of this happening in earlier releases, but this is the first time I’ve experienced it. I’ve switched to Konqueror.

Those having problem I assume all use NVIDIA. Did you use nomodeset option for kernel? Otherwise you will still be using the nouveau driver.

With Intel graphics the problem is the same. So I am much more convinced that it is more a backend problem than a graphics problem

I manage quite some machines with NVIDIA cards (from 5* series AGP upto latest) and have not been able to reproduce this behaviour.


Same problem here, very unstable, especially split view. Using bug reporting assistant it suggests this is a duplicate of this fixed bug which is still getting reports…

I do have nomodeset option set in the kernel. The screen does seem very different feeling than it used to using the NVIDIA driver. How do I tell if it’s actually using the NVIDIA proprietary driver and not the Nouveau driver?

I’m using an NVIDIA Quadro FX1400 if that makes any difference.