Does your pwmconfig find modules and run?

Hi there,

I have logged a bug, but I wanted to know if you run


from konsole is it working?

I get the error

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

But I am using the same machine, same hardware as in 10.3 and I have no problem running it in 10.3. I even copied my 10.3’s pwmconfig binary to 11.2 and I get the same error.

I wonder if you guys get the problem? If yes maybe there is a problem in the package or libs.

I use 64-bits, but would like to know also for 32-bits if it works.

I use FANCONTROL, so when I copied my file to /etc and tried to run fancontrol, it told me it was too old and run pwmconfig and that’s when I got the error. Running SENSORS shows that I seem to have everything in place. Hum, just realized I am missing the bridge temperature and 4-5 voltages… that’s weird…

m8@oskde64:~> fancontrol
Loading configuration from /etc/fancontrol ...

Common settings:

Settings for hwmon0/device/pwm1:
  Depends on hwmon0/device/temp1_input
  Controls hwmon0/device/fan1_input   
Settings for hwmon0/device/pwm2:
  Depends on hwmon0/device/temp2_input
  Controls hwmon0/device/fan2_input   

Configuration is too old, please run pwmconfig again
m8@oskde64:~> sensors                                         
Adapter: ACPI interface                                       
Vcore Voltage:      +1.22 V  (min =  +0.85 V, max =  +1.60 V) 
 +3.3 Voltage:      +3.30 V  (min =  +2.97 V, max =  +3.63 V) 
  +5 Voltage:        +4.87 V  (min =  +4.50 V, max =  +5.50 V) 
 +12 Voltage:      +11.98 V  (min = +10.20 V, max = +13.80 V)
CPU FAN Speed:      856 RPM  (min =  600 RPM)
CHASSIS1 FAN Speed:1081 RPM  (min =  600 RPM)
 CHASSIS2 FAN Speed:1081 RPM  (min =  600 RPM)
CHASSIS3 FAN Speed:1110 RPM  (min =  800 RPM)
CPU Temperature:    +27.0°C  (high = +60.0°C, crit = +95.0°C) 
MB Temperature:     +33.0°C  (high = +45.0°C, crit = +95.0°C) 
Adapter: ISA adapter
Core 0:      +42.0°C  (high = +82.0°C, crit = +100.0°C)

Adapter: ISA adapter
Core 1:      +43.0°C  (high = +82.0°C, crit = +100.0°C)

Adapter: ISA adapter
Core 2:      +34.0°C  (high = +82.0°C, crit = +100.0°C)

Adapter: ISA adapter
Core 3:      +39.0°C  (high = +82.0°C, crit = +100.0°C)

Oh god… FAQ/Chapter3 – lm-sensors

I think I know why, now. I have that atk0110 driver, but I don’t know if I get those errors, I’ll have to dmesg | grep ‘xxx’. I have to check tonight.

I’ll try their fixes, though I have no idea how to enable a driver in the kernel…

But I am happy somewhere on the web they talk exactly about my problem with my hardware. :slight_smile:

Does anyone else use ASUS MB? Can you check that as well? My hardware is 2 years old. Check my signature.

I wish I could edit my subject on original post, but I have no button to do so.

I fixed this thing. Actually I worked around it. Surprisingly enough, there is quite a lot of information on the web if you take time to search. And very recent info, like in the past few days!

I am sure some other people use ASUS motherboards, right? The P5K* series, for example, but some other ASUSes are affected as well.

So the link in my previous post is a GREAT start to understand what’s going on and what to do to fix/work around it.

One other very good thread is this [Bug 13967] New: Revert "ACPICA: Remove obsolete acpi_os_validate_addres]( These people are devs for lm-sensors.

Why since kernel 2.6.31 you get problems with fancontrol or pwmconfig does not run due to pwm-capable modules not loaded? It’s due to ACPI. They fixed something in lm-sensors so that the sensors don’t get hit on the same port as the ACPI hits them, but that causes problems for some ASUS MBs. Like the P5K series.

Work around for OLDER ASUS boards (older than when? No one mentioned, but MBs of 2007 are considered old, and I guess half of 2008 as well): in your ‘menu.lst’ (or grub.conf for other distros), after ‘showopts’, add the folliwing option: ‘acpi_enforce_resources=lax’. Reboot. Then run ‘sensors’. You should see more sensors than before. Run ‘pwmconfig’ and it should work. It’s possible it will fail to test control the fans, but let it create ‘fancontrol’ file and edit it. You can play with the ‘hwmonN’ values, changing ‘hwmon0’ for ‘hwmon5’, for example. For me the atk0110 driver had to be set to hwmon0 and all of the fans sensors to hwmon5. And fancontrol will now work. I am sure you can get the right number with some ‘cat’ and ‘ls’ queries, but I don’t know which ones.

You can also check my bug (closed):

For newer boards (2009+ or 2008.5+, not sure), I am unsure of what to do. It needs to use the ACPI, cuz the kernel parameter opens the door to potential conflicts between sensors and ACPI and this could damage your hardware or freezing up your software. But if you want to risk yourself in, you can use the parameter. It’s been reported that some boards are not affected at all by the parameter, that it seems to have no effect on them (so fancontrol and pwmconfig still don’t work), but I don’t have much information.

Hope that helps anyone.