Does ssh installation still work with 13.2 (and grub2)?

I have a headless server on which I want to do a clean install of 13.2 instead of using “zypper dup”. Setting up a ssh install with grub (legacy) used to be very easy, but before reading enough grub2 documentation to set it up on my own I wanted to make sure that “bit rot” had not broken this very useful installlation technique like it has broken so many other things on openSUSE. If other people have used it with 13.2, then I will be quite happy to RTFM and do it all myself, but if the feature is broken then it will be very inconvenient to put a monitor on the server in order to put things right.


on a home network, ssh was found to perform ok with upgrade to 13.2/Tumbleweed

13.2 has different security to 13.1/factory, indicated in user notes

some old links worked ok but new connections led to ‘connection refused’
before tweaks to files /etc/ssh/ssh_config and sshd_config and establishing new keys

its concluded, on a new install there would not be any established keys hence,
establishing an ssh to the headless server would not be possible

is the conclusion correct?

I’m not quite sure how it is related to grub or grub2. To enable SSH during instalation one needs to pass kernel parameters which is of course possible with both grub and grub2. Whether 13.2 installer supports ssh is another question - I do not know.

The reason grub2 matters is because I have not had a reason to read the grub2 documentation before now, and do not want to bother with it if the 13.2 installer no longer supports ssh installs. (I know that is just being lazy, but the reason I am forced to use grub2 is because the bootloader maintainer is too lazy to support grub legacy anymore.)

The installer itself boots using “syslinux” on MBR based hardware, or grub2-efi on UEFI systems. This is not a change from booting earlier installer versions. So grub2 shouldn’t matter for how you install.

As to support for grub legacy – I think that was a decision by the Yast maintainers. They dropped the Yast module for grub legacy. But manual installing without Yast should still work as far as I know.

I think you have created a rather unique situation for yourself I doubt there are many that have tried it. Best to RFM

You are welcome to step in.

I’m guessing that he might be right that supporting grub legacy is too much work to bother with, it’s just that reading all that grub2 documentation just to install on a single machine once a year is too much work to bother with too! (All my other machines have monitors, and are already up and running 13.2 very happily.) I was hoping someone would know of a step by step howto like the one I used to learn how to do it with grub legacy all those years ago. (I am even lazier then he is!)

I don’t see what the problem here is, the 13.2 ssh install works just as it did previously.

You configure your PXE server to boot with suitable parameters, with usessh=1, password, hostip, gw etc. and then ssh to the box with root@ip, yast.ssh and boom boom pow.

Above image running in VMWare vSphere 5.5 + PXE booting from another ESX VM instance.

Thank you! That’s all I really needed to hear – whether it still worked or not. I didn’t want to go to all the work of setting it up if in the end I still needed to hook the machine up to a monitor in order to fix what I broke trying to do it learn how to do myself.

However, there is a catch that I know existed in 13.1 as well - if the installation fails for ANY reason or repository cannot be found etc. it will drop the system into a text mode and refuse all SSH connections but you can naturally restart the install by power cycling the server.

I chickened out and did an upgrade using “zypper dup” instead. Surprise, surprise, yast changed the traditional if-up networking to wicked and after reboot the machine was unreachable. This is due to the fact that there are two ethernet cards, one gigabit which I use, and a builtin 100Mbps which was not connected to anything. I connected an old DSL router to the onboard ethernet card, and the computer finished booting, and the network came up; I ssh’ed in and used yast textmode to configure the network properly (yast has always preferred the onboard ethernet card which leads to nowhere as the default route!); and now all my computers are happily running 13.2. It would have taken me most of today to get a clean install configured properly even if I did not have to lug a display over the computer to install it, so I guess “zypper dup” saved me a lot of time … but openSUSE has gotten so sloppy with their upgrade of local configurations, that I really would have preferred a clean install.