Does Plasma 5.20 really support Wayland and nvidia?

I keep reading that Plasma 5.20 fully supports Wayland but all I get when I choose a Wayland session is a black screen with a small horizontal line in the upper left corner of my display. I can’t find any way out of this without rebooting. I’m using the 455.28 driver.

Is there a setting I need to change or some different Wayland packages I need?

NVIDIA? Ignore Wayland.

News I’ve been reading is that Plasma 5.20 is supposed to include plenty of new support for Wayland. IIRC some specific items include rendering certain widgets and toolbars (panels?), maybe some menus. In other words, Desktop objects in general.

But,
The proprietary nVidia driver currently may have problems, and in particular won’t work with kernel 5.9.
Recommendation is to boot with a 5.8 kernel until a working driver is provided, current estimation sometime last half Nov.

TSU

Wrong as usual. The only part that won’t work is CUDA which was disabled for TW since 5.8 kernel anyway.

Hello,

I would not use KDE+Wayland+Nvidia.
https://community.kde.org/Plasma/Wayland_Showstoppers

1 Like

Thanks for the link. Do you know what “It requires setting the KWIN_DRM_USE_EGL_STREAMS=1 environment variable to activate.” means? How does one set this?

I’m using 5.8.15-1-default kernel.

https://community.kde.org/Plasma/Wayland/Nvidia

Hello,

I don’t use KDE.
I hope this helps you:
http://blog.davidedmundson.co.uk/blog/running-kwin-wayland-on-nvidia/

If I add nvidia-drm.modeset=1 to the kernel parameters, the nvidia driver doesn’t load. If I choose a Plasma/Wayland session, I get the llvmpipe Mesa graphics which runs my display at 4K and everything seems to work OK but scrolling is a little jerky in Firefox.

I also created the file kwin.sh in /etc/profile.d and made it executable.

When I tried the recommended command

cat /sys/module/nvidia_drm/parameters/modeset

I’m supposed to get Y but I get N. Of course because the nvidia driver isn’t loaded.

I thought I had to use nomodeset in order to load the nvidia driver. The nvidia-drm.modeset=1 parameter isn’t working for me.

Edit: The cat /sys/module command returns N even with the nvidia 455.28 driver running, probably because of the default nomedeset kernel parameter but that’s the only way I can get it to load.

Maybe a bit off-topic, but there is no reason to make things in /etc/profile.d executable for anybody. Where have you read that that should be done?

The first time I tried it without being executable, and when that didn’t work, I tried it the other way.

OK, I do not to want to interfere with your way of working, but do you understand why it is not needed (or maybe is needed) or are you just experimenting with try and error? Do you understand what the colloquial expression (making/being executable" stands for (as usual it does express very badly or not all all with what is really done)?
No answers needed, this off-topic will only consume time and not help you with your problem I guess.

Hi
No, nomodeset is to disable KMS, the loading of the nouveau (in your case), used at boot if the nvidia card has issues with the nouveau driver until you can install the proprietary one. The nouveau is blacklisted?

Your installing the driver the hard way by the looks.

Nouveau is blacklisted. If I remove nomodeset from the kernel parameters, the nvidia driver doesn’t load. Yes, I install the driver the hard way.

Hi
So what model card?


/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

GTX 1060 PCIe SSE2

Edit: Using the recommended command, the output says kernel modules: nouveau, nvidia_drm, nvidia. Not sure where nouveau is coming from.

Hi
I need to see the output, want to see what it’s using :wink:

09:00.0 **VGA** compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1) 
        Subsystem: ASUSTeK Computer Inc. Device [1043:85ab] 
        Kernel driver in use: nvidia 
        Kernel modules: nouveau, nvidia_drm, nvidia

Hi
And you have the libnvidia-egl-wayland.so* files installed? And you removed the nomodeset?


cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT

I have the libwayland-egl1 package installed. Nomodeset was added by me to the kernel parameters. Without it, the nvidia driver doesn’t load. The output I posted above is when booting with nomodeset.