Does openSUSE repositories have VLC 1.1.0?

I saw that VLC 1.1.0 added GPU decoding! What repository can I use in YAST to upgrade to this version?

Packman does, I have

kernelcruncher@linux-ozls:~> rpm -qi vlc
Name        : vlc                          Relocations: (not relocatable)
Version     : 1.1.0                             Vendor: http://packman.links2linux.de
Release     : 2.pm.12.7                     Build Date: Mon 07 Jun 2010 18:06:11 BST
Install Date: Fri 18 Jun 2010 14:22:19 BST      Build Host: nott
Group       : Productivity/Multimedia/Video/Players   Source RPM: vlc-1.1.0-2.pm.12.7.src.rpm
Size        : 2082638                          License: GNU General Public License (GPL)
Signature   : DSA/SHA1, Mon 07 Jun 2010 18:07:33 BST, Key ID f899f20d9a795806
Packager    : detrei@links2linux.de

Not for opensuse 11.1 on packman…

Try changing your repo, you may have one of the non-updated ones

Index of /suse/11.1

Just one question about the Packman repo: Why are there, at least, two different packman repositories with two different urls and different packages (version)??
Currently I’m using this one (added from yast community repos):
(http://ftp.skynet.be/pub/packman/suse/11.2/)

I just realized I’m not using that some people is talking about when tried to upgrade vlc to the 1.1 version (http://packman.unixheads.com/suse/11.2/i586/). Mine still has the 1.0.

Are those servers working under the same repo’s name but with different offer??
I really need to get out of this confusion :\

That repo is out of date
replace it with the one I quoted.

If you don’t know how, post your list ( zypper lr -d ) and I’ll give you the code instructions.

I would register the new one and then switch my packages to it.
There are many pics around showing this process isn’t it??

Remove the old one - Add the new one

then

http://tinyurl.com/yejwull

Ok here we go with the conflicts:


#### YaST2 conflicts list - generated 2010-06-23 01:11:30 ####

problem with dialog-1.1-28.2.i586

 ] to do:
uninstall dialog-1.1-28.2.i586
uninstall alsa-utils-1.0.21-3.1.i586
uninstall alsa-1.0.21-3.2.i586
uninstall yast2-sound-2.18.4-1.1.2.1.i586
uninstall yast2-tv-2.18.4-2.8.noarch
 ] keep old dialog-1.1-28.2.i586



problem with libdvdnav4-4.1.3-2.2.i586

 ] keep old libdvdnav4-4.1.3-2.2.i586

 ] uninstall libdvdnav4-4.1.3-2.2.i586



MozillaFirefox-3.6.2-1.2.i586 requires mozilla-xulrunner192 = 1.9.2.2, can't be done
providers removed: mozilla-xulrunner192-1.9.2.2-4.2.i586
 ] to do:
downgrade MozillaFirefox-3.6.2-1.2.i586 to MozillaFirefox-3.5.9-0.1.1.i586
install MozillaFirefox-3.5.9-0.1.1.i586 (provider change)
obs://build.opensuse.org/mozilla -->  openSUSE
 ] install mozilla-xulrunner192-1.9.2.3-1.2.i586 from excluded repos

 ] break MozillaFirefox ignoring dependencies



MozillaFirefox-3.6.2-1.2.i586 requires mozilla-xulrunner192 = 1.9.2.2, but can't be done
providers removed: mozilla-xulrunner192-1.9.2.2-4.2.i586
 ] uninstall mozilla-xulrunner192-gnome-1.9.2.2-4.2.i586

 ] to do:
downgrade MozillaFirefox-translations-common-3.6.2-1.2.i586 to MozillaFirefox-translations-common-3.5.9-0.1.1.i586
install MozillaFirefox-translations-common-3.5.9-0.1.1.i586 (provider change)
obs://build.opensuse.org/mozilla -->  openSUSE
 ] install mozilla-xulrunner192-gnome-1.9.2.3-1.2.i586 from excluded repos

 ] break MozillaFirefox ignoring dependencies


#### YaST2 conflicts list END ###

I tried to translate the notes from Spanish for your understanding.

I think:

keep old dialog-1.1-28.2.i586

install mozilla-xulrunner192-1.9.2.3-1.2.i586 from excluded repos

keep old libdvdnav4-4.1.3-2.2.i586

I’m just checking libdvdnav4
Because I have libdvdnav4-4.1.3-1.pm

Yes, you need to go to the radio button under version and make sure it’s packman, see this screenshot

http://thumbnails21.imagebam.com/8556/8e2e7385553440.jpg](http://www.imagebam.com/image/8e2e7385553440)

Caf I have just realized that there are different packman mirrors and the one I was using is from Belgium (skynet). Now the funny thing is that I changed it but not exactly with the one you are using which is linux2linux. Mine now is unixheads.

The libdvdnav4 package is available for x86_64 only (I’m i586) so guess that there shouldn’t be any problem to get it from OSS repo.

Anyway the change seems to work well and at least with newer packages.

Thanks again!

Sorry. My i586 laptop is on 11.3 and it has version in the packman factory. That screen was from my _64 machine though.

I have this printout. How do I update to 1.1? When I go into YAST and check under versions, it only lists 1.0.4!

Name        : vlc                          Relocations: (not relocatable)
Version     : 1.0.4                             Vendor: http://packman.links2linux.de
Release     : 0.pm.8.21                     Build Date: Tue 19 Jan 2010 03:16:39 PM EST
Install Date: Wed 20 Jan 2010 11:26:59 AM EST      Build Host: pmbs
Group       : Productivity/Multimedia/Video/Players   Source RPM: vlc-1.0.4-0.pm.8.21.src.rpm
Size        : 1622436                          License: GNU General Public License (GPL)
Signature   : DSA/SHA1, Tue 19 Jan 2010 03:17:25 PM EST, Key ID f899f20d9a795806
Packager    : detrei@links2linux.de
URL         : http://www.videolan.org/
Summary     : VLC - Video Lan Client (preview of the upcoming version)

Change your packman repo, you are probably using one that is not being updated:
Try this one
Index of /suse/11.2

Thanks, but now I’m getting all sorts of errors. For example, it says libvlc5 is required but cannot be provided and same for vlc-noX=1.1.0-2.pm.4.2

What should I do? (Thanks for the help!)

Did we see a list of your repo’s ?

zypper lr -d

Did you do this ever?
http://tinyurl.com/yejwull

When I try to do that, it throws a bunch of errors (libdnav and other stuff).

My repositories:

1  | 11.2 - VideoLan      | 11.2 - VideoLan       | No      | No      |   99     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.2/                            |
2  | KDE_4_Community      | KDE 4 Community       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.2/       |
3  | KDE_4_Stable         | KDE 4 Stable          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2/ |
4  | Libdvdcss repository | Libdvdcss repository  | No      | No      |   99     | rpm-md | http://opensuse-guide.org/repo/11.2/                                                |
5  | NVIDIA Repository    | NVIDIA Repository     | Yes     | Yes     |   99     | rpm-md | ftp://download.nvidia.com/opensuse/11.2/                                            |
6  | Packman_Repository   | Packman Repository    | Yes     | Yes     |   99     | rpm-md | http://packman.unixheads.com/suse/11.2/                                             |
7  | google-chrome        | google-chrome         | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/rpm/stable/i386                                          |
8  | repo-debug           | openSUSE-11.2-Debug   | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.2/repo/oss/                      |
9  | repo-non-oss         | openSUSE-11.2-Non-Oss | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/                        |
10 | repo-oss             | openSUSE-11.2-Oss     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                            |
11 | repo-source          | openSUSE-11.2-Source  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.2/repo/oss/                     |
12 | repo-update          | openSUSE-11.2-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.2/ 

Save the error to a file with the expert button then paste it here