Does ATI repository work now with 11.2?

Just curious as I have not seen any updates on whether it is still broken with 11.2

Last night, I tried to install ATI driver and failed miserably. :frowning:

Whole thing just got corrupted and after couple of hitting power button, the boot partition got corrupted (EXT4… Never had this issue before) and I had to re-install everything.

Now, with bare minimum installation, I want to get ATI driver working before doing anything.

With RadeonHD (which is working right now), for some reason, even with MESA installed, I can not get glxgears to work, it gives me GL error -22.

I want to use fglrx anyways since there are some artifact issues with RadeonHD on my 4670HD.

I had it working nicely in Linux Mint, but for some reason, my DVD burner was not working right on that distro… I will test out my DVD burner when I get home today.

Have you tried using the ati driver from ati? Make sure you have the kernel headers installed first and run it in runlevel 3.
This worked for me on a new install a couple of days ago.

I tried it, but when I ran the install, I got this in the error:
[Error] Kernel Module : Kernel module build environment not found - please consult readme.

LOOKS like this is the issue (I may be wrong…):
linux-oian:/usr/share/ati # rpm -qa|grep kernel
linux-oian:/usr/share/ati # uname -a
Linux linux-oian #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

Notice that linux-kernel-headers-2.6.31-3.4.noarch
and my version of linux is
I think the version difference may have caused the issue. Maybe someone can help me out.

However, I JUST installed the linux header package so I do not know what may be the issue otherwise.

All dev packages are installed as well.

Anyways, I just found out that ATI repository is now working so I just added the repository, then the system just found the newest package, upgraded the package and it is now working fine.

I am HAPPY for now. (I now need to try to burn DVD’s as that was not working well from Mint and Fedora installation so hoping OpenSuse will be fine - The drive was tested fine on Opensuse 11.0 installation so the drive is fine, but who knows…)

Glad you got it working nut is look like you just installed anything that had kernel in the name.

All you needed was the kernel-source that matches your running kernel.

You have mismatched packages and packages for I assume not installed kernels. Unless you installed something different the normal kernel flavor is desktop. And of course the version number must match.

If you want to use the ati install from ati, make sure you have uninstalled the ati rpm from the repo first or it will fail.
For dvd burning, k3b is probably the best.