Does anyone have problem running `at`?

Hello everyone,

I am using Tumbleweed snapshot 20170825 (the latest at current). When I run at through Konsole, it prompts an error, like below,

cnzhx@ostp:~> at --help
at: error while loading shared libraries: libfl.so.2: cannot open shared object file: No such file or directory

And here is the information of at,

cnzhx@ostp:~> ls -l /usr/bin/at
-rwsr-xr-x 1 root trusted 52264 Aug  6 10:46 /usr/bin/at
cnzhx@ostp:~> rpm -qf /usr/bin/at
at-3.1.20-1.1.x86_64

Does anyone know what is the problem here?

Actually, this is the first time I use at.

Judging by the error, your libfl2 library is missing.

How about;

sudo zypper in -f libfl2

Sidenote:
In order for at to work, you’ll also need the atd daemon running ( systemctl enable atd ; systemctl start atd )

Ok, I found out that that package libfl2-2.6.4-2.1.x86_64 was not installed. I do not know why but I try to install it and the problem is solved now.

Hi, thank you, Miuku,

Yes, this solves the problem. Should this be installed with at by default?

I am very pleased to know this :slight_smile:

It’s a bug in the packaging, at does not have a “Requires:” for libfl2 even though it’s required.

I opened a bug report vs Tumbleweed for the at package, here; https://bugzilla.opensuse.org/show_bug.cgi?id=1056428

Thank you. You saved a lot of my time. I’m just trying to find out whether this is a bug or not.