Does anybody with an SB Live! 24 card have it recognised by

I’ve been trying for some weeks to get ALSA to recognise my Creative Labs Sound Blaster Live! 24 bit 7.1 card - with CA0106 codec. Alasamixer does not show the correct devices and I am unable to get either a Master Volume control or to select a capture device. As a result I cannot use a key application - Audacity - under OpenSuSE. I have previously aborted an attempt to get support under Fedora after an extended period of trying.

I really don’t want to regress to Windows, but am I expecting too much for ALSA to recognise this card under OpenSuSE 11? If anybody has been able to do this, I would be grateful for some configuration advice.

I thought you had sound ? I recall this thread:
Audacity: No sound on playback. OpenSuSE 11 - openSUSE Forums

I didn’t reply because the apps you are trying to use are ones I don’t use.

Are you now saying you don’t have sound at all ?

Thread moved to Hardware

Hi, thanks for the continued interest. Yes, I can play audio about 95% of the time, using the default application (something called sound juicer, which I can’t seem to find in my list of applications) which starts when I mount an audio CD. I can also play, sometimes, through Banshee.

I am having great difficulty getting recorded sounds to playback through the Audacity application. I am conluding that the sound card is not being completely/correctly recognised/detected by ALSA. For example, starting alsamixer with the command ‘alsamixer’ gives a VERY different result to using ‘alsamixer -c 0’.

In the first case alsamizer describes the card and the chip as being ‘pulseaudio’ neither of which is correct. In the second case, alsamixer describes the card as ‘CA0106’, which is the identifier marked on the chip on my hardware, and it describes the chip as ‘blank’. Again, neither of these are correct.

In something like every 2 attempts out of 100 to playback in Audacity, this application finds a playback device called ‘ALSA dmix’ and then sound playback with all the quality I know that Audacity is capable of producing under windows (which with 32 -bit float and 96kHz sampling is extremely good quality, for home use).

From this I conclude that the configuration of my card is not being correctly set by ALSA - and hence the post requesting some advice.

Lets test this. Try to record with a very basic alsa command. If that works, only then move on to using Audacity.

Copy and paste one (either, not both) of the following lines into a konsole, and see if you can record sound. Note the “-d 15” means 15 seconds of recording.
arecord -d 15 myrecording01.wav
arecord -d 15 -f cd myrecording02.wav

If “-d 15” (15 seconds) is too long, try “-d 5” (5 sec) or “-d 10” (10 sec) in that command instead … and then iteratively try the “arecord …”, go back to alsa, change a setting, try the “arecord …” etc … over … and over … and over … until you finally get basic recording to work.

I had not recorded anything for so long, it took me 10 minutes of fiddling very quickly … I must have tried 30 or 40 different settings, until finally I found the silly setting that I had that was blocking my sound. *(

Good luck!*

I note this from a Dec 2007 debian site article on pulse audio:
Pulseaudio Debian How-To
… as always, take such articles (from another distribution), especially if dated, with a grain of salt.


Audacity is not compatible with Pulseaudio. There are plans to make it in the future but as of right now it does not work. The current common practice is to kill the Pulseaudio server in order to use Audacity. With my setup this is unnecessary. All you must do is delete all the lines in the asound.conf that appear after “#Optional”. Audacity will then work when you specify the correct device. You will have to add those lines back into the asound.conf in order to restore your setup to its original state. You will have to do this every time you want to use audacity. (Or you could probably write a script to do it.)

I just confirmed from the pulse audio web site:
PerfectSetup - PulseAudio - Audacity - lack of compatibility
It doesn’t support audacity. So I would not be in a hurry to re-install your pulse audio apps, if you removed them.

Thanks for these tips and information. I am unable to use them right now because my OpenSuSE system will no longer boot to a GUI. I am going to start the re-install process, which will take some days to complete with printer support and SAMBA access, before I try to make audio work again.