Docker service fails with result 'timeout'


I’ve just tried to configure docker in yet to be released suse leap 15 and got at issue with docker service. Here is the log

i tried to follow the official guide from here
and it fails on
systemctl start docker

it takes couple of minutes then fails.

could you please help?

When I first saw that Docker article, I skimmed it and didn’t find anything obviously wrong.

You may want to compare what you’ve done with some improved documentation I wrote long ago from which it looks like your article was largely based on, and attempted to update.

Although I haven’t actually run my guide on an openSUSE 15, it’s my early impression that it should work.

Did you install docker using YaST, zypper or some other method?
You’ll notice in my guide that I recommend zypper as simple, quickest and sufficiently complete.
And, if you were installing on a SUSE system, the procedure is different.

Although a complete bootup log file is complete,
You should use the “systemctl” command as a first step, when you use the “status” parameter as follows, it should also display a log snippet relevant to a successful startup or failure

systemctl status docker.service

For now though, it might be useful to know which docker packages are installed on your system, pls post the following results

zypper se -i docker

And, a doublecheck on your configured repos

zypper lr -d

Although not likely a critical factor, but it might be useful to verify that you’re running on an x64 system. There are a number of entries in your posted syslog I don’t recognize as usual in an x64 system.


Hi and tanks for the response :slight_smile:
I solved with reinstalling the system.
the problem i guess was in firewall and networkmanager
as NetworkManager were showing some timeouts while trying to get some response from frewall…
and when i was trying to change settings in firewall it was again hanging…

Paving and re-building is always a practical approach with a brand new system vs long troubleshooting…

Glad to hear you’ve got a working system now.