Docker packer is corrupted while doing an update

Getting this error doing a update on openSEUSE TW. I tired continuing 3 time with the same error.

Retrieving package docker-20.10.9_ce-1.1.x86_64                               (100/142),  29.9 MiB (133.9 MiB unpacked)
Retrieving: docker-20.10.9_ce-1.1.x86_64.rpm ........................................................[done (1.4 MiB/s)]

Warning: Digest verification failed for file 'docker-20.10.9_ce-1.1.x86_64.rpm'
[/var/tmp/AP_0xeqjxLe/x86_64/docker-20.10.9_ce-1.1.x86_64.rpm]

  expected 1fce8b0241e4ef8cd6bd5ef249a4ff056cd68a9648cd6470b97a71514bf11080
  but got  3f93388c88f976241d001115490c4e2eeb9ab6398491224431aac22bd4019466

Accepting packages with wrong checksums can lead to a corrupted system and in extreme cases even to a system compromise
.                                                                                                                      

However if you made certain that the file with checksum '3f93..' is secure, correct
and should be used within this operation, enter the first 4 characters of the checksum
to unblock using this file on your own risk. Empty input will discard the file.

**Unblock or discard? [3f93/...? shows all options] (discard): **discard
Package docker-20.10.9_ce-1.1.x86_64 (Main Repository (OSS)) seems to be corrupted during transfer. Do you want to retr
y retrieval?                                                                                                           
**Abort, retry, ignore? [a/r/i] (a): **a
Problem occurred during or after installation or removal of packages:
Installation has been aborted as directed.                                                                             
Please see the above error message for a hint.
No processes using deleted files found.

No core libraries or services have been updated since the last system boot.
Reboot is probably not necessary.

Hi
I see the same, just locked the packages for the moment and re-ran the dup…


zypper al docker docker-bash-completion docker-kubic

That was helpful, worked for me, thanks!

I see the same error. Is this something we users can/should report somewhere? In that case, where?

Hi
Just transitional, if you added locks remove and zypper dup.

Noticed that yesterday and it seems to have been fixed overnight:


 10:10:19  rpm -Kv .cache/zypp/packages/repo-oss/x86_64/docker-20.10.9_ce-1.1.x86_64.rpm
.cache/zypp/packages/repo-oss/x86_64/docker-20.10.9_ce-1.1.x86_64.rpm:
    Header V3 RSA/SHA256 Signature, key ID 3dbdc284: OK
    Header SHA256 digest: OK
    Header SHA1 digest: OK
    Payload SHA256 digest: OK
    V3 RSA/SHA256 Signature, key ID 3dbdc284: OK
    MD5 digest: OK

I’ll be curious to know what happened, it looks like it’s still the same version that was re-signed.