docker and python packages

Hi,
I was trying to install docker on Leap 15.2 base do wiki document:
https://en.opensuse.org/Docker
When it tries to install

python3-docker-compose

, I got dependency error for


Problem: nothing provides python3-dotenv >= 0.10.5 needed by python3-docker-compose-1.25.4-23.2.noarch
 Solution 1: do not install python3-docker-compose-1.25.4-23.2.noarch
 Solution 2: break python3-docker-compose-1.25.4-23.2.noarch by ignoring some of its dependencies


the system provides

python3-python-dotenv

Is that any reason for naming python packages like that? should I do anything different to install that package?
It was the same in tumbleweed.

Thanks

I cannot replicate this in a 15.2 VM, here’s what happens on mine:

zypper in python3-docker-compose
Loading repository data...
Reading installed packages...
Resolving package dependencies...


The following 12 NEW packages are going to be installed:
  docker docker-bash-completion python3-cached-property python3-docker python3-docker-compose python3-docker-pycreds python3-dockerpty python3-docopt python3-jsonschema python3-texttable python3-wcwidth
  python3-websocket-client


The following recommended package was automatically selected:
  python3-wcwidth


12 new packages to install.
Overall download size: 32.3 MiB. Already cached: 0 B. After the operation, additional 146.9 MiB will be used.

Do you have additional repositories that may have docker / python files in them?

Thanks for reply.
I had two python repos :

  1. Python Modules (SLE_15_SP2)
  2. LEAP_15.2_python

It seems the problem was occurred form them. when I disable those it works fine with me.
Now it comes to the problem I had before, to see if for some additional python I need to use pip instead of using python from leap own packages, then what is the best solution to be used?
Do I need to install all python from pypi? is that not going to effect my system stability?

Regards

You can still keep those repos enabled - it was simply trying to install the newer files from there.

Now that you have it installed, it won’t “switch vendor” to the repo unless you explicitly tell it to.

thanks for the help , then I will enable them again :slight_smile: