do not install the opensuse ati driver !!!

Installed Ati driver : Ati Mobility X1350
ATI - openSUSE
Now my laptop with 3D enabled is very slow what a rubish is this. When try enabling desktop effect the screen is flickering.


ATI drivers are cr@p, no matter which ones

I just got a Thinkpad T40 and this is the first machine I have with an ATI card (Radeon Mobile 7500). What would be the best course of action when dealing with ATI?

Not installing any external driver.

Just in case there’s a tweak you missted, can you post the response you get from these commands:

rpm -qa | grep fglrx
uname -r
cat /etc/X11/xorg.conf

I don’t know much about ATI but these guys or some other experts could perhaps help after reading that info.

rpm -qa | grep fglrx
no output

uname -r : unknow command

I have deinstalled and are now using the internal opensuse driver. No 3D possible or linux is getting instable.

The ten past years I have still the same problems with Ati graphic cards , black screens , flickering screens not closing the system you get a striped screen and not working together with Sax2 etcetera.

I hoped this ATI - openSUSE
would work but it is just like the original ati drivers very disappointed.

Maybe it is time for AMD-ATi to ask some advice to Nvidia.

uname -r : unknow command

You gotta be kidding.


ATI drivers alsways worked for me somehow but never without glitches until the free drivers (radeon in that case) were able to support my card. After that I switched immediately.

Now I own an NVidia card and they are also not without stability issues, so only blaming ATI and “praising” NVidia is just a wide spread misconception in linux community.

ATI sucks? Maybe, but NVidia does too, just because they suck a little less (in most cases, with free drivers I never had a complete freeze due to crappy drivers, a phenomenom I now “rediscovered” again with some NVidia drivers, though not so often, if you don’t believe me, read the changelogs of NVidia driver releases) does not make them “good”.

The moment my card will be sufficiently supported by free drivers (hopes go to nouveau) I will switch _immediately away from that proprietary crap.

Never had big problems with Nvidia drivers from the opensuse site.
I am not praising nvidia, nothing is perfect and maybe the hardware from ati is better but my experience is ; the past ten years again and again nvidia is a better choice then ati drivers when using Linux.
certainly when u use dual screen or Xinerama.

You hav eto keep in mind that beginners also want to easy install 3d drivers just by clicking on the install button.
Thats also why they love openSUSE but then its better that they don’t get a black screen.

By the way: uname -r :

As for most users the installation via the repos (which BTW are not hosted by openSUSE) seems to work your “advise” is ridicoulous, only because you don’t get it working does not mean it is broken, in > 99% of all cases it’s a users error (which you can also see that “uname -r” now seemed to work “magically” although it was “unknown” a few minutes ago).

And to be honest, somebody with “10 years” of linux experience not being able to type uname -r correctly at the first time and then advising people not to install something (with three ! that is), “high credibility” is not the first thing which comes to mind.

sorry but uname -r was just a type fault from me
in holland we say : the bests can happen

Just wrote what my experience is and was hoping that something could change I am not against ATI.

What ATI graphic do you have and which driver , do you also have dual monitor , xinerama support when using this driver :

You do not have the drivers installed.

If you decide to install them and after that you still have problems, could you return this information please:

rpm -qa | grep fglrx
uname -r
cat /etc/X11/xorg.conf

Then maybe someone could help you.

I installed latest AMD( ati mobility) catalyst display driver 9.3 . amdcccle works but I can not enable compositing under desktop effects.

So thats not working for me.
I will uninstall and reinstall
ATI - openSUSE driver
and then post what you ask.

Make sure that the driver from AMD/ATI homepage is still compatible with your card, AMD/ATI dropped support for some older cards, don’t exactly know which was the last compatible release, but double check not to get the wrong driver.

Also have a look if your card is not already supported by the free drivers (radeon), in latest versions of Xorg/X-server they will be supported, don’t exactly know about the version in 11.1.

Yes it is supported Linux x86_64 Mobility Radeon - X1300 series
Mine is X1350 . amdcccle gives a good result about the graphic card works fast only can not shut down the computer get stripes like a tv which has no channel and it is not working with desktop effects.

anton@linux-r2p1:~> rpm -qa | grep fglrx
anton@linux-r2p1:~> uname -r
anton@linux-r2p1:~> cat /etc/X11/xorg.conf


SaX generated X11 config file

Created on: 2009-09-11T13:28:42+0200.

Version: 8.1

Contact: Marcus Schaefer <>, 2005

Contact: SaX-User list <>

Automatically generated by [SaX2] (8.1)


Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”

Section “Module”
Load “dbe”
Load “freetype”
Load “extmod”
Load “glx”
Load “dri”

Section “ServerFlags”
Option “AIGLX” “on”
Option “AllowMouseOpenFail” “on”
Option “IgnoreABI” “on”
Option “ZapWarning” “on”

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”

Section “InputDevice”
Driver “evdev”
Identifier “Mouse[1]”
Option “InputFashion” “Mouse”
Option “Name” “Logitech Optical Mouse”
Option “Pass” “3”
Option “Vendor” “Sysp”
Option “evBits” “+1-2”
Option “keyBits” “~272-287”
Option “relBits” “~0-2 ~6 ~8”

Section “InputDevice”
Driver “synaptics”
Identifier “Mouse[3]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “on”
Option “HorizScrollDelta” “0”
Option “InputFashion” “Mouse”
Option “Name” “Synaptics;Touchpad”
Option “Protocol” “explorerps/2”
Option “SHMConfig” “on”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[5]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “ImPS/2 Generic Wheel Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”

Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 367 230
HorizSync 30-70
Identifier “Monitor[0]”
Option “DPMS”
Option “PreferredMode” “1440x900”
VendorName “SEC”
VertRefresh 43-60
UseModes “Modes[0]”

Section “Modes”
Identifier “Modes[0]”

Section “Device”
BoardName “ATI Mobility Radeon X1350 (M62 7196)”
Driver “fglrx”
Identifier “Device[0]”
Option “Capabilities” “0x00000000”
Option “VideoOverlay” “on”
Option “OpenGLOverlay” “off”
Option “FSAAEnable” “off”
Option “FSAAScale” “0”
Option “XAANoOffscreenPixmaps” “true”
VendorName “ATI”

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1440x900”
SubSection “Display”
Depth 16
Modes “1440x900”
SubSection “Display”
Depth 24
Modes “1440x900”
SubSection “Display”
Depth 8
Modes “1440x900”
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
InputDevice “Mouse[5]” “SendCoreEvents”
Screen “Screen[0]”

Section “DRI”
Group “video”
Mode 0660

anton@linux-r2p1:~> rpm -qa | grep fglrx
anton@linux-r2p1:~> uname -r**default**

C’mon, this is too obvious why this setup can’t work.

Your absolutely right .

Its because this point :
You can use 1-click-install that will install the latest fgrlx version, but before you use 1-click, update the openSUSE using YaST Online Update.

So now I have the wrong kernel number.

No, the kernel version is not the problem, the flavour however is.

The kmp-packages for are compatible with, but a default kernel will not even think about loading a module from a “kmp-trace” package (no matter which version).

did not know that the kmp-packages for are compatible with