Do not all gfxcards with HDMI and/or DisplayPort ouput provide audio on the output ports

It looks like the answer may be they do not:

The card:

# pinxi -SAxx
System:    Host: fi965 Kernel: 5.3.18-lp152.4-default x86_64 bits: 64 compiler: gcc v: 7.5.0 Desktop: Trinity R14.0.7
           tk: Qt 3.5.0 wm: Twin dm: TDM Distro: openSUSE Leap 15.2 Alpha
Audio:     Device-1: Intel 82801H HD Audio vendor: ASUSTeK P5B driver: snd_hda_intel v: kernel bus ID: 00:1b.0
           chip ID: 8086:284b
           Sound Server: ALSA v: k5.3.18-lp152.4-default
fi965:~ # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD1988B Analog [AD1988B Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD1988B Digital [AD1988B Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: AD1988B Alt Analog [AD1988B Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Alsa-info.txt.

Can this be so?

Card specs:

# inxi -Gxx
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] RV620 PRO [Radeon HD 3470] vendor: Dell driver: radeon v: kernel 
           bus ID: 04:00.0 chip ID: 1002:95c0 
           Display: server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa alternate: ati 
           resolution: 2560x1080~60Hz, 1920x1200~60Hz 
           OpenGL: renderer: AMD RV620 (DRM 2.50.0 / 4.12.14-lp150.12.25-default LLVM 5.0.1) v: 3.3 Mesa 18.0.2 compat-v: 3.0 
           direct render: Yes