Do I have to keep inserting my usb when I want to update?

I’m a Suse newbie, 13.2, kde, not a Linux newbie, been using Linux for like 8 years and suse is like nothing i ever tried, looks neat and all but I don’t know if I can use it, took me hours to figure out how to remember wifi password (don’t know if it works, i doubt it) and now I have another issue.

Everytime I want to update yast, it asks for the installation usb, gives me a weird error, i’m sure you saw it, didn’t bother reading the error, i fiigured out immediatly that it’s asking for installation disk, cause i used to see similar error on Debian. On debian you edit the sources file, comment out a line and it’s gone, how to fix it in Suse?

Use YaST > Software > Repositoiries Management. Then in the list search for the device (starts with somethig like cd:/), select it and below uncheck the box Enabled. Finish.

Hi!

Based from your description, most likely the USB installer sources were still enabled in zypper. Can you post the output of

sudo zypper lr -u

? Also, is this a fairly recent install?

If the USB sources are still listed, you can either delete or disable those. Do a

sudo zypper rr (whatever number the USB repos are)

zypper rr where rr means Remove Repository.

Once we have the output, we can move on from there.

Good luck!

On 2015-03-18 18:46, tesla wrote:
>
> I’m a Suse newbie, 13.2, kde, not a Linux newbie, been using Linux for
> like 8 years and suse is like nothing i ever tried, looks neat and all
> but I don’t know if I can use it, took me hours to figure out how to
> remember wifi password (don’t know if it works, i doubt it) and now I
> have another issue.
>
> Everytime I want to update yast, it asks for the installation usb, gives
> me a weird error, i’m sure you saw it, didn’t bother reading the error,
> i fiigured out immediatly that it’s asking for installation disk, cause
> i used to see similar error on Debian. On debian you edit the sources
> file, comment out a line and it’s gone, how to fix it in Suse?
>
>

Whoops, sorry, didn’t see your response there yet. Yes, YaST is a good way of doing it too.

On 2015-03-18 18:56, hcvv wrote:
>
> Use YaST > Software > Repositoiries Management. Then in the list search
> for the device (starts with somethig like cd:/), select it and below
> uncheck the box Enabled. Finish.
>
>

worked thanks!