DNS fails a few seconds after restarting NetworkManager

Hi, I recently got a weird problem with my remote tumbleweed server.

  1. I can ssh to it.
  2. after restarting NetworkManager through systemd, everything works fine, but only for a few seconds.(ping a domain resolves alright but stops work after about 8 packets.)
  3. after problems in 2, I cannot even ping the dns server (the outgoing traffic seems all stopped). but the ssh connection stays well alive.
  4. in stage 1-3, /etc/resolve.conf updates normally and is correctly set.

I’ve tried resetting iptables, checking firewall rules, but everything seems normal but the problem presists, any ideas? Thanks in advance.

Do you ping the DNS server based on name or IP address? If it is IP address, can you try tracepath instead?

Do you have a firewall running? If so can you (temporary) disable it and check if that fixed the problem?

Tried both, same outcome (ping fails a few seconds after NetworkManager restarts).

Whether I can ping through it or not, tracepath only gets responses from localhost, as follows (test IP corresponds to bing.com):

$ tracepath
 1?: [LOCALHOST]                      pmtu 1500
 1:  no reply
 2:  no reply
 3:  no reply
 4:  no reply
 5:  no reply
 6:  no reply

Tried the above tests with firewall stopped, same result.

Can you start on the command line “nmcli monitor” and restart NetworkManager? What output do you get?

What is “ip a” and “sudo ethtool <active-if?” showing when the interface is down?

It’s a remote server, I’m afraid I won’t be able to test with the interface down. I’ll report back when I get access on-site. Thanks for the help.