DNS, Domain, join failles


I’m using openSuse11. I have set up the DNS entries manually, and the first one points to the SBS AD server (SBS’03R2). I have specified the WINS server to the same machine using explicit IP address.

I can see the domain members in the Network Servers window.

I can not ping individual domain members by name, but I can ping them by IP address.

I can not join the AD domain, YaST can’t locate the domain controller.


Thanks, David L.

Check your domain suffix is set correctly.

Or add the domain suffix to the domain searches.

yast -> network devices -> network settings -> hostname/dns tab



That did not work, I had to add the DC to the hosts list explicitly, then it worked.

Thanks for the advise, David L.

By using the host file you are bypassing your dns settings.

Glad you have a workaround.


What does joining the domain actually do?

I do not get the behaviors of MS OS, do not see shares, have to specify acct & PW when attempting to access network resources, etc.

I could see the domain and it’s members before I joined.

David L.

Personally I would not use the hosts file, I would go for resolv.conf file with a restarting of network services.

where does this file live?

David L.


If the file is not there don’t worry just create a new one (as root).
#vi /etc/resolv.conf
The structure of the file is:
search domain_name
nameserver IP_address_in_dotted_ decimal_of_DNS_server

#cat /etc/resolv.conf
search mylocaldomain.whatever

thanks, the contents of the file have the values that I have set using YaST.

2 name servers, the first the AD / DNS server, the second, my router.

However, local (AD domain) names do not get resolved. Internet names do get resoled.


David L.

what the result of
#dig @your_AD_DNS_server name_of_the_domain_member_you_want_to_resolve

The order in the file is reversed, first the name servers, then the ‘search’ line.

Does this make a difference?

David L.

; <<>> DiG 9.4.2-P1 <<>> @rbtm rbsql05
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 13792
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;rbsql05. IN A

;; Query time: 2 msec
;; WHEN: Tue Oct 14 10:25:42 2008
;; MSG SIZE rcvd: 25

It should not make any difference.
But for the sake of testing let’s have the same order like I have on my server (I posted before).
Normally the query is directed to first DNS server, if there is no answer than it is going to 2nd server and if still failing it will go to “upper DNS levels” - like ISP, etc…
Did you tried a reboot of the machine after performed these modifications?

I switched the order in the file, rebooted and it’s still the same.

Did the ‘dig’ results give you a hint?

Thanks, David L.

Is obvious the query is failing.
I am used to use dig like that:
#dig @IP_address_of_DNS_SERVER FQDN_of_server/workstation
dig @ myworkstation.mydomainname.local

this is weird, I took out the hosts entry, rebooted the WS, and got:

rabboard@rbsuse11:~> ping rbsql05.rbtmd.local
ping: unknown host rbsql05.rbtmd.local
rabboard@rbsuse11:~> dig @rbtm rbsql05.rbtmd.local

; <<>> DiG 9.4.2-P1 <<>> @rbtm rbsql05.rbtmd.local
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11331
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;rbsql05.rbtmd.local. IN A

rbsql05.rbtmd.local. 1200 IN A

;; Query time: 1 msec
;; WHEN: Tue Oct 14 11:24:50 2008
;; MSG SIZE rcvd: 53

rabboard@rbsuse11:~> ping rbtm
ping: unknown host rbtm

how come dig gets mane resolution on the DC / DNS name while ping does not?

David L.

dig is querying the DNS server directly (specialized command). Did you try ping FQDN?

don’t forget, also, to check network manager settings (if you are using it).