DNS and DHCP sync ? cannot ping by host name.

Dear all,

Greetings! I have setup opensuse 11.1 as my dns,and dhcp server for my internal lan.

My network consists of 2 windows xp, and one opensuse 11.1 client. All of these clients get their ip addresses from dhcp server.

I can ping any of the clients from any other clients or dns server by ip, But not by machine name.

If I add the A records for the network clients(after assigning static ips), they could be pinged by any client. :\ I guess this is not the right way.

Am i missing the link between dhcp server and dns server services?

I am producing the named.conf, forward, reverse zone files and dhcpd.conf below. Any help will be appreciated. Thanks in advance.

cat dhcpd.conf

option domain-name “mynework.local”;
option domain-name-servers 192.168.1.1, 192.168.1.1;
option routers 192.168.1.1;
option ntp-servers 192.168.1.1;
option lpr-servers 192.168.1.1;
option netbios-name-servers 192.168.1.1;
ddns-update-style none;
default-lease-time 86400;
subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.16 192.168.1.32;
default-lease-time 86400;
max-lease-time 172800;
}

cat named.conf

options {
directory “/var/lib/named”;
dump-file “/var/log/named_dump.db”;
statistics-file “/var/log/named.stats”;
listen-on-v6 { any; };
notify no;
};
zone “.” in {
type hint;
file “root.hint”;
};
zone “localhost” in {
type master;
file “localhost.zone”;
};
zone “0.0.127.in-addr.arpa” in {
type master;
file “127.0.0.zone”;
};
zone “mynetwork.local” in {
file “master/mynetwork.local”;
type master;
allow-transfer { any; };
};
zone “1.168.192.in-addr.arpa” in {
file “master/1.168.192.reverse”;
type master;
};
logging {
category queries { log_file; };
category xfer-in { log_file; };
category xfer-out { log_file; };
category default { log_file; };
channel log_file { file “/var/log/named/bind.log” size 100M; };
};

cat mynetwork.local

$TTL 2D
mynetwork.local. IN SOA dns root.mynetwork.local. (
2009041600 ; serial
3H ; refresh
1H ; retry
1W ; expiry
1D ) ; minimum

		IN 	NS	dns.mynetwork.local.

dns IN A 192.168.1.1
wwww IN CNAME dns.mynetwork.local.


cat 1.168.192.reverse

$TTL 2D

1.168.192.in-addr.arpa. 	IN	SOA 	dns.mynetwork.local.	root.mynetwork.local. (

			2009041600	; serial
			3H		; refresh
			1H		; retry
			1W		; expiry
			1D )		; minimum

			IN 	NS	dns.mynetwork.local.

1 IN PTR dns.mynetwork.local.

You need to set up DNS so that it will allow updates by DHCP. Sorry, it’s been so long since I did this that I would have to tell you to look for some tutorials anyway.

But as an alternative, you could dictate the IP addresses that the clients will get and their DNS name by entering some DHCP records that are keyed to the MAC address of the client. That way you also get “static” addresses assigned to the client.

Thanks a lot for the tip. let me try on google on how to go about. thanks again.

On Sat May 2 2009 08:06 am, sesri wrote:

>
> Thanks a lot for the tip. let me try on google on how to go about.
> thanks again.
>
>
sesri;

You can find some sample configurations and documentation here:
/usr/share/doc/packages/bind. For DDNS you need to set the “allow-update”
option in each zone section of “named.conf”.
An example of this is:


zone "mylocalzone" in {
type master;
file "dyn/mylocalzone.zone";
notify no;
allow-update {key DHCP_UPDATER;};
};
zone "0.168.192.in-addr.arpa" in {
type master;
file "dyn/192.168.0.zone";
allow-update {key DHCP_UPDATER;};
};


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

sesri wrote:
> Dear all,
>
> Greetings! I have setup opensuse 11.1 as my dns,and dhcp server for my
> internal lan.
>
> My network consists of 2 windows xp, and one opensuse 11.1 client. All
> of these clients get their ip addresses from dhcp server.
>
> I can ping any of the clients from any other clients or dns server by
> ip, But not by machine name…
> option domain-name “mynework.local”;

…local is a RESERVED MULTICAST DOMAIN TLD. However, Microsoft
(who doesn’t understand or want to understand standards) want you
to name local domains with .local… MISTAKE.

You can work around this by disabling multicast (avahi and friends)
dns.

I know it used to be that this got in the way all of the time
with regards to name resolution and a fix was to put “mdns off” in
/etc/host.conf, but that (I believe) went away with the avahi
discovery daemon (I’m not positive about this… just something
to look into).

This may not be your problem… but PLEASE don’t name your domains/zones
with endings of .local.