dmesg.txt runs for 1 minute on boot

Hey to All,
I don’t know how it happened, but watching the boot progress on screen there is a repeated line that runs for over a full aseconds.
“bad line in etc/modprobe.d/dmesg.txt line xxx that begins with …”
I’ve looked into the dmesg.txt file and I can’t tell where the problem is that makes it print out this error message.

Any help is greatly appreciated.


I don’t know what you put in that “dmesg.txt”-file (yes, it must have been you, this file does not exist on a standard install), but the most logical thing to do would be to move/delete it, now wouldn’t it?

I also don’t understand, why you don’t post its content, especially as you even already know, that there might be something wrong with that file.

Is it true if I delete dmesg.txt it will not create any problems with boot?


How shall I know, if I don’t know the content?

Shakes his head

The text that you have entered is too long (54422 characters). Please shorten it to 15000 characters long.

This is the error message this forum gives me for trying to copy the dmesg.txt file between quote tags.

I did not add anything to this file.
How it happened is beyond me, although running KDE latest does have a great number of crashes, and for that reason I stick with KDE 3.


Ever heard of no-Paste/pastebin services?

Well, it must have been you messing this up, whatever is in there. This file (as I already said in my first answer) does not exist on a standard install.

Didn’t think you would use it. And why paste the contents of such a large file when all I have to do is delete it?

I guess it doesn’t matter what I say,
Thanks for answering my question so quickly, that was nice.

Maybe because I wanted to see, when that file was created or what is really in it.

The name of the file gives you a good chance of guessing, but instead of cooperating with your own problem, you keep asking unproductive questions.

If you don’t want to get decent help, then why do you ask?

If this file is the product of some insane, self-installed script doing this on every boot, then you will run into this problem again.

It does matter, it does matter a lot in fact, but if you don’t answer questions and still expect help, then you should consider more what you are saying.

Apologies for that, won’t happen again…


dmesg is something that is used to extrapolate information, usually for debugging or something. Read about it here How to use the dmesg command – by The Linux Information Project (LINFO)
So the only way that you would have a file there is if you used dmesg and told it to output the information in a file. Basically, you told it to save whatever it was that you were doing with dmesg.

Back off with the attitude. If you think your superioristic attitude helps, your wrong. I’m sick of seeing you abuse people for asking questions. We all had our starting points, including you. You had to learn to, and you don’t know everything.

Indeed, and I still don’t know a lot, but when asking for help, I actually read the suggestions and answer the questions posted to me.

I’ll agree there, but the way I’ve seen you do it, and I’m guilty of it to, doesn’t help. Maybe they don’t understand the suggestion. There are many possibilities.

I don’t think so in this case.

The response time of the OP clearly shows, that he did not want to solve the problem by himself but to get it solved without having to think. (or at least having to think as less as possible).

If trying to make people think of themselves (especially when the steps to solve the problem are as logical as here), then I am guilty of charge.

If the attitude of telling people they should take more care of their own problems by stating them in a clear manner and showing some initiative on their own is wrong, then this is certainly not my community any more as this attitude made me learn.

Note that on openSUSE-11.1 and older versions, most files in the /etc/modprobe.d directory will be loaded upon boot. Hence one should NOT put any file in that directory that one does NOT want loaded. Hence do NOT put backups in that directory. Hence do not put dmesg.txt in that directory!

Its important in Linux that one does not put files in any random location. If one wishes to store data then /home/Chetanji is a good place for it. Definitely NOT in /etc/modprobe.d :slight_smile:

I believe with openSUSE-11.2 this is planned to be changed and files that will loaded from /etc/modprobe.d/ must have a number in front which will dictate their order of loading and files without the number will not be loaded. But I’m not 100% certain on that detail.

Maybe it is the case, and maybe not. The response time is not conclusive. What is is an eye witness, which we don’t have.

Trying to motivate people to think for themselves is never bad. But you can’t make people do anything. It is their choice.

There are ways to “tell” people. Ways that will inspire and motivate, and ways that will not.

I can yell all day about how foolish people are with their security and their computers. I can talk about what they need to do and so on, but I can’t make them listen. I can’t get them to do anything. That’s their choice, not mine.

As a test, you might try renaming the file. Just rename dmesg.txt to dmesg.txt.old or something. This way, if it works, you can then delete it, if that is what you want to do. If it doesn’t work, you should be able to restore it easily. Just rename it back to it’s original name. What I find interesting is that neither Akoellh nor I have this file on our system, as I explained why before. But what really interests me is that this dmesg.txt is executable. Here is what mine looks like.

> ls -al /etc/modprobe.d
total 84
drwxr-xr-x   2 root root  4096 2009-10-12 21:40 .
drwxr-xr-x 152 root root 12288 2009-10-24 23:10 ..
-rw-r--r--   1 root root  6031 2009-10-05 06:36 blacklist
-rwxr-xr-x   1 root root   128 2009-04-22 04:22 bluetooth
-rw-r--r--   1 root root   106 2009-09-06 14:09 broadcom-wl-blacklist
-rw-r--r--   1 root root    22 2009-09-22 10:08 ipv6
-rw-r--r--   1 root root    28 2008-12-03 05:05 ipw2100
-rw-r--r--   1 root root    45 2008-12-03 05:05 ipw2200
-rw-r--r--   1 root root   858 2009-08-16 04:58 module-renames
-rw-r--r--   1 root root    86 2009-07-02 01:09 nvidia
-rw-r--r--   1 root root   640 2009-05-14 13:13 pam_fp-uinput
-rw-r--r--   1 root root   134 2009-04-14 03:16 pnp-aliases
-rw-r--r--   1 root root    18 2008-12-03 05:05 prism54
-rw-r--r--   1 root root   124 2009-09-09 20:17 sound
-rw-r--r--   1 root root     0 2009-09-09 20:17 sound.YaST2save
-rw-r--r--   1 root root   405 2008-12-03 03:22 thinkpad_acpi
-rw-r--r--   1 root root     0 2009-09-09 20:16 tv
-rw-r--r--   1 root root   532 2009-04-01 15:19 unsupported-modules
-rw-r--r--   1 root root   115 2008-12-04 20:49 vmnics
-rw-r--r--   1 root root    93 2009-05-14 13:39 xen_loop

If this is openSUSE-11.1 or earlier, I believe that by renaming and keeping it in /etc/modprobe.d/ all that will happen is the file will be loaded under a different name. It needs to be moved to a different directory, preferably under /home/username.

Mine is 11.1. I’m not sure about this myself. I have never seen a scenario like this before. What I do know is that from the output of my ls I know that I have 2 directories, and both are executable and 1 file that is executable.

At any rate, both methods/ideas have merit IMO.

I don’t think renaming has any merit, unless one is trying to prove that the line in modprobe.conf works the way it is supposed to.

Take a look at the end of /etc/modprobe.conf.

One will see:

# please keep this at the end and add local modifications to modules.conf.local
include /etc/modprobe.d
include /etc/modprobe.conf.local

which is intended to load every file in /etc/modprobe.d and also load the file /etc/modprobe.conf.local … at least that is how I read that code.

I was trying very hard to be polite by saying “I believe” … etc . … in the above thread, in the hope it would spur more investigation to check out if what I was saying was true as opposed to doing no investiation.

From what I have seen on 11.2 RC1 (and also in previous milestone releases) is there is no /etc/modprobe.conf file. Hence the mechanism for loading the contents of the /etc/modprobe.d directory is different in 11.2 than in previous openSUSE releases. I had a thread on this very subject here: 11.2 new modprobe.d naming convention ? - openSUSE Forums as I tried to figure out what was happening with this directory under openSUSE-11.2.

Correction to this, … my memory has let me down.

In 11.2, files with the extension *.conf will be loaded. Those without that extension will generate an error message. I believe the number in front of the files will indicate the order in which they are loaded.

However in 11.1 and earlier, the code attempts to load all nominal text files in that /etc/modprobe.d directory.

Well, oldcpu is right, openSUSE < 11.2 will not care about file extensions in /etc/modprobe.d/.

And still without the content, this is guessing, so much about bad attitude on my side.

I don’t do this to “burst my ego”, I do this to get the solution in a reasonable way, especially for people reading the thread later.

If this file contains what I (and certainly most of experienced users) suspect considering its filename, there is no way what so ever, why this file should be there and no tool/mechanism, which is sane, will write such a file in that location.

So we can go on guessing and “play nice” or we can wait until the OP starts playing along with what we need to make more than just a guess and what he was told to provide several times now.