Disturbed sound

I installed openSuSE 12.3 on my 3 years old PC based on a Gigabyte GA-MA770 UD3 board. The sound output of the mainboard is choppy, disturbed. It works correctly under any Windows (tested under XP and 7, 32 bit and 64 bit) but it is horrible under Linux (tested under openSuSE 32bit, 64bit, Ubuntu 32 bit, with KDE and GNOME too). I think that the cause may be an IRQ conflict, because the IRQ16 is shared between the audio and USB circuits of the board. The BIOS has no any option to reassign the IRQ-s (even the latest BIOS has no any option to change the IRQ assignment). I tried a lot of suggestions found in the different forums (alsa troubleshooting etc.) but none of them helped. Could somebody help me ?

To quote from the somewhat dated, but possibly still valid, audio troubleshooting guide:

Commencing with openSUSE-11.0, PulseAudio was introduced in openSUSE. This initial PulseAudio introduction, created some problems with Gnome users and KDE4 users (KDE-3.5.9 users were mostly unaffected). For guidance on how to deal with some Pulse Audio problems, please refer to

  • [freedesktop.org - Software/PulseAudio/FAQ](http://www.pulseaudio.org/wiki/FAQ) and
    
  • [SDB : Pulseaudio - openSUSE](http://en.opensuse.org/SDB:Pulseaudio) and
    
  • [freedesktop.org - Software/PulseAudio/Backends/ALSA/BrokenDrivers](http://pulseaudio.org/wiki/BrokenSoundDrivers) 
    

On openSUSE-11.1 and 11.2, PulseAudio works much better.

A possible fix to choppy / skipping sound

The PulseAudio sound server was written to use timer-based audio scheduling instead of the traditional interrupt-driven approach. This is the approach that is taken by other systems such as Apples CoreAudio and the Windows Vista audio subsystem and has a number of advantages, not the least in reduced power consumption, minimization of drop-outs and flexible adjustment of the latency to the needs of the application. However, timer-based scheduling may expose issues in some Alsa drivers. To turn timer-based scheduling off, replace the line


load-module module-udev-detect

in /etc/pulse/default.pa by (or adding if that line not present)


load-module module-udev-detect tsched=0

restart and test.

In other cases, choppy sound in pulsaudio can result from wrong settings for the sample rate in /etc/pulse/daemon.conf . Try changing the line


default-sample-rate = 44100

in /etc/pulse/daemon.conf by


default-sample-rate = 48000

and restart and test.

If the above does not work, restore the original setup.

Its also possible your hardware audio codec was not appropriately identified. Please in a bash shell/terminal with pc connected to the internet run the audio diagnostic script:


/usr/sbin/alsa-info.sh

and select the UPLOAD/SHARE option and then let script complete fully. After it is complete copy the URL / web-address it provides to you to share, and post it here so we can check the audio configuration.

Hi,

thank You for the tips. The suggested pulseaudio workarounds (tsched, sample rate) did not help. My ALSA information is located at http://www.alsa-project.org/db/?f=46023df316c7d21067d8852b4f0242e8e43e2891

Regards

Reinstalling the system without pulseaudio did not help, the sound is choppy even without the pulseaudio service.

The tip of “SDB pulseaudio” site to hide the pulseaudio libraries by moving them into a HIDDEN directory (ALSA fallback) leads to login problems !!!

Any other tips ?

I have never had such a problem myself. so I can only speculate. You may be better off writing a bug report or trying the mailing lists.

I suppose you could try forcing a model option (one at a time), where for the ALC888 (in your PC) I note the following options are possible (where one can ONLY try EACH one, one at a time, with reboot in between) :


ALC882/883/885/888/889
======================
  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  arima		Arima W820Di1
  targa		Targa T8, MSI-1049 T8
  asus-a7j	ASUS A7J
  asus-a7m	ASUS A7M
  macpro	MacPro support
  mb5		Macbook 5,1
  macmini3	Macmini 3,1
  mba21		Macbook Air 2,1
  mbp3		Macbook Pro rev3
  imac24	iMac 24'' with jack detection
  imac91	iMac 9,1
  w2jc		ASUS W2JC
  3stack-2ch-dig	3-jack with SPDIF I/O (ALC883)
  alc883-6stack-dig	6-jack digital with SPDIF I/O (ALC883)
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  acer-aspire-6530g Acer Aspire 6530G
  acer-aspire-7730g Acer Aspire 7730G
  acer-aspire-8930g Acer Aspire 8930G
  medion	Medion Laptops
  targa-dig	Targa/MSI
  targa-2ch-dig	Targa/MSI with 2-channel
  targa-8ch-dig Targa/MSI with 8-channel (MSI GX620)
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m540r	Clevo M540R (6ch + digital)
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  intel-alc889a	Intel IbexPeak with ALC889A
  intel-x58	Intel DX58 with ALC889
  asus-p5q	ASUS P5Q-EM boards
  mb31		MacBook 3,1
  sony-vaio-tt  Sony VAIO TT
  auto		auto-config reading BIOS (default)

If you need guidance as to how the options are applied, please advise.

Solved !

I had to set the headphone level in the mixer to 0. The sound is now OK. Increasing the headphone level causes chopping output. Probably there is an overload effect inside the mixer if the headphone level is greater than 0.

Well done on solving this problem.

Thankyou for sharing your solution.

Note: pulseaudio seems to restore the headphone level to 100% at every system startup, causing problems again and again. Thus I had to deinstall the pulseaudio package.

Thus, there are two components which seem to have problems with my Gigabyte mainboard: ALSA and pulseaudio.

Many thanks, oldcpu

Do you plan on using GNU/Linux for a while ? If so, it likely behooves you to write a Bug Report on your openSUSE version. There is guidance here: https://en.opensuse.org/openSUSE:Submitting_bug_reports Writing such a bug report will bring this to the attention of the SuSE-GmbH sound packager, who is also an alsa sound developer and with whom works with the pulse audio developers. They may then ask for more information off of your PC setup and then apply a permanent fix to alsa and pulse audio as appropriate. That way both future openSUSE versions and also other GNU/Linux distributions will benefit from such a bug-report/fix. If you decide to do so, you can use your openSUSE forum username/password when logging on to bugzilla.