Distro not detected

Yast did not detect Puppy Linux just installed on the same drive. How can I add it to my grub2 boot?

Thanks in advance.

DId you run yast-boot and be sure the detect foreign OS box is checked?? Change something change it back and accept to reinstall grub

Did that. No change. Also ran grub2-mkconfig in console. No change. By the way, I did ask the Puppy forum and their solution was to let openSUSE add it to grub2.

Ok is this EFI or MBR boot. Both OS must use the same methods

Which Puppy version? Older ones used Grub Legacy rather than Grub2. I wonder if current evolution of openSUSE installer still supports finding installations using Grub Legacy.

Based on Puppy’s target userbase, I’m pretty sure it didn’t get installed UEFI.

Has anyone here attempted to use Grub2-efi’s 40_custom to boot a kernel & initrd from a Legacy/MBR installation? I had a chance to try last week, but didn’t think of it. Maybe that’s what I should try now…

MBR is being used.

Latest 64bit version Fossapup64

I added…

 menuentry Fossapup64 {   search --file --set root --no-floppy /fossapup64/initrd.gz
   linux /fossapup64/vmlinuz pmedia=usbflash pfix=fsck psubdir=/fossapup64/ 
   initrd /fossapup64/initrd.gz
} 

to /etc/grub.d/40_custom and invoked grub2-mkconfig. Rebooted. No entry for Puppy.

If puppy is MBR and openSUSE is EFI not sure how you can work it maybe a direct call to the puppy Linux kernel??? ie the old chain method.

Neither one uses EFI boot. Both MBR.

Is there a third party boot method I could use?

Did you scroll all the way to the bottom of advanced options? AFAIK, that’s the location where 40_custom entries begin. The reason I’m not sure is that I don’t use 40_custom. Instead, I copy it to 06_custom, which results in its entrie(s) beginning at the top of page one of the Grub menu. I don’t put anything directly into 06_custom. Instead I create /boot/grub2/custom.cfg myself. Done so, entries in it don’t require the running of grub2-mkconfig to incorporate any changes made to custom.cfg.

What I did:

  1. cloned 15.2 installation on 5.6GB logical partition from MBR HDD /dev/sdb33 to CSM-disabled 8GB GPT SSD partition /dev/sda18 (using DFSee)
  2. e2fsck -f /dev/sda18

  3. tune2fs -U random -L p18s1521 /dev/sda18

  4. resize2fs /dev/sda18

  5. mounted /dev/sda18
  6. made appropriate fstab alterations (100% LABELs, no UUIDs)
  7. added an appropriate entry for /dev/sda18 to Tumbleweed’s custom.cfg (Boot0000* opensusetw in UEFI BIOS)
  8. booted the cloned 15.2 right up
  9. rebooted clone successfully
  10. booted TW successfully
  11. booted clone successfully

This clone on sda18 will be my first target for zypper dup to 15.2.1.

Hi
Can you run the following command as root user;


os-prober

If no output, it’s an os-prober bug, you should raise a bug report that it can’t find it… openSUSE:Submitting bug reports - openSUSE

# os-prober
localhost:/home/ion # 

I will file a bug report later today.

I’ve added Puppy to /etc/grub.d/40_custom and now it shows up as a boot option which does not boot since initrd.gz is not in the root directory. This is what is in /etc/grub.d/40_custom…

#!/bin/shexec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
menuentry Fossapup64 {
   search --file --set root --no-floppy /fossapup64/initrd.gz
   linux /fossapup64/vmlinuz pmedia=usbflash pfix=fsck psubdir=/fossapup64/ 
   initrd /fossapup64/initrd.gz
}

Now my initrd.gz and other needed files are in /dev/sda3 which is unmounted. How do I point to them? Thanks in advance.

Bug report filed.

Hi
For reference: 1178020 – No output result os-prober

I tried installing puppy here, in a KVM virtual machine.

It works. But the setup is very non-standard. The installed system uses squashfs (a compressed file system), and most of linux is in that compressed system.

If I just look at the partition where it was installed, there is no “/etc”, so there is nowhere to look to find things unless you happen to know the internal structure of puppy.

That’s why “os-prober” cannot recognize it. It isn’t realistic to expect os-prober to find this system.

Then is there any way that os-prober can at least report that there is something there that is not configurable? And my next question (in post #15) is how do I add it manually?

I doubt it. That would require a significant change to os-prober.

On one of my system, I have Solus linux installed for EFI booting. And os-prober does find that, but fails to generate a boot menu entry. But Solus at least looks like a linux system, though it is hard to find the kernel/initrd for booting (unless you know where to look). When I mount the Puppy partition, it doesn’t even look like a linux system.

And my next question (in post #15) is how do I add it manually?

I can experiment with that.