Distorted Fonts in Firefox and Thunderbird

I have a Radeon R7 graphics card. Since the upgrade (new install) to 13.2 fonts in Firefox and Thunderbird (maybe other applications might be affected, too) are distorted. It is usually either the first letter of a word or one specific letter (ie g, o, s…) throughout the text. On other occasions certain letters simply go missing. For instance a text might be lacking u, a or some other letter. Interestingly, when I increase the font size, for a while everything seems okay. But then the distortions appear again and I have to decrease the text. What on earth is going on???

Somebody mentioned problems with garbled fonts (and the radeon driver) in another thread recently.

Upgrading to the latest packages from [noparse]X11:XOrg[/noparse] apparently fixed it for him.

If you want to try:

sudo zypper ar http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_13.2 xorg
sudo zypper dup --from xorg

But I cannot guarantee you that it helps of course.

Thanks for the tip. It almost works. Only very rarely do I now comer across a garbled letter, and if so then only in Firefox. Thunderbird now seems perfectly all right. I wonder what the reason for this glitch was/is, though.

A bug somewhere, that got fixed in the latest version?

Have you tried running Firefox with hardware acceleration disabled?

Preferences | Advanced | General and remove the check mark from “Use hardware acceleration when available”.