Display problems in FireFox while using zoom

Could someone help me to resolve display issue that I see in openSUSE 11.1?

I used Firefox 3.0.4 but I see the same issue in Opera. What I see is everything looks normal in Firefox when you get to any webpage. Example below is a Russian site, but you see the same issue on any page. When you try to zoom in on the page everything readjust the size (pitures, fonts),but picture degrates in quality so it is unplesant to see. Here is an example of a normal page without zoom. It looks normal:


Most of the time you can adjust View in FireFox by Zooming in/out (Ctrl ++/ Ctrl – )

See the same page after 2nd zoom:


Picture quality is degrates.

See the same page after 4th zoom:


Picture quality is degrates.

See the same pate after 6th zoom:

As you can see there is no issue with fonts. When you zoom in fonts adjust and look normal, but picture quality degrades with each zoom.

It is a dual-boot PC with Vista and openSUSE 11/1. I have Nvidia Video Card GeForce 7900GS with Nvidia Linux driver. The interesting part that I don’t see a problem on Vista. Firefox zooms in font and pictures and scales just fine. (no picture quality degradation)

I’d like to find a solution for this zoom/scale issue. I’d like to use openSUSE,but this thing just drives me nuts and I keep switching back to Vista that I dislike, but has good FireFox zoom in feature.

Any suggestions? Any soluitons? Have you seen that before?


Well,anyone? anyone?

The reason for that is simple: the picture is a fixed size and when you increase the zoom, the image must be zoomed along with it. You’re going to see the individual pixels – same as if you were to take that same image, open it in an editor (such as Gimp) and then zoom in on it. This isn’t a Firefox issue.

Go to that exact same Web page in Windows, open it with Firefox, and then use “CTRL-+” to zoom. As I recall, earlier versions of Firefox would increase the text and framing, but leave the images alone. If it zooms the image along with the rest of the page, though, of course the image will look “grainy.”

That is not the case my friend. I’m trying to compare APPLES to APPLES.

The same version of Firefox 3.0.5 in Windows and 3.0.5 in Linux. Windows zooms in and render pictures just fine, but openSUSE Firefox degrades the quality.

Anyone else who is not guessing by knows how to solve this issue?

Here is the example of the same page in Vista

No zoom, regular page:


See the same page after 2nd zoom:


See the same page after 4th zoom:


As you can see Firefox in Vista displays images a lot better while zooming.

The question stans: Does anyone knows how to resolve this issue in openSUSE 11.1?

Heh. I’m sorry if you think I’m “guessing.”

Because I had nothing better to do (and arguably need a life at times), I went into XP. I downloaded Mozilla 3.0.5 for Windows and upgraded to that version.

Here’s the key: I then set my screen resolution under Windows to the same thing that I use under Suse (1680 x 1050). When I zoomed, the pictures became grainy and ugly-looking. I’m not going to bother to post them here; if you choose not to believe me, that’s fine.

Pixels is pixels. You CANNOT expand a 100x100 pixel image to 200x200, and then to 400x400, without it becoming increasingly ugly. (At least, not without some really sophisticated rendering algorithms; maybe someone makes a plug-in for Mozilla, or an advanced driver for Linux, that will do this. I’m not aware of one, though.)

As said, pictures don’t scale well.
With the exception of vector graphics which were designed to do just that. They can’t display something like a photo though.

Font’s are similar to vector graphics in that they scale well, I think the image render / scale thing is OS based as I remember a ‘dangerous’ bug in the .jpg implementation of windows affecting nearly everything… including browsers.

According to this site the quality was upped once, but seeing the date of the article I’m afraid you already have a version that has the ‘good’ quality.

Excellent point. I should’ve mentioned that.

Incidentally, I was already familiar with this particular issue, which is why I responded. In the past, I’ve deliberately kept my resolution low (1024x768 max) because I have trouble seeing the icons and text at high resolutions. In fact – gulp – I’ve even excoriated Suse/Sax for defaulting to the highest possible resolution and I’ve whined about how hard it is to reduce the rez with some video cards under Linux.

I bought a new wide-screen LCD monitor several days ago and had a brain storm. (Actually, a “well, duh!” moment.) I finally realized I could pump up the font and icon sizes to make the desktop acceptable to my old eyes.

I now have beautiful, delicious-looking fonts and an overall display that’s a work of art … but yup, in Firefox (or Konqueror, for that matter, or Internet Explorer under Windows), the images sometimes look gritty. In fact, the “login” button for this forum is almost unreadable. It’s a good thing I already know where it’s at … :wink:

compiz-fusion might actually be more than just eyecandy for you then, I’ve never found the windows key + mousewheel zooming all that great, but if you need a ‘closer’ look perhaps it’s of help to you.
(Personally I everything tiny, got fonts set to 8 or smaller, on a 15" 1680*1050 monitor :P)

Ouch! I can’t do that. I’ll be 53 years old on Jan 25th, and my old Mark 1 eyeballs just can’t squint like that anymore!!! lol!

I have exactly the same problem. It also affects opera browser.

Me too, when I use firefox windows, I zoom (ctrl +) and everything become larger and clear (images too).But in suse 1.11 images quality decreases whit zoom (also in firefox)!HELP!!! >:(

Well, the only explanation from community that I got is “just deal with it!” “Linux is still better” >:(

All I know that on the same PC in Vista Ctrl + works and images increase and look nice no matter how many times an click Ctrl ++ ( obviously it’s zooms in too much image quality degrades a bit), but in openSUSE 11 or 11.1 image quality degrades after first Ctrl +. It is hard to see.

Please don’t tell me it is ok!!! It is NOT! If there is an issue with openSUSE it needs to be addressed.

I’m still looking for a solution. I would like to use openSUSE, but just can’t do it without resolving this issue.

Help! Anyone?

Did you install your graphic card drivers? And what graphic cards are you using?

I could be telling a whole bunch of nonsense here and I got no source to back it up… but maybe (again I got nothing to back this up) a simpler scaling algorithm is used when you don’t install your videocard drivers resulting in poor image quality.

If you provide some source image accesseable to use both we could see if the zooming results vary as I don’t think I’m experiencing worse scaling myself under linux… but I rarely use the feature. (and when you post a screenshot of the image yourself make sure to save it as png, as jpeg is not suited for comparing image quality)

I provided that info in the first post:

>>>>>It is a dual-boot PC with Vista and openSUSE 11/1. I have Nvidia Video Card GeForce 7900GS with Nvidia Linux driver.

png or jpg format is not an issue here. I already posted all the pictures. It is obvious when you compare them. The issue is still there.

Anyone could share picture quality in openSUSE 11.1 with
1 Ctrl ++
2 Ctrl ++
3 Ctrl ++
4 Ctrl ++
5 Ctrl ++

I tested on 4 different PCs inclusing beta SLES 11. Result is the same: in Firefox 3.0.5 or .6 after zooming using Ctrl ++ quality of images degrading and after awhile it is painful to watch.

Anyone, anyone on openSUSE side could provide answer to this problem? Axeia please no more nonsense!

I added a bug at bugzilla.novell.com


Please add any other comments on that page and Vote to increase visibility of this bug.

I have the same problem too and find it very annoying - i’ve browse to find a fix but the only way to make it a bit better is to use the firefox extension called No Squint


this is a weird problem - it’s only in firefox,the problem doesn’t occur in Konqueror

if there is a real fix please let me know

(using nvidia 172 drivers / tried with 180 new version > same problem - geforce 7300 gt)

laskagifts you are absolutely right i have exactly the same problem with you in openSUSE 11.2 dual boot with Win7 on an AthlonXP with NVIDIA Gf6200 neither the driver upgrade gave a resolution on that problem. I assume it might be a firefox 3.5.8 problem or at least openSUSE’s Firefox customization. I’m strugling to avoid uninstall and reinstall a fresh download of Firefox. On my previous Linux version (GUbuntu 8.04 LTS) did not met any such problems even with older Firefox’s versions

I think that a good bypass on that problem could considered the option of Zoom Text Only in firefox menu bar. Go to (View>Zoom>Zoom Text Only ] check the box)

I am using openSUSE 11.2 64-bit and in Firefox (version 3.5.8) image zooming is a very real problem! Ubuntu 9.10 Firefox had the same problem but was easily fixable with this: https://launchpad.net/~firefox-smooth-scaling/+archive/ppa

Why doesn’t openSUSE 11.2 have a fix for this issue also???