Display problem caused by desktop effect

Dear All,

My current linux distribution is OpenSuse 11.2 with KDE desktop. I need to use one opensource code, as Atomeye to display atomistic simulation data. It works well when the driver of graphics card is not installed. In order to enhance the display effect, e.g., display speed, I installed graphics card driver by following command:
zypper ar http://download.nvidia.com/opensuse/11.2 nvidia
zypper install x11-video-nvidiaG02.

However, the figure in the poped windows looks like semitransparent, you can check from the picture
RapidShare: 1-CLICK Web hosting - Easy Filehosting
If I turn off the desktop effect, the display effect looks rather normal, although the color of atom is black (should be orange), please also refer the picture
RapidShare: 1-CLICK Web hosting - Easy Filehosting
(Note: I didn’t find out where I can upload the attachment, so I have to store the pictures in Rapidshare. Sorry for that.)

So, my question is, I want to turn on the desktop effect, meantime I want to enable the display of atomistic data normal, what should I do with desktop configuration? Thanks in advance!

Best regards,
Damien

I can’t be bothered looking at those files I have to jump thru too many hoops.

Use imagebam.com in future

Is it that you want to turn off transparency ?

System Settings - Desktop - All Effects
Configure settings in there

Hi, caf4926, pictures are uploaded in imagebam. I hope this time you can check them.
Case of desktop effect turned on:
http://www.imagebam.com/image/825f8463911692
Case of desktop effect turned off:
http://www.imagebam.com/image/52ba5863911693

Yes, I want to turn off this transparency. But the problem remains even I turned off transparency in the Desktop–All effects.

Might be worth a reboot. Then post this from a su terminal

hwinfo --gfxcard

The problem remains in spite of reboot the system. The information obtained by “hwinfo --gfxcard” is following:

junjiz3k@linux-ddxz:~/test> su
Password:
linux-ddxz:/home/junjiz3k/test # hwinfo --gfxcard
24: PCI 400.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_10de_393
Unique ID: YmUS.YXgOH4JclY2
Parent ID: vSkL.3Sm+eIMUHVE
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:04:00.0
SysFS BusID: 0000:04:00.0
Hardware Class: graphics card
Model: “nVidia GeForce 7300 GT”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0393 “GeForce 7300 GT”
Revision: 0xa1
Driver: “nvidia”
Driver Modules: “nvidia”
Memory Range: 0xdf000000-0xdfffffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (rw,prefetchable)
Memory Range: 0xde000000-0xdeffffff (rw,non-prefetchable)
I/O Ports: 0xe800-0xe87f (rw)
Memory Range: 0xddfe0000-0xddffffff (ro,prefetchable,disabled)
IRQ: 16 (41097 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd00000393sv00000000sd00000000bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: nv
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #10 (PCI bridge)

Primary display adapter: #24

I’m not familiar with: Atomeye

And not quite sure what you are trying to achieve.

The first picture seems OK to me. What is wrong with it?

Dear Caf4926, simply in one word, now I know I get what I want by turning off desktop effect.
Thanks all the same for your warm reply and help!

I’m guessing he did not want a transparent tool bar. Instead of turning all effects off he could have chosen a different theme with a solid bar. Or kept the theme for all but the bar and used a solid bare theme for that.