Display Issue

Hello, guys. I’m new to SUSE and Linux as a whole, and I’ve been trying to get familiar with this over the past 24 hours or so. :\ I assume I’ve been somewhat successful in what I’m attempting to do, as I can work my way around a bit now and use some terminal commands.

However, there is this display problem I seem to be encountering with certain windows which is extremely putting off. When I click options like ‘File’ or ‘Edit’ in a window, this is what I get. Here are the screenshots below.



This is what I get when I click the ‘Volume’ button in the Panel at the bottom of the screen.


I have no idea why this is happening. I have tried changing the Desktop Appearance Settings, Theme Settings but nothing seems to work. Although this is not a performance issue, it is hampering my vision of the various available options, and I would like to resolve it at once.

Thanks a million beforehand. And I’m sure to have millions of other doubts in days to come.

Typically such problems are related to either :

  • desktop software
  • desktop configuration
  • graphic hardware
  • support for the graphic hardware

I have even seen such effects when one had put in place a new graphic card and the PC did not have the power to drive the graphic card.

Please, what :

  • desktop ? KDE ?
  • graphic hardware ?
  • graphic driver ?
  • are special desktop effects disabled ?

Yes, I am running KDE.

My graphics hardware is an NVIDIA GeForce GT 540M - 1 GB.

And I am using an Intel graphics driver, though I am not aware of how to find out its exact specifications.

And yes, special desktop effects are disabled. Though, if I enable it, I see no difference.

You have nVidia GeForce GT 540M graphics, but you are using an Intel Graphics driver ? That is unusual.

Is this a PC with hybrid graphics ?

Please, what is the output of:

/sbin/lspci -nnk | grep VGA -A2

Further to my request/question above, is this an openSUSE-11.4 PC with KDE-4.6.0 or have you installed some other KDE version?

Yes, I tried lspci too. I got this.

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
Subsystem: Acer Incorporated [ALI] Device [1025:0507]
Kernel driver in use: i915

01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:0df4] (rev a1)
Subsystem: Acer Incorporated [ALI] Device [1025:0507]
Kernel driver in use: nvidia

Just for the record, my laptop has an Intel(R) Core™ i7-2630QM processor, at 2.00 GHz and 8 GB of RAM. Decent enough to support any graphic detail, I guess.

Also, this is openSUSE 11.4. I am however not sure of the version of the KDE being used. How do I check this?

OK. That is clear. You have hybrid graphics.

You are doing well. GNU/Linux struggles with hybrid graphics, and you have hybrid graphics (ie two different graphic devices). Are you using bumblebee to cope with your dual graphic setup ?

We are sorely in need of a user who is successful with hybrid graphics to write an appropriate guide for our openSUSE GNU/Linux users.

Look for the “My Computer” icon on your openSUSE desktop. Click on that. It should tell you your KDE version.

But my guess is this is a Hybrid graphics issue, possibly caused by power management, or caused by the driver struggling with two different graphic devices in use simultaneous.

I’m not sure if this is a hybrid graphics issue, or an issue at all with my graphics hardware of drivers, but is merely an ‘Appearance’ or ‘Theme’ setting gone wrong. I have no idea, though.

Yes, my KDE version is 4.6.0. Nothing unusual with that.

And no, I hadn’t used Bumblebee until you mentioned it. I immediately went and tried to download the appropriate repository. Is the following Terminal command correct?

sudo zypper addrepo http://download.opensuse.org/repositories/home:/Ximi1970:/bumblebee/openSUSE_11.4/home:Ximi1970:bumblebee.repo

For which I got this:

Adding repository 'Optimus Support for Linux Through VirtualGL (openSUSE_11.4)' [done]
Repository 'Optimus Support for Linux Through VirtualGL (openSUSE_11.4)' successfully added
Enabled: Yes
Autorefresh: No
URI: http://download.opensuse.org/repositories/home:/Ximi1970:/bumblebee/openSUSE_11.4/

Am I doing the right thing? Forgive me for my ‘amateurish’-ness. I have only started with Linux from yesterday. I assume it will take me at least a month to gain some degree of proficiency. What do I do once I have downloaded the repository? Has the system been updated with this new installation?

No change come on adding Bumblebee, though.

This isn’t the only problem I am encountering with this computer. I am not sure if I am allowed to discuss about this here, but one of the several reasons I have tried to make the move from Windows is because my laptop keeps crashing when running Windows. I am able to run it normally for a few minutes, but soon after, large green-gray, horizontal and vertical lines appear across the screen and the laptop crashes. This does not happen when I am using Linux. Any idea why this is happening? Could this be related to the current problem I am facing on SUSE? Could it be a graphics-hardware related problem? I am befuddled.

I also used a desktop widget available with SUSE to check the temperature of my computer’s hardware. It shows 174 F. Is this normal? Seems extraordinarily hot to me.

One more thing though. Other than this particular display problem, I am encountering no other graphics-related problem when running Linux.

If you are worried it could be an ‘Appearance’ or ‘Theme’ issue, just create a new user account. Log on to that new user’s account and accept the DEFAULT settings. Does this problem still occur for that user ?

That is a bit strange. If it were me I would have sent:

zypper ar http://download.opensuse.org/repositories/home:/Ximi1970:/bumblebee/openSUSE_11.4/ repository-of-bumblebee

… but it appears what you applied worked so do NOT send the commands I noted.

. If you now go to YaST > Software > Software Repositories you will see that repository has been added.

If you now go to YaST > Software > Software Management > Repositories you should see the list of repositories on the left. Click on the Ximi1970-bublebee repos you added.

That’s good. You now have added a link to your software package manager so that it can see the file server with the bumblebee application.

If you look you will see:

   ] VirtualGL-2.2.1-34.1.x86_64.rpm                                     17-Jul-2011 21:18  881K   Details
   ] VirtualGL-devel-2.2.1-34.1.x86_64.rpm                               17-Jul-2011 21:18  7.4K   Details
   ] acpi_call-kmp-default-0.0.1git20110703_k2.6.37.1_1.2-2.1.x86_64.rpm 17-Jul-2011 20:57  7.8K   Details
   ] acpi_call-kmp-desktop-0.0.1git20110703_k2.6.37.1_1.2-2.1.x86_64.rpm 17-Jul-2011 20:57  8.0K   Details
   ] bumblebee-1.7.10-4.1.x86_64.rpm                                     12-Aug-2011 13:44   27K   Details
   ] libturbojpeg-1.1.1-7.1.x86_64.rpm                                   14-Jul-2011 23:22  174K   Details
   ] libturbojpeg-32bit-1.1.1-7.1.x86_64.rpm                             14-Jul-2011 23:22  134K   Details
   ] libturbojpeg-32bit-devel-1.1.1-7.1.x86_64.rpm                       14-Jul-2011 23:22   86K   Details
   ] libturbojpeg-devel-1.1.1-7.1.x86_64.rpm         

ie it looks to me that if you wish to use bumblebee, you need to install it.

But are you certain you need to use bumblebee ? Have you read what it is about ?

I can’t in all honesty compare MS-Windows to GNU/Linux. I left MS-Windows (on my home PCs) back in 1998 and so much has changed since now and then in MS-Windows. I would not even venture a guess.

I think you stated this to be a laptop. Hence I assume then it was designed properly and this is not due to insufficient power ? … although, maybe it is ? Could it be you have both the Intel and the nVidia graphic hardware powered at the same time (bumblebee may stop that) and that is causing a problem ? In truth ? I don’t know.