Display driver problem? how to restore system?

I don’t know how to use the vi, so I used the gedit (probable same result) so now the /etc/X11/xorg.conf.d/50-device.conf is like this
Section “Device”
Identifier “Default Device”

#Driver “radeon”

Driver “radeonhd”

Required magic for radeon/radeonhd drivers; output name

(here: “DVI-0”) can be figured out via ‘xrandr -q’

#Option “monitor-DVI-0” “Default Monitor”

After restarting I still cannot enable the Desktop Effects. Is there possible that the raedonhd depends on a package that was uninstalled with ATI?
is it maybe easer to reinstall the ATI drivers and try to solve the problems I did get there? Problems with playing videos and sometime freezing while playing, and when I shutdown I got stripes on half of the screen (lower part) and black the upper part and the system newer did turn off (ones I did try to press enter few times and then at last the system shutdown at the end.

I don’t think radeonhd fully supports 3D acceleration so I’d not expect to be able to use Desktop effects. The radeon driver is better at this and the propritary driver is best. I forgot if you are running 11.3 or 11.4. There was some problems as you describe in 11.3 I think it requires a kernel upgrade. But I use NVIDIA cards so perhaps I should leave it at that.

I am using 11.4. I don’t know what driver will install as defult on fresh install (I am new in Linux). But whatever that driver is it support the Desktop Effects (one of the thing that got me exiting to start to use openSuSE). Maybe it is raedon so I will try to change both the xorg.conf and the 50-device.conf to raedon and see what happen. Just want to ask before if the xorg.conf should look like it is (my post few minutes ago).

If you use the 50-device file you don’t need a xorg.conf file. the xorg.conf file will always override any other settings. I’d remove it or rename it and do the settings only in the newer 50-device.conf file.

The best way to get the desktop effects going is to use the ATI proprietary driver. As gogalthorp said (and I think I posted earlier) the opensource drivers may not give you the desktop effects — you’ll likely have to go to the closed-source driver.

If you go into Yast → Software —> Software Repositories, then Add, then Community Repositories, then enable the ATI repository that should get you started. After that, go into software update, let your system update itself (as it should install the ATI driver automatically)… then restart and you should be using the ATI driver at that point.

Sorry for all the trouble I am making for you but this still not work. And sorry for late reply. I have not very reliable internetconnection. My SonyEricsson MD400g (Roger) USB-airstick just stop working and I have to rely on my neighbor connection.
I have already installed the ATI drivers (ati-fglrxG02-kmp-desktop) and still I cannot activated the Display Effects??
Is it possible that when I uninnstalled the drivers that the process did uninstalled some package that it rely on and wont installed automatically again???
I see on boot messages this line
<3> 37.300990] fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
I don’t know if it can be something

Another thing
Do you have any clue why my USB airstick stop working. I haven’t touch anything there from configure it in the beginning.
I have SonyEricsson (Rogers) and I found info in the Internet how to get it working and after following these informations it worked fine until now. The 2 files that I configured in the beginning are unchanged so it must be something else. Now when I plug the USB stick in it will take about 20-30 seconds to show up on my desktop and that I think is normal (have always be like that) but after about 1 or 2 minutes then it will just disappear from my desktop. While it is still on the desktop I can see the connection in Network Manager and I try to connect to it but without success and then the device just disappear (from my desktop) and the connection will disappear from the Network Manager. It is just like I have unplugged the device but of course it is still there plugged in.

The changes I did in the beginning was to add a line in the /lib/udev/rules.d/77-mm-ericsson-mbm.rules

Sony-Ericsson MD400G

ATTRS{idVendor}==“0fce”, ATTRS{idProduct}==“d103”, ENV{ID_MM_ERICSSON_MBM}=“1”

and /etc/usb_modeswitch.d/0fce:d103 … add the following lines


After that the device worked perfectly until now (2 days ago after my neighbor turn of his wireless connection I did try to use my USB-aircard but like I said it has stop working).

Well now I am trying to find out why nothing work. I have all the drivers installed but still not able to enable the Desktop Effects.
Testing the driver (SDB:Radeon - openSUSE)

iceland@linux-y9he:~> glxgears
Segmentation fault

“Mesa - System for rendering interactive 3-D graphics” is installed

iceland@linux-y9he:~> glxinfo
name of display: :0.0
Segmentation fault

Both of this come up with fault so I don’t know??

Another thing is when I try to open the ATI catalyst Control Center it will come up with error window that say
“No ATI graphics driver is installed, or the ATI driver is not functioning properly.
Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig.”

Ok that is a clue. You did not install the driver correctly. Exactly how did you try to install it?

You can try this method.

  • install atiupgrade from my repo :
su -l
zypper ar http://download.opensuse.org/repositories/home:/please_try_again/openSUSE_11.4/ PTA
zypper refresh -r PTA
zypper in atiupgrade

  • rename /etc/X11/xorg.conf (although atiupgrade can use the current xorg.conf, but it won’t hurt)
su -l
mv /etc/X11/xorg.conf{,.bak}

  • reboot in runlevel 3 (text mode) by appending “3” to the boot options

  • login as root

  • type:

cd /tmp

  • Be patient. You need an internet connection for this to work at this point.

It will install the latest driver (and uninstall the one you installed from the ATI repo) and set up a basic /etc/X11/xorg.conf to use fglrx (the ATI proprietary driver). As soon as you start X or reboot you should have the latest ATI driver installed.

I did install ATI driver using the Install/Remove Software (same way as I did in the beginning). The first time I did install the driver I did ad the ATI repositories “http://www2.ati.com/suse/11.4/” and then it installed automatically. Then when I uninstalled it I did unselected the drivers (I did got some message but because before I did installed the driver everything work great so I ignored that message). Now I enabled the repositories and selected the drivers again and install, but somehow after installing the driver it is not working correctly.
I will try what “please_try_again” advice me to do and see if it will work out.
I will let you know after restarting.

I still haven’t success in please_try_again because even I will be automatically connected to neighbor wireless network when I boot my system normally, it seems that I will not connect automatically in runlevel 3. Why?? I don’t know. I tried several times and every time the connection to www2.ati.com failed. I tried then to boot normally and to do this in terminal but then it says this script cannot be run in X. I will try again in runlevel 3 but I think it is not working (have tried several times).
In meanwhile I see something in boot.msg that I have been wondering if it mean something.
everytime I when I boot my computer I notice one line in the booting
34.127963] fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
so I did open the boot.msg file and copy everything around that message as seen here. Is there something you can see out of this?

<6> 34.099999] [drm] Initialized drm 1.1.0 20060810
<6> 34.127824] [drm] radeon defaulting to kernel modesetting.
<6> 34.127827] [drm] radeon kernel modesetting enabled.
<7> 34.127959] checking generic (d0000000 1000000) vs hw (d0000000 10000000)
<3> 34.127963] fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
<4> 34.127990] Console: switching to colour dummy device 80x25
<6> 34.128334] radeon 0000:01:05.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
<7> 34.128339] radeon 0000:01:05.0: setting latency timer to 64
<6> 34.130788] [drm] initializing kernel modesetting (RS780 0x1002:0x9610).
<6> 34.130888] [drm] register mmio base: 0xFDFE0000
<6> 34.130890] [drm] register mmio size: 65536
<6> 34.131280] ATOM BIOS: B27722
<6> 34.131305] radeon 0000:01:05.0: VRAM: 256M 0x00000000C0000000 - 0x00000000CFFFFFFF (256M used)
<6> 34.131308] radeon 0000:01:05.0: GTT: 512M 0x00000000A0000000 - 0x00000000BFFFFFFF
<6> 34.132745] [drm] Detected VRAM RAM=256M, BAR=256M
<6> 34.132750] [drm] RAM width 32bits DDR
<6> 34.132867] [TTM] Zone kernel: Available graphics memory: 896564 kiB.
<6> 34.132869] [TTM] Initializing pool allocator.
<6> 34.132889] [drm] radeon: 256M of VRAM memory ready
<6> 34.132891] [drm] radeon: 512M of GTT memory ready.
<6> 34.132927] [drm] radeon: irq initialized.
<6> 34.132929] [drm] GART: num cpu pages 131072, num gpu pages 131072
<6> 34.133710] [drm] Loading RS780 Microcode
<6> 34.140603] radeon 0000:01:05.0: WB enabled
<6> 34.171886] [drm] ring test succeeded in 1 usecs
<6> 34.172041] [drm] radeon: ib pool ready.
<6> 34.172107] [drm] ib test succeeded in 0 usecs
<6> 34.172109] [drm] Enabling audio support
<7> 34.172119] failed to evaluate ATIF got AE_BAD_PARAMETER
<6> 34.172218] Radeon i2c bit bus 0x90: Test OK
<6> 34.172317] Radeon i2c bit bus 0x91: Test OK
<4> 34.172341] Radeon i2c bit bus 0x92: bus seems to be busy
<3> 34.175010] [drm:radeon_i2c_create] ERROR Failed to register bit i2c 0x92
<4> 34.175021] Radeon i2c bit bus 0x93: bus seems to be busy
<3> 34.178010] [drm:radeon_i2c_create] ERROR Failed to register bit i2c 0x93
<4> 34.178015] Radeon i2c bit bus 0x14: bus seems to be busy
<3> 34.181007] [drm:radeon_i2c_create] ERROR Failed to register bit i2c 0x14
<6> 34.181095] [drm] Radeon Display Connectors
<6> 34.181097] [drm] Connector 0:
<6> 34.181098] [drm] VGA
<6> 34.181100] [drm] DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
<6> 34.181102] [drm] Encoders:
<6> 34.181103] [drm] CRT1: INTERNAL_KLDSCP_DAC1
<6> 34.181104] [drm] Connector 1:
<6> 34.181105] [drm] DVI-D
<6> 34.181106] [drm] HPD1
<6> 34.181108] [drm] DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
<6> 34.181110] [drm] Encoders:
<6> 34.181111] [drm] DFP1: INTERNAL_KLDSCP_LVTMA
<6> 34.264058] usb 1-5: new high speed USB device using ehci_hcd and address 6
<6> 34.285443] [drm] radeon: power management initialized

Another message (not related to ATI but can be related to my USB aircard is here)
47.498459] /usr/src/packages/BUILD/kernel-desktop- usb_submit_urb(ctrl) failed
The problem with my SonyEricson MD400g device is that first when I plug it in then I cannot connect (and no leeds on the device). Then if I "savely remove device) and removed from the usb and then reconnect it, I will get the leeds when I try to connect. But getting the leeds - the device will dissaper (both from the network manager and from my computer (the flash drives)) and I still will be disconnected. Soon the leed will stop flashing and even if I unplug the device and repluged in, it will not show up again. Only when I have restart the computer I can get it up again (but of course like before, not able to make connection).
and here is arounded lines
<6> 34.754870] usb 3-1: New USB device found, idVendor=15d9, idProduct=0a41
<6> 34.754874] usb 3-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
<6> 34.754877] usb 3-1: Product: USB Mouse
<6> 34.762085] input: USB Mouse as /devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1:1.0/input/input0
<6> 34.762197] generic-usb 0003:15D9:0A41.0001: input,hidraw0: USB HID v1.10 Mouse [USB Mouse] on usb-0000:00:12.0-1/input0
<6> 35.093206] usb 3-3: new full speed USB device using ohci_hcd and address 3
<6> 35.239903] usb 3-3: New USB device found, idVendor=0c10, idProduct=0000
<6> 35.239907] usb 3-3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
<5> 35.381506] scsi 6:0:0:0: Direct-Access Generic USB SD Reader 1.00 PQ: 0 ANSI: 0
<5> 35.382959] scsi 6:0:0:1: Direct-Access Generic USB CF Reader 1.01 PQ: 0 ANSI: 0
<5> 35.383586] sd 6:0:0:0: [sdb] Attached SCSI removable disk
<5> 35.384712] scsi 6:0:0:2: Direct-Access Generic USB xD/SM Reader 1.02 PQ: 0 ANSI: 0
<5> 35.385463] sd 6:0:0:1: [sdc] Attached SCSI removable disk
<5> 35.386592] scsi 6:0:0:3: Direct-Access Generic USB MS Reader 1.03 PQ: 0 ANSI: 0
<5> 35.387209] sd 6:0:0:2: [sdd] Attached SCSI removable disk
<5> 35.388577] sd 6:0:0:3: [sde] Attached SCSI removable disk
<6> 35.624199] usb 4-1: new full speed USB device using ohci_hcd and address 2
<6> 35.774347] usb 4-1: New USB device found, idVendor=03f0, idProduct=0317
<6> 35.774351] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
<6> 35.774354] usb 4-1: Product: HP LaserJet 1200
<6> 35.774356] usb 4-1: Manufacturer: HewLett Packard
<6> 35.774358] usb 4-1: SerialNumber: 00SGCD198360
<6> 36.004191] usb 3-2: new low speed USB device using ohci_hcd and address 4
<6> 36.162922] usb 3-2: New USB device found, idVendor=1c4f, idProduct=0002
<6> 36.162926] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
<6> 36.162928] usb 3-2: Product: USB Keykoard
<6> 36.162930] usb 3-2: Manufacturer: USB
<6> 36.179267] input: USB USB Keykoard as /devices/pci0000:00/0000:00:12.0/usb3/3-2/3-2:1.0/input/input1
<6> 36.179372] generic-usb 0003:1C4F:0002.0002: input,hidraw1: USB HID v1.10 Keyboard [USB USB Keykoard] on usb-0000:00:12.0-2/input0
<3> 47.498459] /usr/src/packages/BUILD/kernel-desktop- usb_submit_urb(ctrl) failed
<4> 47.498624] generic-usb 0003:1C4F:0002.0003: timeout initializing reports
<6> 47.498732] input: USB USB Keykoard as /devices/pci0000:00/0000:00:12.0/usb3/3-2/3-2:1.1/input/input2
<6> 47.498835] generic-usb 0003:1C4F:0002.0003: input,hidraw2: USB HID v1.10 Device [USB USB Keykoard] on usb-0000:00:12.0-2/input1
<7> 47.579862] PM: Marking nosave pages: 000000000009f000 - 0000000000100000

Is my problem very big?? should I just reinstall my openSuSE system? or can everything be fixed in Linux (openSuSE)

That the script cannot be run in X is normal (I actually wrote this error message :wink: ). You’re not connected in runlevel 3 because you’re using the networkmanager (I guess). You can try to configure your wireless device to use dhcp but without the network manager and see if it does connect in console mode. … Or - if you’re not currently using another fglrx driver - you can try to run the script in X after commenting out these two lines (by inserting a “#” at the beginning) in the file /usr/bin/atiupgrade:

# ps ax | grep -v grep | grep -q 'X ' && exec echo "this script cannot be run in X"
# ps ax | grep -v grep | grep -q -i 'xorg ' && exec echo "this script cannot be run in X"

I do not guarantee that it will succeed but it might bring you one step ahead: install the kernel sources, the needed tools and download the ati installer, compile the module and install the driver. aticonfig will fail but you can run it later while rebooting in console mode (you don’t need a network connection for that).

Ok now I have installed the ATI drivers and reboot. The system then boots to login prompt. What will I do next to be able to log in normally?

Let’s check if the proprietary driver is installed:

rpm -qa | grep fglrx

If it is installed, let’s check if we need to configure /etc/X11/xorg.conf:

sudo aticonfig --initial=check

If it doesn’t say Found fglrx section, let’s create one:

sudo aticonfig --initial

Then reboot normally.

rpm -qa | grep fglrx

sudo aticonfig --initial=check
check found fglrx section

I did make the third part too
sudo aticonfig --initial
found fglrx primary device section
using /etc/X11/xorg.conf
saving /etc/X11/xorg.conf.fglrx-0

I am now rebooting

I am restarting now

Reboot to login prompt again!!!
what next?

Log in as root, type:

init 5

Tell us what happens then.

linux-???# init 5

just nothing

what about “startx” (no quotes)?