Disk noise at shutdown

Hi everybody! I’m new to opensuse 12.2, everything worked out-of-the-box, but I have a little big problem that makes me worry…
Every time at shutdown the disk in my HP netbook makes a strange noise I’ve never heard on Windows. It seems it’s something related to the parking of hd heads at power off. I found a solution for Ubuntu here (if the issue is the same, as I think, even if the kernel here on opensuse is much newer).
The problem is that my /sys/class/scsi_disk/0:0:0:0/ folder doesn’t have a stop_on_shutdown file.
Anyone experienced the same issue and/or knows a solution for this?

Ps: it seems the problem doesn’t happen if I hibernate (I tried a couple of times), only with regular shutdown.

Thanks a lot :slight_smile:

I see laptop-mode-tools is not installed by default, I’m going to install it and see if there is any option that can help me…

Nothing useful in laptop-mode, any idea?

Maybe read the whole thread

I only see it’s considered to be a bug in an old version of kernel, last message has been written in 2011, fixed somehow in some ubuntu distros (but I’m not using Ubuntu :stuck_out_tongue: ), no solutions apparently (I thought it has been already fixed in the last 4 years), am I missing something?

The thing is: the problem doesn’t appear on some (ubuntu) distros, so maybe there is some software tweak that can be fixed with some sort of hard disk setting… without trying to rebuild kernel or some other painful (maybe useless) solutions I would better avoid…

I only see it’s considered to be a bug in an old version of kernel
I agree

so maybe there is some software tweak
Don’t know, but seems unlikely

Trying a different kernel is pretty simple for integrated graphics
It’s a little more work otherwise

There is a setting, but it defaults to “yes”. Check the value on your system. Go

  • Yast
  • System
  • Sysconfigeditor
  • Search for “HALT_DISK” and review the option. It should be set to “yes”.

It’s set to yes… but I found other interesting settings there, like HALT_POWERDOWN_INSERT. Not sure it is what I’m looking for, but I also found out there is a command for hdparm that force the hd into standby mode… now I was thinking of a way to issue that command right before the system power off, in this way the hd’s heads should be already parked, is this correct? Do you know if that option is the way to execute the command?

I’d like to try any reasonable way before working on the kernel :stuck_out_tongue: