Disk Cleanup

My “/” partition is getting smaller and smaller, but I don’t install any new applications. Why is that? Is there a way to clean up unnecessary files?

This can help
Clear Temp Files at Boot

Thanks, caf4926. I didn’t want to set Max_Days_In_Temp to 1, but I changed the Clear_Temp_Dirs_AT_Bootup to yes. I’ve also installed “bleachbit”, which is an excellent application, I’ve got 500 mb freed instantly :slight_smile:

On 06/17/2011 08:36 AM, riderplus wrote:
>
> Thanks, caf4926. I didn’t want to set Max_Days_In_Temp to 1, but I
> changed the Clear_Temp_Dirs_AT_Bootup to yes.

so what are max days set to?

i ask because mine is set to one–by design, there should be nothing
left in /tmp that is needed by any program or part of the system through
a boot…

so, i really want it empty /tmp on every boot, and at least it will do
that if i boot once a day…

I’ve also installed
> “bleachbit”, which is an excellent application, I’ve got 500 mb freed
> instantly :slight_smile:

check your log files (/var/log)…sometimes you have a problem you
might not know about which is feeding info into /var/log/messages over
and over and over…and it can get pretty big pretty quick…

assuming you have been running without reinstalling since your february
arrival i’d say if your ‘messages’ (not ‘localmessages’) file is over
(say) 7 to 10MB you really need to take a close look…look for long
strings repeated lots of times…or search on the word ‘error’…but,
be advised to ask before you jump because “fixing” some ‘errors’ might
be a nice way to break things more…

and, maybe you need to set up your logrotate to pack down and/or delete
logs so old you don’t need them…(i just realized i need to do that also)

by the way, i don’t use bleachbit…i used something like it in windows
once (in '95) and never did that again!


dd
http://is.gd/bpoMD

Thanks for this, DenverD. The max days are set to default (0). I don’t have any error messages from what I could see.

You know of course that although zero is less than one, in this situation it is considerably more.

Actually there are, even though the file has only 1.3 mb…Just to give you some examples of errors:

Jun  5 11:50:47 linux-k3kh pulseaudio[2480]: alsa-sink.c: Error opening PCM device front:0: Device or resource busy

. Or

Jun  5 16:43:00 linux-k3kh kdm_config[1522]: Multiple occurrences of key 'UseTheme' in section [X-*-Greeter] of /usr/share/kde4/config/kdm/kdmrc

Or

Jun  7 00:02:42 linux-k3kh kernel:    15.166739] type=1400 audit(1307397758.874:10): apparmor="STATUS" operation="profile_load" name="/usr/lib/dovecot/deliver" pid=951 comm="apparmor_parser"

Or

Jun  7 16:33:14 linux-k3kh kernel: [32319.547099] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.

Any suggestions?

Yes, sure. I’ve read the comment posted by Akoellh on the page your link sent me to, that’s why I thought of being careful not to do anything wrong.

Is everything working OK?

What DD was meaning was something quite different. In that a error is cycling over and over every second or so and it fills your log. I have seen some massive log files in ‘messages’
I don’t think this applies to you.

I don’t think so. /etc/sysconfig/cron says:

cron.daily can check for old files in tmp-dirs. It will delete all files

not accessed for more than MAX_DAYS_IN_TMP. **If MAX_DAYS_IN_TMP is not set

or set to 0, this feature will be disabled.**

Maybe I don’t quite understand your comment, though.

That’s good news. I don’t know what’s with these errors, but they don’t affect me, so unless someone suggests anything I’ll just google them and try to find out what they are related to.
10x again!

Ok…the last one ([drm:intel_panel_get_max_backlight] ERROR fixme: max PWM is zero.) seems to be a bug reported here: https://bugs.archlinux.org/task/22663.
And there’s a
Comment by Jan de Groot (JGC) - Monday, 31 January 2011, 04:42 GMT-4
It’s a harmless debug message that was added to 2.6.37 to see if they actually needed that code.

You explain what you think that means. :smiley:

What it says. If set to ‘0’, this optiion is disabled and (when set) CLEAR_TMP_DIRS_AT_BOOTUP will manage to empty /tmp.

Maybe you did misunderstand my earlier comment, that or I really am thick as two short planks.

I kinda thought so. :smiley:

Sorry for the interruption.

On 06/17/2011 08:06 PM, riderplus wrote:
>
> The max days are set to default (0).

then your /tmp will never be emptied during boot…which is not i have,
or what you actually want…

recommend you set it to 1…and, then it be cleaned at the right time
during boot and be completely empty before needed…

otherwise, if you have a program crash while it has a file in /tmp, that
file will stay there forever (or until you remove it) [torrents, flash,
even YaST store downloaded stuff in /tmp while downloading and then will
normally either delete them when not needed (movie over) or move them to
the required location–unless aborted, crashed, etc]

NOTE: do not manually remove any file in /tmp while the system is
operating…unless you are absolutely certain it is not in use…(i would
never do it!)


dd
http://is.gd/bpoMD

On 06/17/2011 08:36 PM, riderplus wrote:
>
> That’s good news. I don’t know what’s with these errors, but they don’t
> affect me, so unless someone suggests anything I’ll just google them and
> try to find out what they are related to.
> 10x again!

sorry you misunderstood me, i was not clear enough (i guess)…i meant
as caf has already written…if you are having no problems, don’t make
problems trying to fix something not broke

but 2000 of the same thing with little in between IS a problem…

and 10GB of those is a BIG problem when your / (root) directory runs
completely out of space…


dd
http://is.gd/bpoMD

Since overflowing tmp-dirs are apparently a wide spread problem i recently opened a feature request at openFATE to set CLEAR_TMP_DIRS_AT_BOOTUP to yes as default. I would like to see you going there and vote or discuss it.

On 06/18/2011 05:36 PM, tux93 wrote:
>
> I would like to see you going there and vote

i voted no! it should not be default…

let the system administrator set it, if needed…


dd
http://is.gd/bpoMD