Disk/Boot Issues

Hello,

Last night I installed a second hard drive along with windows 7 and openSUSE. The Windows 7 partition consisted of one hard drive and openSUSE the other hard drive. Windows installed with no problems and booted and then openSUSE installed with no problems and booted. I restarted my computer to boot back to windows and windows kept auto restarting. I tried to turn off auto restart and see what error messages I was getting but it would still auto restart. I could still boot to openSUSE so I figured it might have been something odd with windows so I went to boot from the Windows 7 disc to reinstall. I couldn’t get anywhere with the windows 7 disc so I tried to repartition the problematic hard drive using openSUSE, but that failed to work. I figured at this point that there must be something wrong with the hard drive so I ran a few diagnostic tools, such as badblocks, and they all told me the hard drive was in perfect working order. At this point I am lost about what to do next. It is very odd that windows 7 ran excellent last night for a few hours while I set up a few programs but as soon as I installed openSUSE I couldn’t boot to windows. If anybody could offer me any insight about possibilities that I could try next to rectify the situation I would be really grateful.

Are you currently able to boot openSUSE?
What version is it 12.2?

Do you know what order the HD’s are in the BIOS?
Make sure you do
Then see if windows will boot if you disconnect the SUSE HD

Yes I am still able to boot into openSUSE and I am running 12.2. I disconnected the hard drive that openSUSE was on and I was able to reinstall windows on the other. Now my problem is how do I get grub to recognize the new hard drive with windows on it. I can boot to either OS depending on which drive is set to boot from in bios. I suppose this is more of a boot issue now instead of a hardware problem.

I am not sure about 12.2 but earlier opensuse had an repair option.

I used it after I had to reinstall windows, which overwrites the mbr.

I’ve fixed the issue with grub but now I am back to my first issue again. Windows auto restarts whenever I try to boot to it from grub. If I change the boot order to the hard drive that windows resides on then it boots straight to windows and has no problems. If I boot to the hard drive that contains grub, then openSUSE will work but windows tries to auto restart. Am I having a problem of a boot record for windows existing on the other hard drive when they should both be on my primary drive? If so I have no clue how to fix that issue.

This sounds odd and it’s not something I recall.

So at a starting point of having windows up and running. On it’s own, with just this HD, this HD is termed sda.
Connect the openSUSE HD and it should be, needs to be sdb.
Thing is, when you connect a HD it can change the BIOS settings. So go check the Windows HD is 1st and the openSUSE one 2nd.
This should make it sdb (windows will refer to as D or similar letter)

So this should give us a system running windows from sda and have an additional HD sdb

If you now boot the openSUSE DVD and install openSUSE to sdb
(if openSUSE doesn’t seem to have the HD order correct or as you would expect sda=windows… you better come back here for advice)
Follow the basic principles found here: https://docs.google.com/open?id=0B3e0lLG3OdqEY0NVdWRnWGluMFE
Then at this part: https://dl.dropbox.com/u/10573557/12.2_liveCD_Install/13_Install_Summary.jpeg
Click the section title ‘Booting’ and make it look like this: https://dl.dropbox.com/u/10573557/Grub2_Project/C1.png
Now proceed with the install.

On 2012-12-21 05:16, caf4926 wrote:
>
> This sounds odd and it’s not something I recall.

When windows disk is the first disk, it boots. When it is the second
disk, and booted from grub in the first disk, it does not boot. Wasn’t
there a setting in grub to reverse the disk ordering?


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Hi,
I am a little confused and request confirmation on :
a) You have two physically separate hard disks, sda and sdb as identified by linux.
b) Are both internal? In any case the BIOS (or whatever you have in its stead) will always identify one as the first depending upon the connector order on the motherboard.
c) If the disk with Windows 7 is first in booting order you boot into Windows without a problem.
d) Presumably your bootloader is Grub 2 or is it Legacy Gub?
e) Which ever bootloader, booting from the Linux disk you are presented with the menu?
f) If you select openSUSE option you are able to boot into it without a problem?
f) When you select Windows 7 from Grub menu the Windows OS keeps restarting? What exactly happens? To what point does Windows load when it restarts. That is do you reach the login screen before restart?
g) Or is it that the Grub menu goes off and comes on again?

If it is (g) above then your problem is with the Grub entry not pointing to Windows booting partition!

If it is (f) the issue it would appear is more complicated. It would mean that the Grub entry is pointing to a defective install of Windows in a different partition, while the normal booting partition reached by BIOS is OK. Could be worthwhile to check the partitions on sda(?)

PrakashC

I finally fixed the problem. I switched the SATA cables to change the boot order because I couldn’t do so in bios. I reinstalled windows onto sda and then openSUSE on sdb. The master boot record was installed onto sda and it works completely fine. I guess it was just an issue of GRUB2 being installed on sdb instead of on sda. Thank you for all your help and suggestions!

Well done !