Discussion thread openSUSE 42.3

Hi all,

The release of openSUSE 42.3 is due, please share your experiences, good and bad, here. This thread in Chit-Chat on purpose.

To start: installed both KDE and GNOME from the last iso before the released one ( build 330, the release is build 331 ), ran zypper dup && zypper patch. Very, very pleased with what I see. Setup some default stuff ( webserver, phpMyAdmin, salt-minion ), not a single flaw so far.

I’m currently upgrading via zypper dup, so cannot say much yet (not that I expect any problems :wink: ).

I noticed one thing though:
Packman’s 42.3 repo is not fully up-to-date yet.
In particular, they still have vlc 2.2.4, while 42.3 ships with 2.2.6.

Not a “big” problem" per se, unless you (want to) use the VLC backend for KDE’s Phonon. You’ll get a conflict when trying to install it.
Ignoring the conflict should be fine though and should work, I don’t think there were breaking changes in that minor version upgrade. (I cannot speak of experience yet though, I will report after the upgrade has finished.)

PMBS (Packman’s build system) does have 2.2.6 already (actually a link to the 42.3 package on OBS), so it’s just a matter of time until it gets published on the mirrors I suppose.

I’m not too familiar with the version numbers, but some VLC users will be glad with this news. What I did re. install is no more than defaults, import partitioning, users ditto, add LAMP server and GNOME to chosen KDE install, do it, zypper dup ( iso 330, release is 331 ), zypper patch. Added some online accounts on both DE’s , added Packman, ran zypper --from on that repo ( ssht, installed ffmpeg too ) and so on. IMHO a procedure that shows a lot of side options, but is quite straight forward. Helped out a new user today, let her do the install with KDE on her own ( dead HDD in her laptop, replaced with an SSD. ). She’s a total end-user, just clicked on and on, results as it should be. Let her do the same ( clean ) install with GNOME, and that one she actually completed without any issues. I left a proud new user, with both GNOME and KDE.

Hi!
I can only agree and as I have written before, it looks good.

It was a period(different builds) that I was not sure what was happening,-neither my main PC or my work laptop was even near to start the installation process. Stopped at:
“75% searching system files”.

I have no problems with build 322. There is tools to help users to upgrade both on the medium and in wikis.

The only other problem that I had is with VirtualBox from Oracle. As I(and others) have written(and test) in another tread that the version in the repo works fine in Leap 42.3. It is up to Oracle to adjust their version (from Leap 42.1!). Wouldn’t mind to have the extension pack as well in the repo for 42.3.

Sorry for my lousy English.

Regards

I don’t think that’s possible.

42.3 ships with kernel 4.4.x, but has backports from later kernels that are incompatible.

The virtualbox package from the standard repos contains a patch to adapt to that (but it would likely be broken on a standard 4.4.x kernel I suppose).

At least that was the problem a while back. Apparently the latest kernel is compatible enough so that the kernel modules build, but I don’t know if they also work too.

See 1047215 – Cannot install Oracle Virtualbox 5.1.-5.1.22_115216 : Kernel installation is not valid
The last comment by the reporter is “Correction : Does not work.The virtualbox Gui opened, but vbox services does not run.”
Could just as well have a different reason too though.

Wouldn’t mind to have the extension pack as well in the repo for 42.3.

The extension pack is closed and proprietary software, and therefore cannot be shipped in the distribution.
And I think Oracle doesn’t even allow redistribution at all.

Hi!

The extension pack is closed and proprietary software, and therefore cannot be shipped in the distribution.
And I think Oracle doesn’t even allow redistribution at all.

Ups, I did not think of that! Why are I’m asking? Vrdp.

Rest of your post I’m moore or less aware of.

Nice that the forum have “rev” up on the upcoming of Leap42.3;).

Regards

I’ve been running 42.3 on my main desktop for around 2 weeks now. I’ve been using “zypper dup” to update it.

Thus far, it is looking pretty good. The one exception is “konqueror” which seems buggy. I also installed “webenginepart” which allows “konqueror” to use QTWebEngine, and that works reasonably well. But if I set it to use WebKit, then it doesn’t work well with opensuse forums. And there’s some weird interaction that messes up any open “xterm” session. If I login to a site while using WebKit, then switch to QTWebEngine, I am no longer logged in. If I switch back to WebKit, I am again logged in. It seems that the cookies are not shared between WebKit and QTWebEngine interfaces.

The only other problem that I am having is with “gapcmon” (in KDE Plasma 5). That was working fine until I setup a printer. To setup the printer, I had to install “hplip” which sits in the tray. And, after that, “gapcmon” no longer wants to set in the tray.

A bit more detail on “gapcmon”. If I set it to autostart (in “Startup and Shutdown”), then “gapcmon” starts but is not in the tray. If I manually start it later in the session, then it runs but is invisible. I cannot see it in the tray. If I unset the “Use Tray Icon” setting, I can then start it manually and it remains visible. And if I then set the “Use Tray Icon”, it sometimes shows up in the tray. But I’ll have to remember to unset “Use Tray Icon” before logout, or I will have problems on the next login.

When I first ran “amarok” it complained about missing codecs. It tried and failed to install them. After manually installing everything that seemed relevant from packman, it is now working well.

Yes, I noticed that too (months ago already because I also tried the pre-release versions).
Probably a WebKit problem, the version coming with Qt5 is actually deprecated (in favor of QtWebEngine, based on Chromium) and not really developed since a long time (Qt 5.2?).

It has been revived though last year:

I’m looking forward to the first release… :wink:
(I wasn’t able to build and try the Alpha so far)

Most other sites work fine though with the current version AFAICT, and at least in my impression actually better than with the old Qt4WebKit.

We chose to keep WebKit as default because the webenginepart is still missing some integration, e.g. passwords cannot be stored (no kwallet support), and files are always downloaded to the ~/Downloads/ folder without asking (at least that has been fixed upstream a few days ago though)

And there’s some weird interaction that messes up any open “xterm” session. If I login to a site while using WebKit, then switch to QTWebEngine, I am no longer logged in. If I switch back to WebKit, I am again logged in. It seems that the cookies are not shared between WebKit and QTWebEngine interfaces.

No. They are completely independent things.

QtWebEngine is basically more or less an “embedded” Chromium without the GUI. (it even runs as separate process)

I have no idea whether it would even be possible to integrate it with KDE’s cookie jar (and daemon) that KHTML and kwebkitpart use TBH.

When I first ran “amarok” it complained about missing codecs. It tried and failed to install them. After manually installing everything that seemed relevant from packman, it is now working well.

At least mp3 support is now available in the distribution’s own gstreamer-plugins-ugly package itself. (though gstreamer-fluendo-mp3 is still available in the non-oss repo as well)
Unfortunately, that’s only installed by default in GNOME:
http://bugzilla.opensuse.org/show_bug.cgi?id=1049512
(has been noticed slightly too late for 42.3 final… :()

Shouldn’t affect upgrades though, and following any of the existing multimedia guides should “fix” it as well.

They are supposed to be independent.

After using konqueror/webkit a bit, my “xterm” misbehaved. If I typed some characters, the cursor moved but what I had typed did not show up. This has happened twice. It does not affect “konsole”, but it does affect “xterm” sessions. I have not tried to pin it down.

Perhaps konqueror was using the “xterm” fonts and messing up something with them. I’ve since changed konqueror fonts. I changed them to what they already are, but saved the change. Perhaps that will fix the issue. At least the appearance of konqueror pages looks different after that change.

QtWebEngine is actually more or less an “embedded” Chromium without the GUI.

Yes, that’s about what I guessed.

But there’s one thing missing with konqueror and QTWebEngine. It no longer shows that RSS feeds icon, which I had found useful. If I want that, I have to switch back to WebKit or KHTML.

Sorry, I’m not sure I understand what you mean here.

An xterm that runs in the same X session shows those problems? I don’t see how Konqueror/Webkit should cause this TBH…
Or did you start konqueror in this xterm?

But there’s one thing missing with konqueror and QTWebEngine. It no longer shows that RSS feeds icon, which I had found useful. If I want that, I have to switch back to WebKit or KHTML.

Right.
That’s a plugin for KHTML and kwebkitpart, shipped with konqueror (konqueror-plugins to be exact).

None of the plugins have been ported to webenginepart, and again I don’t know whether it is even possible.
OTOH, QtWebEngine does seem to be extensible, as kdepim shows (it uses QtWebEngine only since a while, and does come with some plugins like adblock).
Time will tell, I suppose.

Yes. And if I have two “xterm” windows, they both show the problem.

I don’t see how Konqueror/Webkit should cause this TBH…

I don’t either. But it happens.

Or did you start konqueror in this xterm?

I started “konqueror” from the menu (the “Internet” sub-menu).

Right.
That’s a plugin for KHTML and kwebkitpart, shipped with konqueror (konqueror-plugins to be exact).

I’m mostly making do with “firefox” for this function. I can hit CTRL-I on a page, and it gives me feed options. I’m currently using “vivaldi” where I would previously have used “konqueror” (i.e. as the browser for “akregator” to use). I’m using “firefox” for other browsing, including these forums.

In the meantime, I’ll occasionally experiment with “konqueror”.

Hi!

No not whining as usual:P but Knurprp`s post of:

I left a proud new user, with both GNOME and KDE.

Technical details rather belong in the mailling list of openSUSE. I know, -guilty my self sometimes. No I have never and never will post there.

Rev it up for ordinary users:)(forum).

Regards

Well, I don’t see how Konqueror or WebKit could possibly mess with other running applications’ fonts (or other things), especially if they are standard Xorg apps like xterm.
The only “explanation” I would have at the moment would be some graphics driver issue… (assuming that it is about fonts, but other interference is even less likely I think)

I will definitely try to verify that once my upgrade is finished (currently 3907 from 7914 packages updated, so tomorrow probably… :wink: ), but in that case I probably wouldn’t be able to reproduce it anyway.

You could maybe try if it happens in e.g. IceWM as well though.

Yes, I might try that. I’m not sure if I know how to reliably cause the problem.

While I think of it, there’s another minor issue with konqueror. There’s a setting “open tabs in background”. Since I want them opened in the foreground, I unchecked that. And tabs opened in the background. So I checked it again, and now tabs open in the foreground (except when opening a bookmark in a tab). So that setting seems to be reversed.

Hm, IIRC this used to work.
I prefer to having tabs opened in the foreground and definitely changed that setting when testing the pre-release versions.

But thanks for mentioning, I will check that as well and try to fix it.

For an update to 42.3 we’d need a bug report though, now that it’s finished… :wink:

Btw, I fixed one bug already today:
http://bugzilla.opensuse.org/show_bug.cgi?id=1049975
(introduced in KF5 in 2014! but nobody noticed so far…)

I’ll wait until the official release date.

Btw, I fixed one bug already today:
1049975 – konqueror/kcookiejar cookie settings not stored correctly
(introduced in KF5 in 2014! but nobody noticed so far…)

I noticed that bug report this afternoon (browsing the bugs mailing list). I think my cookie settings didn’t bump into the problem (yet).

Something else that I have noticed in the last few days. I sometimes see the screen flickering on an application. It looks like desktop effects gone wrong.

I’ve been using 42.3 on my main desktop for around 3 weeks, with no such problem. Then I started playing with konqueror, and I am seeing problems. That might be unrelated of course.

For the present, I have turned off desktop effects. And konqueror is doing fine (mostly). I did try login to opensuse forums with konqueror, but that is still broken. So I’m using firefox for this reply. On konqueror, I tried a “reply with quote” but the edit box did not contain any quote. It’s hard to know if that is a konqueror bug or a forums software bug.

Current plan – I’ll leave desktop effects turned off for 3-4 days, using konqueror. Then I’ll turn it on again for 3-4 days. Then I’ll switch to vivaldi browser with desktop effects on. This is to see if I whether that screen flickering occurs in any of those situations.

I have now turned of the WYSIWYG edit option for the forums. And now reply with quote works in konqueror (I’m using it for this reply)

Only the “Accept For Session” setting is affected, and only if you change it in Konqueror/KF5 (originally it should just be taken over from KDE4) ,a wrong value is written to the config file then.

Sounds like a graphics driver issue to me.
FWIW, I did notice something like that (in 42.2), but with QtWebEngine (also used by kmail), never with QtWebKit.

I did try login to opensuse forums with konqueror, but that is still broken. So I’m using firefox for this reply. On konqueror, I tried a “reply with quote” but the edit box did not contain any quote. It’s hard to know if that is a konqueror bug or a forums software bug.

As I wrote, I’d assume it to be a bug in QtWebKit.
But it’s obviously related to the JavaScript that the forums’ WYSIWYG editor uses…

I cant install or recommend Leap because of Steam lib issues.
Still running with

STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam