Disconnecting from Wireless networks when closing laptop lid (with external screen connected)

Hi, I’m relative newb so bear with me :slight_smile:
I’m running Leap 42.3 with KDE on my Asus Vivobook X556UQ and haven’t changed much aside from the kernel version

cesar@linux-fmap:~> uname -a
Linux linux-fmap 4.13.3-2.g38f3021-default #1 SMP PREEMPT Wed Sep 20 15:56:10 UTC 2017 (38f3021) x86_64 x86_64 x86_64 GNU/Linux

As I did before with windows I connected my external screen via VGA to the Laptop and close the lid so I can position the monitor on top of the Laptop due to space problems. However, whenever I do this I lose connection to my wireless network and it acts as if it can’t find any network (there are 2 I can usually see, although with weak connections). The connection is relatively weak, but it had never an issue in over a year (didn’t randomly disconnect and such). I can even move further away from the router to the end of the room and still have connection (which is like 1-2 metres away from my usual position). So I don’t really think the density of the lid covering the transmission point would be be the final straw on making the network unreachable, especially as I worked with the same setup on windows for several months.

hwinfo gives me this for my WLAN (removing Unique and parent ID just in case)

: None 00.0: 1070a WLAN
  [Created at net.126]
  Unique ID: censored tentacles
  Parent ID: more censored tentacles
  SysFS ID: /class/net/wlan0
  SysFS Device Link: /devices/pci0000:00/0000:00:1c.5/0000:03:00.0
  Hardware Class: network interface
  Model: "WLAN network interface"
  Driver: "ath10k_pci"
  Driver Modules: "ath10k_pci"
  Device File: wlan0
  HW Address: f0:03:8c:dc:fd:21
  Permanent HW Address: f0:03:8c:dc:fd:21
  Link detected: yes
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #23 (WLAN controller)

Anyone know what could cause this and what I should look at to fix it? Thanks for any help!

Not sure if there is a KDE setting, but there is in the file /etc/systemd/logind.conf and set the following;




This seems to have solved it. Thanks!