Disappearing Mouse after installing Catalyst drivers.

I just installed the ATI Catalyst drivers for my Radeon HD3200, and upon reboot my mouse has disappeared. I can still use it, it’s just that there’s no pointer on the screen. In addition, moving windows and loading/scrolling any window is very, very slow.

I also noticed there’s no entry for the mouse in xorg.conf

I have run aticonfig --intial and aticonfig --initial -f, to no avail.

Did you read here:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

In fact, have good look thru that thread, there are lots of comments too. ATI sounds to be problematic.

I did, but I’m not sure where I’d put the “option” line, and the second solution where a mouse wasn’t showing up didn’t apply to me, as that person was using a different driver.

You are running those after a direct boot to runlevel 3 I hope, and not after first going to run level 5 ?

And I hope you installed the appropriate proprietary driver when in run level 3 and not in run level 5 ?

No, no I did not. I’ve never used this distro before today, and am not quite sure what that even is.

Run level 5 refers to running with an X window desktop (ie Gnome, or KDE, or LXDE or Xfce … )

Run level 3 refers to running in a full screen text mode, with NO X window running.

To boot to run level 3, when the first boot splash/screen appears, press 3 and the 3 should appear in the options line. Then boot per normal selection and that will take one to a full screen text login. Then log in as a regular user, and once logged in, type “su” (no quotes) to switch to user root.

This is explained in the URL caf4926 passed to you in post#1: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

When one is ready to leave run level 3, one can restart the PC with root permissions with:

shutdown -r now

or one can halt/shut-down the PC with

shutdown -h now

Please do not take this wrong, but I think it might be useful to re-read that post#1 here openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums as I think maybe you missed some things in that post.

Here is also some basic openSUSE concepts: Concepts - openSUSE

Thank you for the explanation.

Also, the thread I was linked to is not at all the thread I thought it was, I guess I wasn’t paying enough attention there.

Ok, I have looked over the thread, and reinstalled the driver at runlevel 3, then ran

aticonfig --initial

in runlevel 3, and rebooted with

shutdown -r now

I still have no visible mouse pointer, and window movement is still incredibly slow.

Here is the contents of my xorg.conf: (pastebin is a lifesaver)

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0

Section "Files"

Section "Module"

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:5:0"

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24

What driver? Exactly what file? How did you do this reinstall? Exactly what commands? In WHAT run level ? Before re-installing did you first remove the old fglrx before installing the new ??

The xorg.conf you provided suggests you did NOT follow the suggestions in the thread we linked to you. ie here: openSUSE Graphic Card Practical Theory Guide for Users - check out post#38 and #45

I can see no evidence of any attempt to try the possible fix in post#38 nor the one in post#45.

I’m not saying those work, because I have never encountered the problem you are experiencing, but some others have reported success using those, and I copied information from their posts to post#45.