Disappearing desktop, window manager and other madness...

What is it with OpenSUSE that doesn’t seem to work with me? I’ve tried 11.2 RC1, and thinking it was an RC problem (more like alpha if it is), I dropped back down to 11.1. Geeze, these are default installs from LiveCD and DVD.
I’ve tried it with 2 different desktops and a laptop. None have been very nice.
The desktops 1) Intel motherboard, 965 chipset, Core 2 Duo, 2) ECS motherboard, AMD 780 Chipset
The laptop? Thinkpad T61.

Even the most basic install doesn’t seem to take.
Whether with nVidia or ATI graphics, dual-monitor seems to be a bust. (I’ve learned to never install the ATI or nVidia drivers. Doing so kills everything)
One one desktop, dual-monitor would work, but it would lose it every time on re-boot and I have to re-apply every time.
One another trying to do turns everything black, requiring a reboot.
Sometimes the plasma bar will disappear. Not sure when it will decide to.

Network doesn’t fare much better. After applying some system updates (hey, it asked me to do so), sometimes network
gets lost. One I could manually restart eth0, the other it just disappears. Plus the stupid applet
on the plasma bar says it can’t handle the network settings because Network Manager is doing it. Network Manager is disavowing any responsibility as well.

The list seems to go on and on…
You’d think the Thinkpad should fare better, but it doesn’t seem to.

Is it me? Maybe. But how come it is that on all 3 machines, Ubuntu/Kubuntu have installed without a hitch from version 7 right on up to the latest 9.10
(I’m hardly a novice, I’ve been compiling Linux and installing it since RH 3 days. And my day job actually involves development in Linux).

OpenSUSE is the distro I want to love and use on my machine, but it sure isn’t doing itself any favours here…

Okay, so this may be just a ***** session and not very helpful, but at the least, I think that NOT ENOUGH testing is being done. Or if it is, nobody is fixing the bugs.

Ubuntu : It just works, more or less
OS X : It just works
eComStation (OS/2) : even this freakin’ old OS installed and configured without a hitch! (Yes, with Wireless, Firefox 3.5 and all).

=> Soapbox pease, thank you.

Moved to soapbox


As for dual monitor… stuff; I installed several different ATI drivers attempting to get my 3450 Radeon SAPPHIRE- HOME to work with the Gigabyte motherboard it was seated on(GIGABYTE - Product - Motherboard - Overview - GA-MA78GM-S2H (rev.1.1)). My experience with trying a release candidate was not a very happy one.

I understand your frustration and I know that pain. I couldn’t begin to detail the full comedy-horror story some of my associates experienced trying to get that hardware working with Kubuntu.

Following the above failures I simply ran home to: OpenSuSE 11.0.

OpenSuSE 11.0 still works fine with KDE 3.5.10, with what seems to me, to be very good support for dual monitors and multiple desktops. To make that work I"ve found that I “have” to install ATI/AMD drivers; if I want it to work properly. Finding the driver mix that works is the challenge. I don’t find that the latest drivers work from ATI; I never depend on them. You just have to install them… see what happens and then move up or down the driver food chain until you find the right mix.

11.2 RC2 seems to work fine with a current HP notebook we tossed it on. 11.1 almost worked with that computer also; to be honest and fair. That computer also ran OpenSuSE 11.0 fantastically.