Disabling unplugged eth0 makes wlan0 work????

I have recently installed suse 11.3 on both of my laptops. One a Durabook S14K and one an HP DV9000. Both have a wired (eth0) and a wireless (wlan0) network port built in.

The wireless cards are both up and working but…

I find that neither will transfer any data over the wireless connection unless I do ‘ifdown eth0’.

Is this normal?
Is there some setting that will make the machines auto-disable the eth0 i/f when no cable is plugged in? or can I disable the wired port at boot time by default.

I have no internet or lan access and attempting to ping my network printer by ip address ( gives me “destination host unreachable” unless I take the wired interface down. If I have done the ifdown, then everything works fine.

It is a Belkin router, DHCP on, WPA/PSK-TKIP.

Thanks in advance for your patience with a newbie!
Benster (pghben@yahoo.com)

Use the right startmode for your cards (at least for eth0), I prefer “ifplugd”.

That worked.

Perhaps that should be the default setting for wired connections?


The “default setting” is the use of NetworkManager, which automatically activates/deactivates devices on plugging/unpluggig the cable.

If somebody switches to ifup, he should know what he is doing (or at least read the help yast provides).

I apologize for my limited knowledge, I am making an effort to learn as much as I can as fast as I can.

I thought I had done pretty well to go from zero to finding and installing firmware and drivers and getting the network cards up and running without adding yet another thread to the “my wireless card doesn’t work” list.

Since you mentioned it, though…

I’d like to make a constructive suggestion to avoid people like me needing to ask more questions like I did.

I know I find it confusing that Network Manager is not called that in control center, but rather “Network Connections”

A quick read of the YaST warning window about ifup does not make it clear how to get to Network Manager’s settings, especially since it mentions Network Manager by that name, and there is no YaST or Control Center item by that name.

I thank you again for solving my problem and I hope that my suggestions about ways to improve the user experience could be implemented in order to help other new users.

I’m coming at this from the point of view of a reasonably intelligent, but very new user who is still stumbling around trying to find things and whose only interest is to get everything working quickly.

Just finding where everything is and what it does is the hardest part of adopting a new system. People who already have that knowledge sometimes don’t see that, despite the help messages they have built in, there can still be cues lying about that send the un-initiated off in the wrong direction.


I know I find it confusing that Network Manager is not called that in control center, but rather “Network Connections”

I must disagree for three very simple reasons.

  1. The Network Connections module includes more than only NetworkManager, so it would be misleading if you would rename it.

  2. In the tab for general options you see two radio buttons where you can choose between NetworkManager and ifup, there is also a very good help screen in that tab.

  3. The normal way (and it always was like this since openSUSE 10.2 on my installations) is, that NetworkManager is already active when you first boot into GUI after installation.
    You add your options for your connections (i.e. WPA-passphrase, ESSID …) into the NetworkManager applet and you are connected, you don’t even need to open YaST. If you don’t (want) to use NetworkManager you have to deactivate it deliberately, simply “doing nothing” in YaST is the easiest way to use NetworkManager.

I think that, had I had no problems getting the network cards to function, I might very well have headed down the intended path and never have stumbled off onto switching to ifup.

The problem is this - when you are one of the unlucky ones - and the automatic configuration fails to get your network hardware up and running, you go looking for settings/drivers/forums/etc. that can solve the problem and get you up and running.

If you are a soon-to-be-former windows user, you are used to going to “control panel” - you see “Control Center” and think, “oh so that’s what it’s called here” and that is right where you head. Near the top of the list is “Network Settings” Guess what you click?

Immediately when you open “Network Settings” a dialog pops up and says “Settings are controlled by network manager”, you click cancel and head off to find “network manager”

Look in “Control Center” - not there
Look in “YaST” - not there
Look in “more applications” - not there

HMMMMM, now you think - where do I go?

Hence my suggestions that:
1> there should be something in Control Center called “Network Manager” -or-
2> the warning dialog and help file in “Network Settings” should point you to “Network Connections” instead of “Network Manager”

I’m clearly not an expert here, and have no pretentions or aspirations of becoming one. I’m one of those “I just want it to work” types.

What I am trying to explain to you is how I wandered off into the experts-only-woods in my bare feet only two days into using suse, in hopes of keeping others from meeting the same fate.

p.s. follow me to the hardware forum for fun with a tv tuner card!

Yeah, that’s really typical for former windows users: “Popups with help error messages MUST be ignored”.

Let me show you:


An if you click on OK, this happens automatically.


And there you are.

If you are unsure, what this means, why not click “Help”-button?