Disabling screen blanking during youtube videos

Whenever i watch a yt video my screen blanks after about 4 minutes for all other intensive purposes i have it set to blank at 30 minutes. I’m running KDE 4.11.2 and SUSE 13.1 on a Dell Inspiron 15 Firefox 24. How do I disable screen Blanking During yt videos?

You cannot, other than disabling the screenlocker/power saving completely.
For that check “Configure Desktop”->“Display and Monitor”->“Screenlocker” and “Configure Desktop”->“Power Management”.

You can configure Power Management on a per Activity basis, though. So you could create an extra Activity for watching youtube videos and switch to it. I’m not sure if that also applies to the Screenlocker though.

This is most often a setting of the video player installed. I use Totem, normally associated with GNOME, but can be installed into KDE which I do. By default it is set to disable your screen saver when playing video. Consider installing it to see if it might help. Here is what I loaded:

http://paste.opensuse.org/view/download/99030212

Thank You,

Yes totem does, and VLC, Kaffeine, Xine and MPlayer (and all other Frontends to them that I didn’t mention, like SMPlayer f.e.) do that as well.

But flash-player does not, and the OP was asking about watching youtube videos in the browser.
Totem cannot be used to watch youtube videos, AFAIK…

Try this:
Create in new file in ~/bin, name it no_blanking.sh
Put the following two lines in


#!/bin/bash
xset s noblank -dpms

Next open a terminal window and do


chmod 755 ~/bin/no_blanking.sh

Add no_blanking.sh to KDE’s Autostart.
logout, login
Watch a ten minute yt vid.

Does the normal screen saver still work and its OK to run as a normal user?

Thank You,

Yes, silly me. I was thinking about iTunes Movie Trailers that does use Totem if loaded and where I found Totem to stop my screen save when going though lots of movie trailers. Thanks for setting me straight.

But that would have the same effect as just disabling it in KDE, wouldn’t it?
So he could just as well disable it in “Configure Desktop”…

I use a tray app called caffeine to manually toggle the screen saver but the “activate for Flash video” does not work flash. it’s a gtk app and works file in KDE though it tends to visually mess up the icons (at least it did in 12.3)

If you don’t mind watching YT vids in a non-browser uMplayer and sMplayer can browse and play YT vids and have a disable screen saver option

OK thanks. I missed the timer in power management I just increased it to longer than the normal yt video I watch. That’s a good enough fix for me, I appreciate the help guys.

Bump !

So, still no “fix” from preventing power-saving when watching videos with flash-player ? Other than disabling power-saving offcourse !

Well, ask Adobe to add support for inhibiting the power-saving in flash-player.
Good luck with that! :sarcastic:

But here’s a workaround: (haven’t tried it)
http://silviumc.wordpress.com/2011/12/05/how-to-stop-the-screen-saver-in-kde-while-watching-long-flash-clips-in-a-web-browser/

You could put that in a script and add an icon to your desktop that runs it, f.e.

I see someone has already mentioned this but you may have missed it.

The most effective way to prevent screen blanking when watching Flash video in the browser is to create a new activity. Then in the power management settings define the behaviour for that activity.
For me I set

Define Special Behaviour > Never Shut Down Screen
> Never suspend or shut-down the computer

Bump,
I can’t believe that after 2 years this issue is still here :smiley: Looks like opensuse coders are not so powerful as I thought :open_mouth:
And yes its kinda dumb to play around with power settings when windows, even android do it auto rotfl! pfff opensuse shame on you >:)

Well, it is a bug/missing feature in Flash-Player, not openSUSE, KDE, or Linux.
Nothing else than Flash-Player can know when a Flash video is played and powermanagement should be suspended.
And no, “opensuse coders” can change nothing in Flash-Player as this is closed-source, proprietary **** by Adobe (they even abandoned it themselves in the meantime).

And btw, the exact same problem does exist in Windows too (in Windows 7 at least).

I have posted a work-around already though, see my previous post. Then there’s caffeine, mentioned in this thread, too.
And kaffeinety seems to be another one:
http://software.opensuse.org/package/kaffeinety

Another note: All other (open source) media players I know offer the possibility to automatically suspend power management while playing a video.

Well I do understand this. I know that adobe is not interested in opensource world, same as all rest…
But I know that there are a lot of clever ‘opensuse coders’ who could find a workaround on this issue. It’s just after so many years its all the same.

Alright adobe is closed source, so what? It runs on opensource browsers, all of them these days have optional add-ons to install.
I can bet that somebody from opensuse team could actually code some handy add-on for us>:)
Depending on visited web page disable screen saver + put timer to keep system awake…
Simple and nice solution and no need to amend bloody power saving options all time…
Then put wiki on how to do things and here you go most users would be just happy…

Oh and I have never had any probs in win7;)

Hm?
Again, there are work-arounds.

Alright adobe is closed source, so what? It runs on opensource browsers, all of them these days have optional add-ons to install.

So what?
Nobody can look at the source code and change anything, e.g. add support for inhibiting power management like every media player has. That’s what.

I can bet that somebody from opensuse team could actually code some handy add-on for us>:)

Right. They just don’t do it because they want to annoy you.>:)
And the rest of the world as well.

What’s wrong about those tools like caffeine or kaffeinety? Why write another add-on which only works in one browser (yes there still are several different ones). I’m not sure whether such a thing that you want exactly is even possible, though.

Another question: Why haven’t you written one already?
Or anybody?
Don’t you think there’s a reason?

Or maybe just nobody (except you apparently) thinks this is important enough… :wink:

Oh and I have never had any probs in win7;)

In my experience with Windows 7, the screen saver kicked in every time I watch a Flash video. So I disabled it.

actually, it seems the behaviour you are after should be implemented by the browser.
Mozilla implemented this feature in Firefox 30 on Windows in July 2014 (just a few months ago) with a promise that other platforms were to follow.

see . . . https://bugzilla.mozilla.org/show_bug.cgi?id=517870

. . . even android do it auto rotfl! pfff opensuse shame on you >:)

really? Last I was aware Flash support had been dropped in Android altogether.

There really is nothing worse than inflammatory comments borne out of ignorance.

Ah, ok.
That explains why I saw this problem in Windows 7 (and he does not apparently) then.
Thanks for the pointer!

Would indeed be nice to have that on Linux as well, not only for Flash but HTML5 as well in particular (which is played back by the browser directly).
If I understand https://bugzilla.mozilla.org/show_bug.cgi?id=811261 (the followup bug for Linux) correctly, it should be part of Firefox 33… But I haven’t read all of the bug, only skimmed through it.

On Mon, 08 Sep 2014 01:06:02 +0000, farcusnz wrote:

> There really is nothing worse than inflammatory comments borne out of
> ignorance.

Guys, let’s keep it friendly. The old saying, “if you can’t say
something nice” applies (“neutral” is OK, too).

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C