Disabling Notebook Touchpad?

I have been using a small applet for the last couple of years to disable my touchpad. I got it off the Suse Forums.de site, IIRC.

However it does not work in 64 bit Open SUSE, nor in KDE 4.

Does anyone have any suggestions for permanently disabling my touchpad? (short of smashing it with a hammer) I never use it, and am essentially looking for a version of the applet that has been updated to work with 64 bit and KDE 4.

Thanks in advance for a simple solution!

hi, i think you were using the apps that i wrote ( also available here Disable - Enable Touchpad KDE-Apps.org )

I’m sorry, unfortunately i dont have any 64 bit system nor kde 4 to test so i cannot check out directly to find a solution (i believe its really simple) but as soon as i can find some infos around i will get back to you

You wrote that? That is the coolest little app! Thanks! I have used that thing every day for like two years or more.

Is there any way to keep the touchpad disabled after rebooting? I always forget to disable the pad again after a reboot.

Thanks for your reply!

Foresthill, could you please do some tests for me?
If, as a normal user, you give the command
man synclient
do you get any manual page or it says the command synclient is unknown?

Also, what is the output of the command
synclient -l
(-l for “list”) Could you paste the list that is given as output please?

That should give a hint for a solution. I think its just maybe a cap letter in the string that is the command or something like that

thanks in advance!

PS: if you want to disable the touchpad permanently, then follow these instructions:

Comment the following lines of /etc/X11/xorg.conf

#Section “InputDevice”

Driver “synaptics”

Identifier “Mouse[3]”

Option “Buttons” “5”

Option “Device” “/dev/input/mice”

Option “Emulate3Buttons” “on”

Option “InputFashion” “Mouse”

Option “Name” “Synaptics;Touchpad”

Option “Protocol” “explorerps/2”

Option “SHMConfig” “on”

Option “Vendor” “Sysp”

Option “ZAxisMapping” “4 5”

#EndSection

then restart X server

(from many sources, such as SuSELinuxSupport: How to disable a synaptic touchpad in a laptop )

The command yielded this:

Can't access shared memory area. SHMConfig disabled?

Modifying the xorg.conf file as shown did not work to disable the touchpad, even after a reboot. :frowning:

in the file /etc/X11/xorg.conf
check that you have the option (in the part "Section “InputDevice”):

** Option “SHMConfig” “on”**

Maybe you have it set on “off” for some reasons
If it was off, after modifying this, reboot before trying again

Here is the relevant section of my xorg.conf file:

Section "InputDevice"
  Driver       "synaptics"
  Identifier   "Mouse[3]"
  Option       "Device" "/dev/input/mice"
  Option       "Emulate3Buttons" "on"
Option		"Input Fashion" "mouse"
  Option       "Name" "Synaptics;Touchpad"
Option		"Protocol" "explorerps/2"
  Option       "SHMConfig" "on"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

With all due respect, I’m not a programmer, but just looking at that set up, I would expect the touchpad to continue to work, since there appears to be no command to disable it.

in the file /etc/X11/xorg.conf, the part to disable is normally the one pointed out above, that is
#Section “InputDevice”

Driver “synaptics”…

Your error message is a hint that something is wrong with some configuration settings.
What do you get if you give the command

syndaemon -d

Same “can’t access” message as I got in the post above.

I have to apologize here. My system is really trashed from automatic updates. Not only is my sound broken, but the SUSE automatic updater program itself, ironically, got broken by its own automatic updates.

And now this.

Plus my cursor is jumping all over the place as I try to type this because I can’t disable the touchpad.

I am just gonna reinstall and avoid auto updates this time. :frowning:

Well yes it sounds like the most convenient solution at this point. Would probably take a whole lot more to solve all those problems (even if would be a good way to learn something).
I always avoid automatic updates as well so i agree with that strategy
Hopefully your synaptics modules will work after reinstalling, good luck, post again if you still have problems