disabling automatic screen shutoff / make "xset s off" permanent

I’m trying to make “xset s off” permanent.

Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 600 cycle: 600

Where is the default value of “timeout: 600” set?

Section "Monitor"
  Identifier "LVDS0"
  Option "DPMS" "false"

Section "ServerLayout"
  Identifier "ServerLayout0"
  Option "StandbyTime" "0"
  Option "SuspendTime" "0"
  Option "OffTime"     "0"
  Option "BlankTime"   "0"


I tried adding that to /etc/X11/xorg.conf.d/50-monitor.conf (why 50 btw?)
but it didn’t seem to have any effect.
Is the “Identifier” value arbitrary, or does it need to be something specific?
I can’t find any information regarding what the value is supposed to be, or how to determine it.
I also tried “Default Monitor” as seen in the file’s comments.

Other people suggest simply adding “xset s off” to ~/.profile or ~/.xinitrc

If your using kde did you try start button settings-system settings- power management ?

What ever desktop you are using maybe totally in control of this sort of thing. Hence wayland arriving - good time to do it as x hardly does anything any more. That’s a quote.

I’m on kde leap and just disabled this there. Also need to do the same thing with lxde - if it has the facility.


I’m not sure if it’s still applicable, but I had always used a script file that I made to have KDE run at startup with the commands: xset dpms 0 0 0; xset -dpms

In earlier versions of openSUSE, xset would often misbehave and ignore desktop settings. The commands are run as a regular user so it should only be valid as long as you are logged in.

I just checked in 42.2 using xset -q and it seems that the KDE power manager settings are being followed correctly. My xset has DPMS turned off and all timeouts set to zero.

I’m using OpenBox.

Is it necessary to run mkinitrd after modifying 50-monitor.conf?

I handle it with the following script I created a few years back:

First, create a file with the following contents, give it a meaningfull name such as “noblankscreen” or something:

    xset dpms 0 0 0
    xset -dpms
    xset s noblank

Save it in /bin, set the permissions to rwxr-xr-x

Set it as a login script for each user you want to disable screen blanking for.

Log out, log back in, or reboot & log in.

Check to see that it all worked by opening a terminal and run:

xset q

You should see something similar to the following lines:

Screen Saver:
  prefer blanking:  no    allow exposures:  yes

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Disabled

BTW: It helps to go into the user settings (under Display and Monitor?), turn off any reference to Blank Screen and disable the automatic screensaver activation.

Then, if necessary, use the above script.

Note that, after each time you lock the screen, or hibernate, or sleep, you should drop to a terminal and invoke that script again.

xset s off

in **~/.profile **[FONT=arial]worked for Openbox.

With xfce:

Settings Manager -> Power Manager -> Display -> Blank after -> Never

xset s off

can also be placed in