Disabling a Dell Vostro 1520 Touchpad's Tap Funtion In KDE

For some reason, my touchpad is being recognized as a standard PS-02 Mouse, but tapping and scrolling still seems to work… trouble is, I have a disability that makes impossible for me to work with tapping enabled, and I can’t seem to find any way of doing so via GUI, or even via xorg.conf (already tried adding a Synaptics entry, as shown here: openSUSE Forums - View Single Post - Disable touchpad tapping (opensuse 11.2 gnome), but that had no effect whatsoever… so how can I fix this, before I either go insane, or inadvertently tap something that causes damage or loss of data?

kde is single click
where gnome is double click (More like windows)

You can enable double click in kde and you can also adjust the click interval so it is less likely to be done accidentally.

That link you quote is showing how the user added another mouse entry and set it as the default mouse. Is this what you have done?

I’ve already been through this with you… tried adding the entry, and it didn’t even show up to be set as a default, and removing the other entry resulted in KDE not loading. The double click setting has been enabled for a while, but that does very little good when the touchpad is continuously registering taps. If this (and my wireless issues) can’t be fixed soon, I’ll likely be looking for another distro to try, as this has to be the absolute least usable one I’ve tried yet!

This is not GUI, but it gets the job done.
Create a script file like below, and name it ‘tapoff’

synclient tapbutton1=0

Make this script executable:

$chmod 755 tapoff

Then, when you want to disable tapping, simply type:


I created the script in my account folder, chmoded it, and then ran it; and though it didn’t throw any error, my touchpad was still tapping… so I ran the script as root, but the results were the same! Any other ideas? :confused:

There has to be a way to fix this, and I can’t really even use my openSUSE installation until I get this fixed, so will somebody please tell me what I can possibly do to resolve this! >:(

to see a list of input devices and ensure that your touchpad is detected:
xinput list

find your configuration file:
sudo find / -name ‘11-x11-synaptics.fdi’

use a text editor on 11-x11-synaptics.fdi and make sure to include these lines in the middle if they are not already there to disable tapping:
<merge key=“input.x11_options.SHMConfig” type=“string”>true</merge>
<merge key=“input.x11_options.TapButton1” type=“string”>0</merge>
<merge key=“input.x11_options.TapButton2” type=“string”>0</merge>
<merge key=“input.x11_options.TapButton3” type=“string”>0</merge>

That did it! Thanks a million theopalmery!!!