Disable zypper metadata refresh

Zypper take a lot to refresh metadata. For example

"Initializing Target
Checking whether to refresh metadata for google-talkplugin
Retrieving: repomd.xml ...............................................................................[done (31 B/s)]
Checking whether to refresh metadata for libdvdcss
Retrieving: repomd.xml ........................................................................................[done]
Checking whether to refresh metadata for mozilla
Retrieving: repomd.xml ...............................................................................[done (70 B/s)]
Checking whether to refresh metadata for muzlocker
Retrieving: repomd.xml ...............................................................................[done (57 B/s)]
Checking whether to refresh metadata for packman
Retrieving: repomd.xml ........................................................................................[done]
Checking whether to refresh metadata for openSUSE-12.3-Non-Oss
Retrieving: content ..................................................................................[done (38 B/s)]
Retrieving: media .............................................................................................[done]
Checking whether to refresh metadata for openSUSE-12.3-Oss
Retrieving: content ..................................................................................[done (38 B/s)]
Retrieving: media .............................................................................................[done]"

Is there any command switch to disable it?

On 2013-05-13 18:16, editheraven wrote:
> Is there any command switch to disable it?

Yes, it is in the man page.

But it may not be advisable.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

change this

##
## Amount of time in minutes that must pass before another refresh.
##
## Valid values: Integer
## Default value: 10
##
## If you have autorefresh enabled for a repository, it is checked for
## up-to-date metadata not more often than every <repo.refresh.delay>
## minutes. If an automatic request for refresh comes before <repo.refresh.delay>
## minutes passed since the last check, the request is ignored.
##
## A value of 0 means the repository will always be checked. To get the oposite
## effect, disable autorefresh for your repositories.
##
## This option has no effect for repositories with autorefresh disabled, nor for
## user-requested refresh.
##
# repo.refresh.delay = 10

in

/etc/zypp/zypp.conf

Thanks. In fact, I found out that ipv6 was the one slowing those server connections. Thanks.