Disable touchpad tapping (opensuse 11.2 gnome)

Hello,

I’ve installed opensuse gnome on my Asus K40in laptop. This laptop has an elantech touchpad.

I want to disable tapping and going into hardware/mouse doesnt show a touchpad option…the old way was to edit xorg.conf but… it looks like this file isnt there anymore.

Google has pointed at this link (Elantech touchpad driver for Linux) where there seems to be an elantech driver for linux but for now, installing it goes beyond my enthousiast-newbie expertise…

Can someone help me on this?

Hi
No need, just use the Control Center->Mouse->Touchpad and check the
box.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 19:03, 2 users, load average: 0.37, 0.15, 0.11
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Thanks Malcom for your reply,

Actually, that was one of my points : the mouse menu shows no touchpad tab as it does on other laptops i’ve installed it on…

Is there a way to bring back that tab?

I admit that I don’t have 11.2 installed yet, but have you tried configuring your mouse model via YaST > Hardware > Mouse Model (assuming it still exists)?

Hi
Ahh ok, strange indeed. Can you look through dmesg and see if it sees
the touchpad?


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 22:27, 2 users, load average: 0.17, 0.15, 0.16
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Deano : well, it still exists but i see no touchpad choices…

Malcom : the only reference to a touchpad in the dmesg output is : “Registered led device: asus::touchpad”

Does this help? The touchpad does work but isnt clearly recognized by the system?

Deano : well, it still exists but i see no touchpad choices…

Oh, I see. Is it a synaptics touchpad? Take a look at this thread. There are some utilities available that can help with this.

Its not a synaptics touchpad, its an elantech (like on eeepc’s)

The thread you refer to deals with kde issues, and i’m on gnome.

However, some people are talking about passing some parameters in the startup script, maybe its a path to my solution?

The scipt suggested there is

#! /bin/sh
synclient MaxTapTime=0
synclient MaxDoubleTapTime=0

How could it be done in gnome?

Hi
Put the script in you ~/bin directory and make it executable (chmod
700), then add it to the startup applications in Control Center.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 1 day 13:03, 2 users, load average: 0.01, 0.07, 0.09
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

OK… Still no success…

Here is what I did

  1. created a script touchpad.sh in my ~/bin directory with the following content :
    #!/bin/bash
    sleep 10
    synclient MaxTapTime=0

  2. made it executable : sudo chmod 700 touchpad.sh

  3. added it to the startup applications in Control Center

  4. rebooted

  5. Touchpad tapping is still enabled…

Maybe I did something wrong?

Hi
Yup using sudo :slight_smile: check who owns the file now… if it’s owned by
root then;


sudo chown yourusername:users ~/bin/touchpad.sh

You should probably add the full path to the synclient binary
(/usr/bin?) as well and rename the file to just touchpad or mytouchpad


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 1 day 16:29, 2 users, load average: 0.19, 0.16, 0.18
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

File was effectively owned by root… so I did as you suggested Malcolm

Results? Touchpad tapping is still enabled…

Any other solution comes to your minds?

by the way, thanks for all this help…

Oh and I’ve tried installing touchfreeze so that at least touchpad is off when I type : here again, no effects… I type and touchpad is alive and tappin’

Hi
Ok, can you provide some more details, run;


hwinfo --mouse

I note on my netbook it too has the elantech device.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 1 day 22:41, 2 users, load average: 0.29, 0.32, 0.29
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Now that hal manages these devices, it may be necessary to have a look at the relevant fdi file in /use/share/hal/fid/policy/ and add/edit the required entries, similar to what is explained here:

How to write a customized fdi file for the Elantech touchpad » fedora-eee - Home for the Fedora Eee PC Kernel and More!

This Ubuntu HOWTO, describes the same approach (see Input Configuration with HAL section).

lshal will give you a list of devices with udi’s.

Wow thanks guys I will do my homework and try to apply whats there…

BUT, i ran into something that might be useful for you :

in the fedora-eee tutorial, they show all options, saying this list can be obtained but typing “synclient -l” in the console. I tried it and here is what I got :

synclient -l
“Couldn’t find synaptics properties. No synaptics driver loaded?”

I am an enthousiast linux user but still a newbie but… does this mean the drivers werent installed?

alright, I followed fedora-eee tutorial with no results.

Here are some extra info for the helping community :

hwinfo --mouse returns (note I use an external logitech usb mouse so that must be the reference) :

33: PS/2 00.0: 10500 PS/2 Mouse                                 
  [Created at input.183]
  UDI: /org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port_logicaldev_input
  Unique ID: AH6Q.oV6xZUCQFf1
  Hardware Class: mouse
  Model: "ImPS/2 Logitech Wheel Mouse"
  Vendor: 0x0002 
  Device: 0x0005 "ImPS/2 Logitech Wheel Mouse"
  Compatible to: int 0x0210 0x0013
  Device File: /dev/input/mice (/dev/input/mouse0)
  Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event1, /dev/char/13:65, /dev/input/by-path/platform-i8042-serio-4-event-mouse, /dev/char/13:32, /dev/input/by-path/platform-i8042-serio-4-mouse, /dev/char/13:63
  Device Number: char 13:63 (char 13:32)
  Driver Info #0:
    Buttons: 3
    Wheels: 1
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=no, avail=yes, need=no, active=unknown

lshal partial output where touchpad is mentionned :


udi = '/org/freedesktop/Hal/devices/leds_asus_touchpad'
  info.addons.singleton = {'hald-addon-leds'} (string list)
  info.capabilities = {'leds'} (string list)
  info.category = 'leds'  (string)
  info.interfaces = {'org.freedesktop.Hal.Device.Leds'} (string list)
  info.parent = '/org/freedesktop/Hal/devices/platform_asus_laptop'  (string)
  info.subsystem = 'leds'  (string)
  info.udi = '/org/freedesktop/Hal/devices/leds_asus_touchpad'  (string)
  leds.device_name = 'asus'  (string)
  leds.function = 'touchpad'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'leds'  (string)
  linux.sysfs_path = '/sys/devices/platform/asus_laptop/leds/asus::touchpad'  (string)

and here the “xinput list” output :

“Virtual core pointer” id=0 [XPointer]
Num_buttons is 32
Num_axes is 2
Mode is Relative
Motion_buffer is 256
Axis 0 :
Min_value is -1
Max_value is -1
Resolution is 0
Axis 1 :
Min_value is -1
Max_value is -1
Resolution is 0
“Virtual core keyboard” id=1 [XKeyboard]
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
“Asus Laptop extra buttons” id=2 [XExtensionKeyboard]
Type is KEYBOARD
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
“ImPS/2 Logitech Wheel Mouse” id=3 [XExtensionPointer]
Type is MOUSE
Num_buttons is 7
Num_axes is 2
Mode is Relative
Motion_buffer is 256
Axis 0 :
Min_value is -1
Max_value is -1
Resolution is 1
Axis 1 :
Min_value is -1
Max_value is -1
Resolution is 1
“AT Translated Set 2 keyboard” id=4 [XExtensionKeyboard]
Type is KEYBOARD
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
“CNF7129” id=5 [XExtensionKeyboard]
Type is KEYBOARD
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
“Sleep Button” id=6 [XExtensionKeyboard]
Type is KEYBOARD
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
“Power Button” id=7 [XExtensionKeyboard]
Type is KEYBOARD
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
“Video Bus” id=8 [XExtensionKeyboard]
Type is KEYBOARD
Num_keys is 248
Min_keycode is 8
Max_keycode is 255
“Power Button” id=9 [XExtensionKeyboard]
Type is KEYBOARD
Num_keys is 248
Min_keycode is 8
Max_keycode is 255

Hi
I get data for both an external mouse and the touchpad.

Can you check the BIOS for the touchpad configuration, also what
happens if you boot without the external mouse connected? Does the
touchpad work, do you see the touchpad tab in the Control Center
configuration.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 2 days 0:33, 2 users, load average: 0.18, 0.19, 0.18
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

BIOS : all I have is an “internal pointing device” that can be enabled/disabled - and its enabled

Touchpad does work with or without external mouse and there is no change whatsoever in the outputs, the touchpad tab is missing, etc…

What does ‘hwinfo --mouse’ output (if anything) when you don’t have any external mouse connected?

The synclient app comes from x11-input-synaptics package (in OSS repo for openSUSE 11/11.1), not sure about 11.2 though.

See if this yields anything further

lshal |grep touch -B 2 -A 14

although I am thinking your touchpad is not being detected correctly.

Ok… for your info, in order to eliminate potential problems, I’ve upgraded the BIOS (was a few months behind). However, this didnt change anything…

Here is the output :

~> lshal |grep touch -B 2 -A 14  
  platform.id = 'asus_laptop'  (string)

udi = '/org/freedesktop/Hal/devices/leds_asus_touchpad'
  info.addons.singleton = {'hald-addon-leds'} (string list)
  info.capabilities = {'leds'} (string list)
  info.category = 'leds'  (string)
  info.interfaces = {'org.freedesktop.Hal.Device.Leds'} (string list)
  info.parent = '/org/freedesktop/Hal/devices/platform_asus_laptop'  (string)
  info.subsystem = 'leds'  (string)
  info.udi = '/org/freedesktop/Hal/devices/leds_asus_touchpad'  (string)
  leds.device_name = 'asus'  (string)
  leds.function = 'touchpad'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'leds'  (string)
  linux.sysfs_path = '/sys/devices/platform/asus_laptop/leds/asus::touchpad'  (string)

udi = '/org/freedesktop/Hal/devices/platform_Fixed_MDIO_bus_0'
  info.parent = '/org/freedesktop/Hal/devices/computer'  (string)
  info.product = 'Platform Device (Fixed MDIO bus.0)'  (string)
  info.subsystem = 'platform'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_Fixed_MDIO_bus_0'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'platform'  (string)

Hope this helps…