Disable touchpad if a mouse is plugged in

This probably also applies to Tumbleweed, but it is in Leap 15.2 that I am seeing the issue.

For a long time, I have configured KDE to disable touchpad if a mouse is plugged in. It is in the touchpad settings (part of “Input devices”).

Computer 1: I try to configure that setting. And the setting is nowhere to be found. However, it still works. KDE on this computer was originally configured in Leap 15.1, where the setting was available. So it works, but I cannot configure it.

Computer 2: Here, when I go to that configuration, I can still find it (and it works). On this computer KDE was originally configured for Leap 15.0 (or perhaps earlier), and the setting remains and is still configurable. However, if I create a new user on this computer, and configure KDE from scratch, then the configuration is not available. If I then copy “.config/touchpadrc” from the user that works, then it starts working for this new user, but still doesn’t show in the configurations.

Is this setting being deprecated? Or is this a bug that I should report to kde.org?

This configuration option is the main reason that I switched to using KDE a few years ago. I would really hate to lose the option.

The kcm (system settings) module for the touchpad now uses “libinput” rather than “synaptics”. It currently doesn’t support all of the functions previously available. It’s not the only setting that’s been “lost”.

See also this bug report: 415364 – Implement feature to disable touchpad when mouse is plugged in when using Libinput driver

The KDE developers don’t see it as a bug per se, but the more users that (politely) complain, the better…

Thanks.

I will add my complaint to that bug report, sometime later today.

I have now posted my complaint to that bug report.

I’ll note that the bug report has been changed from “not a bug” to “confirmed” and the title has been changed to refer specifically to disabling touchpad if a mouse is plugged in.

It looks as if we might see some action on this.

Please note that, for KDE Bug Reports to be actioned in a timely fashion, one has to “vote” on the “Importance”.

Yes, hopefully sooner than later…

I’m not yet troubled by this issue, as my only machine with a trackpad is on leap 15.1, and I won’t be updating that to 15.2 until around the midpoint of the 15.2 lifecycle. Over the first few days of initial trackpad use I made quite a few tweaks to the settings until I was comfortable using the pad… I hope I’m able to retain those.

In the (KDE) bug report you wrote

Here’s a strange thing. On one laptop, I see the old touchpad settings screen. That laptop was originally configured with openSUSE Leap 15.0, then upgraded. However, if I create a new user on that same computer, then I get the new touchpad settings screen with some settings no longer visible.

That, sort of, goes along with Nate Graham’s comment from the same bug report

… If you want to see that interface (and regain the missing features), then you’ll need to replace Libinput with Synaptics. …

What I don’t understand at the moment is what governs whether the Libinput or Synaptics driver is used… or, more specifically, how to specify which driver to use.

In theory, perhaps… In practice I’ve not necessarily found that to be the case :wink:

I’m not sure about that either.

I also have Gnome installed. And it turns out that Gnome-Wayland uses libinput, while Gnome-X11 uses the synaptics driver. So I uninstalled the synaptics driver and locked it, to force Gnome-X11 to use libinput. The reason I can know that KDE was using libinput, was that the synaptics driver was not there at all.

On the laptop where you get the new touchpad settings screen with some settings no longer visible?

What happens if you install “xf86-input-synaptics”, is that alone sufficient to “restore” the former kcm_touchpad settings?

Edit:

OK… scrub that… I’ll go make a coffee…

you wrote “So I uninstalled the synaptics driver and locked it

No. And I say that, because the other laptop got the new settings screen, but with the synaptics driver still installed.

However, now that I have uninstalled the synaptics driver, I only get the new settings screen on both computers.

It is looking as if, when both drivers are installed, Plasma decides which to use based on existing settings. But I’m not sure which settings will trigger that change.

What I’m finding a bit strange is, that in an Oracle VirtualBox VM, regardless of whether on a Desktop or, this Laptop (with an Elantech Touchpad (Synaptics)), the Leap 15.2 Beta KDE Plasma System Settings still show the Touchpad tabs in the same fashion as that for Leap 15.1.

  • I couldn’t try to change the settings because, my initial test VM didn’t pass the Laptop’s Touchpad through to the VM – I’m reinstalling with the ICH9 Chipset activated …
  • The Desktop is just that, a Desktop – it doesn’t have a Touchpad but, the KDE Plasma System Settings Touchpad tabs were still there and, despite the warning that, no Touchpad was found, the “Enable/Disable Touchpad” tab was selectable and indicated that the “Disable touchpad when a mouse is plugged in” was still there.

FWIW, this blog is one of several I’ve found that describes how to create a simple udev rule to automatically disable a touchpad when an external pointing device is connected (and another rule to re-enable the touchpad when not connected to an external pointing device). It might serve a s a workaround while KDE gets its act together around this.

Thanks. That might be useful.

As for a wordaround in KDE, you can actually just use a text editor, and edit “$HOME/.config/touchpadrc” – or create that file if it doesn’t already exist.

What it needs, are these lines:


[autodisable]
DisableWhenMousePluggedIn=true


It’s good to know that the underlying desktop functionality is still there - just a ‘regression’ with the desktop GUI config then.

I meant to comment about the beginning of that blog article.

As best I can tell, the issue is for people who have learned to touch-type. A touch-typist keeps the hands very close the keyboard, so is frequently bumping the touchpad. By contrast, a “hunt and peck” typist tends to keep hands well above the keyboard, and does not run into this problem.

True, but usually I’d expect such users to enable ‘Disable touchpad when typing’ to prevent such issues?

The OP of the original kde bug report said the settings for “Sensitivity” were one of the ones lost upon the change to libinput.

I’ve changed that setting myself on this 15.1 install, it’s the “FingerHigh” and “FingerLow” settings in touchpadrc.

You could as a test try the touchpadrc I’m currently using, (with “xf86-input-synaptics” installed, obviously)

[autodisable]
DisableWhenMousePluggedIn=true

[parameters]
AccelFactor=0.0932965790666462
CircScrollDelta=5.73
FingerHigh=20
FingerLow=10
HorizEdgeScroll=true
HorizScrollDelta=2.9
HorizTwoFingerScroll=true
MaxDoubleTapTime=200
MaxSpeed=9.718179076522594
MaxTapMove=2.7
MaxTapTime=200
MinSpeed=0.615678058020243
RBCornerButton=MiddleButton
SingleTapTimeout=200
TapAndDragGesture=false
Tapping=false
VertEdgeScroll=true
VertScrollDelta=1.4

but I’d be quite surprised if that caused the original kcm_touchpad settings to appear, I think there’s more to it than that.

On the laptop where I got the new interface, I already had:


[autodisable]
DisableWhenMousePluggedIn=true

[parameters]
CircScrollDelta=5.73
MaxTapMove=4.4
Tapping=false
VertScrollDelta=2.5

That did not force using the synaptics driver. But then I notice that the power settings were also different between the two. There’s probably some setting for some input device that cause it to use the synaptics driver. But I don’t know what that is. I’m not about to try hunting down every related config file.

:slight_smile: Yes, I can relate to that.

You’ve resolved your disable trackpad when mouse is plugged in… so leave it at that.