Disable Nouveau during installation & after installation without installing Nvidia

Hi everyone! This is my first post in this forum.

I use an Optimus laptop with hybrid Intel and Nvidia graphic cards. My laptop (Thinkpad X1 Extreme) can’t disable dedicated graphic card in BIOS and only offers two modes: hybrid mode and dedicated graphic card mode. I’m on Tumbleweed Gnome using Wayland.

First issue. I have been using Tumbleweed for over a year and I just had a new installation (Tumbleweed 20210709) yesterday. In my previous installation there was an promote asking if you want to disable Nouveau at the final stage. It’s a very handy feature because I normally just use Intel without Noveau or Nvidia. I never want to use Nvidia due to the high battery consumption, occasional hiccups with kernel updates and incompatibility with Wayland. I also normally disable Noveau because it also uses a lot of battery for my laptop. However, the disabling Nouveau promote didn’t show up in my new installation as before and I had to manually disable Nouveau. Does anyone knows why the disabling Nouveau promote is gone? Is this a bug or intentional?

Second issue. Then I tried to manually disable Nouveau without installing Nvidia. Here is what I did:

  • Taboo Mesa-dri-nouveau and xf86-video-nouveau in Yast.
  • Create 50-blacklist.conf in /etc/modprobe.d and add the followings:
blacklist nouveau 

options nouveau modeset=0

sudo mkinitrd
  • Add the following kernel parameters via Yast Bootloader:
  • Reboot

But it seems Nouveau is still running on the background despite many attempts. My battery drains like crazy compared to my last installation in which Nouveau was disabled during installation. Could someone please help me disable Nouveau? Here are a few outputs:

lsmod | grep nouveau
sudo lsinitrd | grep nouveau 
[sudo] password for root:  
drwxr-xr-x   1 root     root            0 Jul  8 02:40 usr/lib/modules/5.13.0-1-default/kernel/drivers/gpu/drm/nouveau 
-rw-r--r--   1 root     root       753944 Jul  8 02:40 usr/lib/modules/5.13.0-1-default/kernel/drivers/gpu/drm/nouveau/nouveau.ko.xz

Have you tried nouveau.modeset=0 on kernel command line? If xf86-video-nouveau is installed, remove it. zypper al xf86-video-nouveau will prevent its return. In most cases, the newer technology default modesetting DIX driver works better. See here for more info.

Thanks for this. Yes I tried **nouveau.modeset=0 **before, but it didn’t do anything so I didn’t include in the kernel parameter. For the sake of testing, I added **nouveau.modeset=0 **again in kernel parameter together with modprobe.blacklist=nouveau, and the result is the same. Both **xf86-video-nouveau **and Mesa-dri-nouveau are not installed and tabooed in Yast as mentioned in the original post.

I will take a look at the link you provided.

Your lsmod result does not show nouveau so why do you think it is still running?!

I use a laptop with NVIDIA OPTIMUS as well. On my machine it is the switched-on NVIDIA-card that drains the battery. So i always install bbswitch which will switch-off the NVIDIA-card completely direct after boot and will switch it on on shutdown.



Thanks, because the battery drains really quick in my new installation compared to my old one. I also tried Nvidia once with the Intel mode (Nvidia wasn’t completely off) and it actually used less battery compared to Intel only and blacklisting Nouveau.

I’ll probably try bbswitch.

Does bbswitch only support 390 driver but not newer ones?

Well I installed the Nvidia driver (460) and suse-prime-bbswitch. Then I rebooted my laptop and switch to the Intel mode. **lsmod **said bbswitch already turned the Nvidia card off. No additional setup needed.

I wish Tumbleweed could bring the disabling Nouveau feature back in the future installation. Disabling Nouveau without installing Nvidia just mysteriously didn’t work for now.

No problem here:

Operating System: openSUSE Tumbleweed 20210714


# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev ff)


# cat /etc/modprobe.d/09-modprobe_nvidia_blacklist.conf

blacklist nvidia
blacklist nouveau


# cat /etc/modprobe.d/50-bbswitch.conf
options bbswitch load_state=0 unload_state=1

Modules loaded:

# lsmod | grep nouveau
# lsmod | grep nvidia
# lsmod | grep i915
i915                 2879488  30
i2c_algo_bit           16384  1 i915
video                  57344  1 i915
drm_kms_helper        290816  1 i915
cec                    61440  2 drm_kms_helper,i915
drm                   577536  11 drm_kms_helper,i915