Disable keyring Gnome openSUSE 13.1

Each time I boot my suse and owncloud desktop app is loaded I get prompted to insert a password in a dialog box from keyring app. Is there a way to disable this keyring app ? It looks similar to the one in KDE wich I managed to disable, but I don’t find it in the new Gnome 3.10.

Thanks !

Are you using gdm? The keyring should be unlocked automatically then on login.
If you want to use GNOME you should consider switching to gdm ATM, because some things don’t work otherwise, like “Lock Screen” f.e.

If you are using gdm, and the keyring is not unlocked automatically, try to run:

sudo /usr/sbin/pam-config -a --gnome_keyring --gnome_keyring-auto_start --gnome_keyring-only_if=gdm,gdm-password,lxdm,lightdm

and post errors you may get.
That line is normally run when “gnome-keyring-pam” is installed, so check if you have that, too, without it that won’t work of course.

If you want to have it unlocked with another login manager as well, run the same but omit the part starting with “–gnome_keyring-only_if”.

I do not know if it is possible to disable gnome-keyring alltogether, though.

A question regarding KDE:
Why did you disable kwallet? Just giving the wallet an empty password would prevent a password dialog as well and would let you use it comfortably. :wink:

I had a similar problem and raised this bug: