Disable faulty trackpoint on Wayland Gnome

Hey I literally just installed yesterday on a laptop I just got and today my trackpoint started randomly drifting non-stop and I’m having trouble finding a command to disable it.
My laptop is a Toshiba Portege Z30t-A if anyone need to know.
Can anyone help me?

Welcome to the forum!!

Log to plain vanilla X11 (vs Wayland) and see how that works.

Uhh I don’t know how to switch from Wayland to X11 on Gnome.
I wanted to try something new so i’ve never used Gnome before :upside_down_face:

You choose it at the login screen…

Ah sorry i set it to automatically login when i installed it, i had completely forgotten that most distros allow you to choose on the login screen

Logout

That should give you a login screen.

Choose Gnome-xorg on that login screen.

That will at least allow a one-time test. It may or may not permanently change your automatic login to Gnome-xorg. (I haven’t tested that recently).

Done that, hasn’t fixed it.
Edit: installed Xinput, listed input devices and manged to find it in the list and disabled it, thanks!