Disable Blueman on KDE

I have installed Blueman. But I want to disable it on KDE startup so that whenever I turn on my Bluetooth, blueman shouldn’t take over the KDE’s Bluedevil.

Please tell me how I can do so.

Remove the package (unless you really want to keep it):

zypper rm blueman

Check ~/.kde4/Autostart for links to this app.

I do not want to remove it as its very useful to connect to the Internet through the phone and many things that BlueDevil currently doesn’t support. So I simply want to remove it from the startup.

Does Blueman start as a Service?
Then you can disable the “Start on Boot” configuration through YAST

YAST > System > System Service(RunLevel) > Advanced


@tsu2 No, its not a service. It starts with KDE.

If it is not in ‘Autostart’, also make sure that its not simply starting because you have ‘Restore previous session’ in System Settings>>Startup and Shutdown>>Session Management.

I guess its associated with a KDE installation in /usr. I kill blueman before logout, but it still starts with every login.

Ok, I think I may have found how it gets loaded. Blueman is a gnome app, and at installation it creates a .desktop file called /etc/xdg/autostart/blueman.desktop. Have a look at this file with an editor and make sure that this entry


doesn’t contain KDE as well. Mine for reference:

[Desktop Entry]
GenericName=Bluetooth Manager applet
Name=Bluetooth Manager
Comment=Bluetooth Manager applet

FWIW, a similar approach can be used to autostart Gnome apps like nm-applet for those users running KDE4 (who don’t like the KDE equivalents).

Outlined here:

Kubuntu: knetworkmanager and kdebluetooth sucks! let’s use better tools « goshawk’s digital nest

Just to expand on potential Autostart folders, for those looking to enable or disable ‘auto-starting’ of particular apps. KDE checks these locations for .desktop files:


(Adjusted for openSUSE which uses .kde4 directory naming)


Autostart in KDE Linux | Sharpley.org.uk

KDE / GNOME autostart | LinuxPC.info

Hope this is helpful to others. :slight_smile:

Thanks a lot guys, your replies are definitely great! :slight_smile:

Your welcome. :slight_smile: