Direct rendering disabled when running Live CD without ACPI, and with ACPI it doesn't boot

I’m not sure if I should post this in Hardware or in Install/Boot/Login…

When I run OpenSUSE from the Live CD using normal settings, booting stops with a blank screen a moment after the kernel is loaded. When running it with ACPI disabled, it works, but direct rendering is disabled, even though it detects my video card (Mobility Radeon HD 5650) correctly :frowning: Here’s the Xorg.0.log file: my xorg log -

Is there a way to make it work?

I’ve just tried the Gnome 3 Live CD based on OpenSUSE and it’s working perfectly. It boots without having to disable ACPI, and direct rendering works. So it must be possible to make the regular OpenSUSE work too! :slight_smile:

I googled around the internet and found the “nomodeset” kernel parameter. When I use it, the Live CD boots with no problems, but direct rendering is disabled (exactly like when booting without ACPI) :frowning:

Just bumping this thread… OpenSUSE either doesn’t boot at all, or it boots but direct rendering is disabled. On the other hand, OpenSUSE Gnome 3 Live CD works perfectly well.