direct render works - sax2 meesed up - some 3d apps wont run

hello everyone.

it seems to me that every new year and every fresh linux installation gives me some headaches.

first of all i have an ibm thinkpad t30 with radeon mobility 7500

after the first attempts, glxinfo would give me this:

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2

and this:

OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 2.1 Mesa 7.3-devel

after installing and switching between opensuse 11.0, 11.1, fedora 10 and 11, nothing changed.

then after one installation of opensuse 11.0 glxinfo went ok (MESA DRI Radeon…) now glxgears gave the correct 1200 fps (opposed to the ~80 previous).

then i installed quake3 (tried ioquake3 too) from repository, copied the pak files and tried to run it, it just quits with this:

----- finished R_Init -----
------ Initializing Sound ------
Segmentation fault

note that on my last year install of opensuse 11.0 quake3 worked right after install (it works with wine from my win partition - latest point release)

another thing i noticed that the Bullet Physics sdk’s demos (i think it uses freeglut) work very slowly while on windows i have no problem with them

it seems that there is no problem with my card opengl-wise.

next weird thing comes from sax2:
it seems to ignore my xorg.conf.
and when i click on the option next to the radeon driver it shows the option but next to the XAANoOffscreenPixmaps it has this:
>>> 0x85807a0
instad of “true” which is in the xorg.conf
and when i click on it to modify, it just crashes the sax gui, and instantly quits

also i use the xorg.conf from my last year’s install (since it was 11.0 just like this one)

the opengl reliant parts of xscreensaver also seem to work without problem

i have nother problem with starcraft broodwar and its latest patch.
installed both original and expansion+ patch and slo copied the mpq files so it does not look after cd, but after running it, it just switches the desktop to 640x480 mode but does not show the game screen (i see the desktop with all the applications that were open before), but i can hear music, and if i move the mouse around i can click on the menus, etc.
if i tweak around in the wine registry to set direct3d for SC to opengl, after running the game, it shows the intro screen for half second then it goes green.

-blender for example works fine

any help would be really appreciated because i would like to be able to run quake3 and i also need opengl for my development.

thank you very much

ok the quake3 problem is gone after downloading ioquake3 from source, compiling it and it looks like it had problems with openAL because it was using the software driver so i installed the other one and now it works

but the other problems still persist