Direct output of microphone


I would like to plug my guitar on my pc and hear what I’m playing out of my headphones. I have not found out yet how I can enable direct output. Neither with Line-In, nor Mic-Input worked. Has anyone an idea how to enable it? KMix does not provide such a function as far as I know.

I’m using openSuse 11.2.

Best Regards


i’m not certain what the output of a Strat/etc is exactly…

it may not be enough power out to drive the electronics of the
microphone circuit (which is, i guess, the place you are plugging into
on your computer…or is there on your computer a guitar in jack??)

maybe there needs to be a pre-amp involved between the guitar and the

or maybe the guitar output is SO much that you have already burned out
the microphone input circuits…

CAVEAT: [posted via NNTP w/openSUSE 10.3]

You need to go from the preamp line out of your guitar amp to the line in of the linux box. If there is just the mic input be careful you don’t give it too much juice from the preamp. Additionally I think you might want to use jackd, with qjackctl to “hook up” (virtually, of course) the system line in to the system line out, though there are probably a lot of ways to do that.

You might also be able to get a usb audio interface for the usb port that would have an instrument in could work instead of a preamp, but that kind of solution is a little bit overkill for what you want.

Edit: there is practically no juice in a guitar cable, it’s just what gets generated by the magnets wrapped with the cord in the pickup–though I guess there are some new fangled battery powered pickups anymore, they still don’t have much, definitely not enough for any hope of your pc jack working on its own.

The thing to realize is that a guitar needs to connect to something with a high input impedance. This prevents loading down the pickup and losing signal voltage because the pickups just cant provide lots of current. (Ohm’s law)

If you don’t want to use the preamp out from your guitar amp (as Malcolm suggested), you will need to use a Direct Injection (DI) box between the guitar and the sound card.

In my view, you would get more satisfying results if you use an external sound interface (usb or firewire) which can offer you features such as balanced microphone (xlr) as well as high impedance inputs. Have a look at products from M-audio and Echo Audio.

On-board sound chips do not seem to work well with low latency. Latency can be thought of as the delay between when you strike a string on the guitar and when you actually hear the note from your computer speakers or headphones.

A simple but capable two-channel sound interface should not be too costly, and they are easy to source second-hand.

Using Jack, you can set up virtual effect racks, etc with quite acceptable latency.

Hope this adds something to your research.


Hello and thanks for your replies.
I connect my guitar to an effects processor and this processor to the line-in of my PC.
I suppose it has something to do with the settings of the mixer or something like that.
In windows it works, so it has nothing to do with the juice from the guitar.

Any ideas?

Thanks a lot.

How about showing us your mixer settings?

ie … What is output website/URL provided by running (with PC connected to Internet and PC configured the way you think should work):


There’s another thread going on with a related topic, have you tried using jackd? I would go ahead and install qjackctl using yast, which should bring in jack as a dependency (if it doesn’t then you’ll need jack also.) Start qjackctl, start the server with play, then click on connections, in the audio tab connect up “system” to “system”. That should play the mic-in through the speakers.

As an added bonus for you I would search for “ladspa” in the yast->software management, there is a program there called “jack-rack” and then there are a bunch of audio signal processing libraries that work as plugins for jack-rack (or another host), I know I saw some for guitar. You would just hook that into the virtual audio signal chain using qjackctl (there is a command line one that comes with jack too but it’s easier with a gui I think). I just put that stuff in last night after my building’s cutoff for making noise so I didn’t fiddle with it much, that’s for when I get off work in a few minutes ;), only I’ll be playing with a keyboard synth.

If you have a 5.1 sound output option, it should be turned off. It appears that 5.1 is incompatible with mic and probably line in. Kmix let a user select mutually exclusive options which seems to be regarded as an idiot user problem rather than the user interface design problem that it is.